aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-17 15:34:14 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-17 15:34:14 +0000
commit0286a22dbe6373e761b616d2ce657b6a06591f77 (patch)
treefb7ac5f81cac82f1c4de1df415a09bbdabcf9621 /audio
parent4f1fc936319a9ca84a7d65ab2c9e250a8eb19bea (diff)
downloadports-0286a22dbe6373e761b616d2ce657b6a06591f77.tar.gz
ports-0286a22dbe6373e761b616d2ce657b6a06591f77.zip
- Update to version 1.2.0
- Allow to build against Qt 5 instead of Qt 4 (off by default) - Add missing `desktop-file-utils' to USES as suggested by `stage-qa' - Remove INSTALLS_ICONS knob (not to be used for Qt-based programs) - Fix a typo and rephrase pkg-message text while I am at it
Notes
Notes: svn path=/head/; revision=397119
Diffstat (limited to 'audio')
-rw-r--r--audio/flacon/Makefile20
-rw-r--r--audio/flacon/distinfo4
-rw-r--r--audio/flacon/files/patch-CMakeLists.txt12
-rw-r--r--audio/flacon/pkg-message5
-rw-r--r--audio/flacon/pkg-plist5
5 files changed, 27 insertions, 19 deletions
diff --git a/audio/flacon/Makefile b/audio/flacon/Makefile
index b3f8245fe668..a09e15b37a0c 100644
--- a/audio/flacon/Makefile
+++ b/audio/flacon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= flacon
DISTVERSIONPREFIX= v
-DISTVERSION= 1.0.1
+DISTVERSION= 1.2.0
CATEGORIES= audio
MAINTAINER= danfe@FreeBSD.org
@@ -15,9 +15,19 @@ LIB_DEPENDS= libuchardet.so:${PORTSDIR}/textproc/uchardet
USE_GITHUB= yes
-USES= cmake pkgconfig
-USE_QT4= gui network \
- linguisttools_build moc_build qmake_build rcc_build uic_build
-INSTALLS_ICONS= yes
+USES= cmake desktop-file-utils pkgconfig
+
+OPTIONS_DEFINE= QT5
+QT5_DESC= Build against Qt 5 instead of Qt 4
+
+QT5_CMAKE_ARGS= -DUSE_QT5:BOOL=ON
+# :ts, would be handy here but is not available in fmake(1)
+QT5_USE= QT5=${_QT5_DEPS},${_QT5_BDEPS:C/,/_build&/g:%=_build}
+QT5_USE_OFF= QT4=${_QT4_DEPS},${_QT4_BDEPS:C/,/_build&/g:%=_build}
+
+_QT4_DEPS= gui,network
+_QT4_BDEPS= linguisttools,moc,qmake,rcc,uic
+_QT5_DEPS= gui,network,widgets
+_QT5_BDEPS= qmake,buildtools,linguisttools
.include <bsd.port.mk>
diff --git a/audio/flacon/distinfo b/audio/flacon/distinfo
index 846e458addd9..0e7ec5ebfe1c 100644
--- a/audio/flacon/distinfo
+++ b/audio/flacon/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flacon-flacon-v1.0.1_GH0.tar.gz) = 6a10ddf20d767aeb3ce0d6187f5b85c1a1cf64bfc42a0f827e0d5bd88b78977f
-SIZE (flacon-flacon-v1.0.1_GH0.tar.gz) = 245710
+SHA256 (flacon-flacon-v1.2.0_GH0.tar.gz) = 2ebc83d733ea6d50f2bd4ad8c20c65368be5eaf351e0195c9b4d47a54957b8f8
+SIZE (flacon-flacon-v1.2.0_GH0.tar.gz) = 283187
diff --git a/audio/flacon/files/patch-CMakeLists.txt b/audio/flacon/files/patch-CMakeLists.txt
index 1202aa60a8c5..a0170c6a7cee 100644
--- a/audio/flacon/files/patch-CMakeLists.txt
+++ b/audio/flacon/files/patch-CMakeLists.txt
@@ -1,14 +1,6 @@
---- CMakeLists.txt.orig 2014-08-19 17:05:30 UTC
+--- CMakeLists.txt.orig 2015-09-04 19:04:20 UTC
+++ CMakeLists.txt
-@@ -204,6 +204,7 @@ include(translations/translatorsinfo.cma
- create_translatorsinfo_qrc(TRANSLATORS_INFO_QRC translations)
- set(LIBRARIES ${LIBRARIES} ${UCHARDET_LIBRARIES})
- include_directories(${UCHARDET_INCLUDE_DIRS})
-+link_directories(${UCHARDET_LIBRARY_DIRS})
-
-
- add_executable(${PROJECT_NAME} ${HEADERS} ${SOURCES} ${MOC_SOURCES} ${QM_FILES} ${QRC_SOURCES} ${UI_HEADERS} ${ENGINES_CPP} ${ENGINES_H} ${TRANSLATORS_INFO_QRC})
-@@ -271,7 +272,7 @@ configure_file(
+@@ -348,7 +348,7 @@ configure_file(
add_custom_command(TARGET ${PROJECT_NAME}
COMMAND gzip -c ${CMAKE_CURRENT_BINARY_DIR}/flacon.1 > ${CMAKE_CURRENT_BINARY_DIR}/flacon.1.gz
)
diff --git a/audio/flacon/pkg-message b/audio/flacon/pkg-message
index 2eff0a5691c0..5ab277c99cf3 100644
--- a/audio/flacon/pkg-message
+++ b/audio/flacon/pkg-message
@@ -1,7 +1,8 @@
Flacon uses external programs to perform audio conversion. Install
- them manually, depending on your needs, from the following ports:
+ them manually, depending on your needs, from the following ports or
+ corresponding packages:
- autio/faac audio/flac
+ audio/faac audio/flac
audio/lame audio/mac
audio/mp3gain audio/shntool
audio/tta audio/vorbisgain
diff --git a/audio/flacon/pkg-plist b/audio/flacon/pkg-plist
index 35b9cf6cff13..d75d702ad3a5 100644
--- a/audio/flacon/pkg-plist
+++ b/audio/flacon/pkg-plist
@@ -13,11 +13,16 @@ share/icons/hicolor/48x48/apps/flacon.png
%%DATADIR%%/translations/flacon_gl.qm
%%DATADIR%%/translations/flacon_hu.qm
%%DATADIR%%/translations/flacon_it.qm
+%%DATADIR%%/translations/flacon_ja_JP.qm
+%%DATADIR%%/translations/flacon_lt.qm
%%DATADIR%%/translations/flacon_pl.qm
%%DATADIR%%/translations/flacon_pl_PL.qm
%%DATADIR%%/translations/flacon_pt_BR.qm
%%DATADIR%%/translations/flacon_pt_PT.qm
+%%DATADIR%%/translations/flacon_ro_RO.qm
%%DATADIR%%/translations/flacon_ru.qm
+%%DATADIR%%/translations/flacon_sr.qm
+%%DATADIR%%/translations/flacon_tr.qm
%%DATADIR%%/translations/flacon_uk.qm
%%DATADIR%%/translations/flacon_zh_CN.qm
%%DATADIR%%/translations/flacon_zh_TW.qm