aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2022-01-04 23:04:14 +0000
committerDiane Bruce <db@FreeBSD.org>2022-01-04 23:07:16 +0000
commit07060a51a4f3559cf4fdcb591b73cdb20a94e295 (patch)
treeb63843d15d1bcce9a44286c13d6359bc11bbab50 /audio
parent29c3e2e6e1de61d7811499849a3755aa5e40bbdb (diff)
downloadports-07060a51a4f3559cf4fdcb591b73cdb20a94e295.tar.gz
ports-07060a51a4f3559cf4fdcb591b73cdb20a94e295.zip
audio/codec2: missing patch
I thought I did the commit -a bump the PORTREVISION to make sure this gets rebuilt
Diffstat (limited to 'audio')
-rw-r--r--audio/codec2/Makefile1
-rw-r--r--audio/codec2/files/patch-unittest_CMakeLists.txt15
2 files changed, 16 insertions, 0 deletions
diff --git a/audio/codec2/Makefile b/audio/codec2/Makefile
index b06a9672ae5a..06f0a232a75e 100644
--- a/audio/codec2/Makefile
+++ b/audio/codec2/Makefile
@@ -1,6 +1,7 @@
PORTNAME= codec2
DISTVERSIONPREFIX=v
DISTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= audio hamradio
MAINTAINER= hamradio@FreeBSD.org
diff --git a/audio/codec2/files/patch-unittest_CMakeLists.txt b/audio/codec2/files/patch-unittest_CMakeLists.txt
new file mode 100644
index 000000000000..87d65febe48a
--- /dev/null
+++ b/audio/codec2/files/patch-unittest_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- unittest/CMakeLists.txt.orig 2022-01-04 12:38:05 UTC
++++ unittest/CMakeLists.txt
+@@ -97,6 +97,7 @@ target_link_libraries(t48_8 codec2)
+ add_executable(t48_8_short t48_8_short.c ../src/fdmdv.c ../src/kiss_fft.c)
+ target_link_libraries(t48_8_short codec2)
+
++if ( BUILD_CML)
+ # Build CML as part of unit test setup
+ find_program(OCTAVE_CMD octave-cli REQUIRED)
+ message("Octave command: ${OCTAVE_CMD}")
+@@ -122,3 +123,4 @@ add_custom_command(
+ OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/faster_fading_samples.float
+ COMMAND cd ${CMAKE_CURRENT_SOURCE_DIR} && ./fading_files.sh ${CMAKE_CURRENT_BINARY_DIR}
+ )
++endif()