aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-06-28 21:24:04 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-06-28 21:24:04 +0000
commit07771e3208810bd1f2a60666eec1eaf7710f0f0b (patch)
tree109208b385caeddb4b91d13ea0b018612a871592 /audio
parentd0b8e0bff8d29f51aae0f3bd778bf1b9844b6ee5 (diff)
downloadports-07771e3208810bd1f2a60666eec1eaf7710f0f0b.tar.gz
ports-07771e3208810bd1f2a60666eec1eaf7710f0f0b.zip
- Update to 0.7.0
- Move textproc/clucene from BUILD_DEPENDS to LIB_DEPENDS - Remove GH_TAGNAME - Add PORTVERSION to PLIST_SUB - Remove files/patch-src__libtomahawk__Source.cpp - Add files/patch-src__libtomahawk__sip__PeerInfo.cpp
Notes
Notes: svn path=/head/; revision=321989
Diffstat (limited to 'audio')
-rw-r--r--audio/tomahawk/Makefile10
-rw-r--r--audio/tomahawk/distinfo4
-rw-r--r--audio/tomahawk/files/patch-src__libtomahawk__Source.cpp11
-rw-r--r--audio/tomahawk/files/patch-src__libtomahawk__sip__PeerInfo.cpp11
-rw-r--r--audio/tomahawk/files/patch-src__main.cpp4
-rw-r--r--audio/tomahawk/pkg-plist334
6 files changed, 354 insertions, 20 deletions
diff --git a/audio/tomahawk/Makefile b/audio/tomahawk/Makefile
index 33a7ce36a25b..71243697c5dd 100644
--- a/audio/tomahawk/Makefile
+++ b/audio/tomahawk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tomahawk
-PORTVERSION= 0.6.1
+PORTVERSION= 0.7.0
#PORTREVISION= 0
CATEGORIES= audio
@@ -11,8 +11,8 @@ COMMENT= Multi-source, social, and smart music player
LICENSE= GPLv3
-BUILD_DEPENDS= clucene>=2.3.3.4:${PORTSDIR}/textproc/clucene
LIB_DEPENDS= attica:${PORTSDIR}/x11-toolkits/attica \
+ clucene-core:${PORTSDIR}/textproc/clucene \
boost_thread:${PORTSDIR}/devel/boost-libs \
echonest:${PORTSDIR}/audio/libechonest \
jreen:${PORTSDIR}/net-im/libjreen \
@@ -30,8 +30,7 @@ CMAKE_ARGS+= -DCMAKE_BUILD_TYPE:STRING="Release" \
GH_ACCOUNT= tomahawk-player
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= ${DISTVERSION}
-GH_COMMIT= ccb976a
+GH_COMMIT= 7a869ef
INSTALLS_ICONS= yes
@@ -42,7 +41,8 @@ OPTIONS_RADIO_PHONON= GSTREAMER VLC XINE
QTWEETLIB_DESC= Enable Twitter SIP plugin
VLC_DESC= Multimedia support for VLC
-PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
+PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,} \
+ PORTVERSION=${PORTVERSION}
USES= cmake pkgconfig
USE_GITHUB= yes
diff --git a/audio/tomahawk/distinfo b/audio/tomahawk/distinfo
index d6ca1979ad16..ed5e1141e2df 100644
--- a/audio/tomahawk/distinfo
+++ b/audio/tomahawk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tomahawk-0.6.1.tar.gz) = 587100b08e08507b96cc7d2fa165d7125037f0f9343715be4cfe5ece6ef87655
-SIZE (tomahawk-0.6.1.tar.gz) = 6432875
+SHA256 (tomahawk-0.7.0.tar.gz) = 2871c6fcdc88e0392051e62697c25494571b2a62b709782590f3d539723669a6
+SIZE (tomahawk-0.7.0.tar.gz) = 6520138
diff --git a/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp b/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
deleted file mode 100644
index 098ba3d6d6ef..000000000000
--- a/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/libtomahawk/Source.cpp.orig 2013-03-24 10:41:13.000000000 +0100
-+++ ./src/libtomahawk/Source.cpp 2013-04-29 22:46:47.000000000 +0200
-@@ -148,7 +148,7 @@
- m_avatar = new QPixmap( avatar );
- m_fancyAvatar = 0;
-
-- TomahawkUtils::Cache::instance()->putData( "Sources", 7776000000 /* 90 days */, m_username, ba );
-+ TomahawkUtils::Cache::instance()->putData( "Sources", Q_INT64_C(7776000000) /* 90 days */, m_username, ba );
- m_avatarUpdated = true;
- }
-
diff --git a/audio/tomahawk/files/patch-src__libtomahawk__sip__PeerInfo.cpp b/audio/tomahawk/files/patch-src__libtomahawk__sip__PeerInfo.cpp
new file mode 100644
index 000000000000..e4f0219ea3db
--- /dev/null
+++ b/audio/tomahawk/files/patch-src__libtomahawk__sip__PeerInfo.cpp
@@ -0,0 +1,11 @@
+--- ./src/libtomahawk/sip/PeerInfo.cpp.orig 2013-06-28 17:01:55.000000000 +0200
++++ ./src/libtomahawk/sip/PeerInfo.cpp 2013-06-28 17:02:45.000000000 +0200
+@@ -312,7 +312,7 @@
+ m_fancyAvatar = 0;
+
+ Q_ASSERT( !contactId().isEmpty() );
+- TomahawkUtils::Cache::instance()->putData( "Sources", 7776000000 /* 90 days */, contactId(), ba );
++ TomahawkUtils::Cache::instance()->putData( "Sources", Q_INT64_C(7776000000) /* 90 days */, contactId(), ba );
+ }
+
+
diff --git a/audio/tomahawk/files/patch-src__main.cpp b/audio/tomahawk/files/patch-src__main.cpp
index ac03be1230f3..3a1d5c952df7 100644
--- a/audio/tomahawk/files/patch-src__main.cpp
+++ b/audio/tomahawk/files/patch-src__main.cpp
@@ -1,5 +1,5 @@
---- ./src/main.cpp.orig 2013-03-24 10:41:13.000000000 +0100
-+++ ./src/main.cpp 2013-04-29 22:46:47.000000000 +0200
+--- ./src/main.cpp.orig 2013-06-28 17:15:02.000000000 +0200
++++ ./src/main.cpp 2013-06-28 17:15:16.000000000 +0200
@@ -34,8 +34,10 @@
#ifndef ENABLE_HEADLESS
diff --git a/audio/tomahawk/pkg-plist b/audio/tomahawk/pkg-plist
index 9073f0f8120a..18395ffc6181 100644
--- a/audio/tomahawk/pkg-plist
+++ b/audio/tomahawk/pkg-plist
@@ -1,5 +1,309 @@
@comment $FreeBSD$
bin/tomahawk
+include/libtomahawk/AclRegistry.h
+include/libtomahawk/ActionCollection.h
+include/libtomahawk/Album.h
+include/libtomahawk/AlbumPlaylistInterface.h
+include/libtomahawk/Artist.h
+include/libtomahawk/ArtistPlaylistInterface.h
+include/libtomahawk/AtticaManager.h
+include/libtomahawk/ContextMenu.h
+include/libtomahawk/CountryUtils.h
+include/libtomahawk/DllMacro.h
+include/libtomahawk/DropJob.h
+include/libtomahawk/EchonestCatalogSynchronizer.h
+include/libtomahawk/FuncTimeout.h
+include/libtomahawk/GlobalActionManager.h
+include/libtomahawk/HeadlessCheck.h
+include/libtomahawk/LatchManager.h
+include/libtomahawk/MetaPlaylistInterface.h
+include/libtomahawk/Pipeline.h
+include/libtomahawk/Playlist.h
+include/libtomahawk/PlaylistInterface.h
+include/libtomahawk/PlaylistPlaylistInterface.h
+include/libtomahawk/Query.h
+include/libtomahawk/Result.h
+include/libtomahawk/Source.h
+include/libtomahawk/SourceList.h
+include/libtomahawk/SourcePlaylistInterface.h
+include/libtomahawk/TomahawkPlugin.h
+include/libtomahawk/TomahawkSettings.h
+include/libtomahawk/TomahawkSettingsGui.h
+include/libtomahawk/TomahawkVersion.h
+include/libtomahawk/Typedefs.h
+include/libtomahawk/ViewManager.h
+include/libtomahawk/ViewPage.h
+include/libtomahawk/accounts/Account.h
+include/libtomahawk/accounts/AccountConfigWidget.h
+include/libtomahawk/accounts/AccountDelegate.h
+include/libtomahawk/accounts/AccountDllMacro.h
+include/libtomahawk/accounts/AccountFactoryWrapper.h
+include/libtomahawk/accounts/AccountFactoryWrapperDelegate.h
+include/libtomahawk/accounts/AccountManager.h
+include/libtomahawk/accounts/AccountModel.h
+include/libtomahawk/accounts/AccountModelFilterProxy.h
+include/libtomahawk/accounts/AccountModelNode.h
+include/libtomahawk/accounts/DelegateConfigWrapper.h
+include/libtomahawk/accounts/ResolverAccount.h
+include/libtomahawk/accounts/lastfm/LastFmAccount.h
+include/libtomahawk/accounts/lastfm/LastFmConfig.h
+include/libtomahawk/accounts/lastfm/LastFmInfoPlugin.h
+include/libtomahawk/accounts/spotify/SpotifyAccount.h
+include/libtomahawk/accounts/spotify/SpotifyAccountConfig.h
+include/libtomahawk/accounts/spotify/SpotifyInfoPlugin.h
+include/libtomahawk/accounts/spotify/SpotifyPlaylistUpdater.h
+include/libtomahawk/audio/AudioEngine.h
+include/libtomahawk/config.h
+include/libtomahawk/context/ContextPage.h
+include/libtomahawk/context/ContextWidget.h
+include/libtomahawk/context/pages/RelatedArtistsContext.h
+include/libtomahawk/context/pages/TopTracksContext.h
+include/libtomahawk/context/pages/WebContext.h
+include/libtomahawk/context/pages/WikipediaContext.h
+include/libtomahawk/database/Database.h
+include/libtomahawk/database/DatabaseCollection.h
+include/libtomahawk/database/DatabaseCommand.h
+include/libtomahawk/database/DatabaseCommandLoggable.h
+include/libtomahawk/database/DatabaseCommand_AddClientAuth.h
+include/libtomahawk/database/DatabaseCommand_AddFiles.h
+include/libtomahawk/database/DatabaseCommand_AddSource.h
+include/libtomahawk/database/DatabaseCommand_AllAlbums.h
+include/libtomahawk/database/DatabaseCommand_AllArtists.h
+include/libtomahawk/database/DatabaseCommand_AllTracks.h
+include/libtomahawk/database/DatabaseCommand_ClientAuthValid.h
+include/libtomahawk/database/DatabaseCommand_CollectionAttributes.h
+include/libtomahawk/database/DatabaseCommand_CollectionStats.h
+include/libtomahawk/database/DatabaseCommand_CreateDynamicPlaylist.h
+include/libtomahawk/database/DatabaseCommand_CreatePlaylist.h
+include/libtomahawk/database/DatabaseCommand_DeleteDynamicPlaylist.h
+include/libtomahawk/database/DatabaseCommand_DeleteFiles.h
+include/libtomahawk/database/DatabaseCommand_DeletePlaylist.h
+include/libtomahawk/database/DatabaseCommand_DirMtimes.h
+include/libtomahawk/database/DatabaseCommand_FileMTimes.h
+include/libtomahawk/database/DatabaseCommand_GenericSelect.h
+include/libtomahawk/database/DatabaseCommand_ImportPlaylist.h
+include/libtomahawk/database/DatabaseCommand_LoadAllAutoPlaylists.h
+include/libtomahawk/database/DatabaseCommand_LoadAllPlaylists.h
+include/libtomahawk/database/DatabaseCommand_LoadAllSortedPlaylists.h
+include/libtomahawk/database/DatabaseCommand_LoadAllSources.h
+include/libtomahawk/database/DatabaseCommand_LoadAllStations.h
+include/libtomahawk/database/DatabaseCommand_LoadDynamicPlaylist.h
+include/libtomahawk/database/DatabaseCommand_LoadDynamicPlaylistEntries.h
+include/libtomahawk/database/DatabaseCommand_LoadFiles.h
+include/libtomahawk/database/DatabaseCommand_LoadOps.h
+include/libtomahawk/database/DatabaseCommand_LoadPlaylistEntries.h
+include/libtomahawk/database/DatabaseCommand_LoadSocialActions.h
+include/libtomahawk/database/DatabaseCommand_LogPlayback.h
+include/libtomahawk/database/DatabaseCommand_ModifyPlaylist.h
+include/libtomahawk/database/DatabaseCommand_PlaybackCharts.h
+include/libtomahawk/database/DatabaseCommand_PlaybackHistory.h
+include/libtomahawk/database/DatabaseCommand_RenamePlaylist.h
+include/libtomahawk/database/DatabaseCommand_Resolve.h
+include/libtomahawk/database/DatabaseCommand_SetCollectionAttributes.h
+include/libtomahawk/database/DatabaseCommand_SetDynamicPlaylistRevision.h
+include/libtomahawk/database/DatabaseCommand_SetPlaylistRevision.h
+include/libtomahawk/database/DatabaseCommand_SetTrackAttributes.h
+include/libtomahawk/database/DatabaseCommand_SocialAction.h
+include/libtomahawk/database/DatabaseCommand_SourceOffline.h
+include/libtomahawk/database/DatabaseCommand_TrackAttributes.h
+include/libtomahawk/database/DatabaseCommand_TrackStats.h
+include/libtomahawk/database/DatabaseCommand_UpdateSearchIndex.h
+include/libtomahawk/database/DatabaseImpl.h
+include/libtomahawk/database/DatabaseResolver.h
+include/libtomahawk/database/DatabaseWorker.h
+include/libtomahawk/database/FuzzyIndex.h
+include/libtomahawk/database/IdThreadWorker.h
+include/libtomahawk/database/LocalCollection.h
+include/libtomahawk/database/Op.h
+include/libtomahawk/database/Schema.sql.h
+include/libtomahawk/database/TomahawkSqlQuery.h
+include/libtomahawk/filemetadata/MetadataEditor.h
+include/libtomahawk/filemetadata/MusicScanner.h
+include/libtomahawk/filemetadata/ScanManager.h
+include/libtomahawk/filemetadata/taghandlers/apetag.h
+include/libtomahawk/filemetadata/taghandlers/asftag.h
+include/libtomahawk/filemetadata/taghandlers/id3v1tag.h
+include/libtomahawk/filemetadata/taghandlers/id3v2tag.h
+include/libtomahawk/filemetadata/taghandlers/mp4tag.h
+include/libtomahawk/filemetadata/taghandlers/oggtag.h
+include/libtomahawk/filemetadata/taghandlers/tag.h
+include/libtomahawk/infobar/InfoBar.h
+include/libtomahawk/infosystem/InfoSystem.h
+include/libtomahawk/infosystem/InfoSystemCache.h
+include/libtomahawk/infosystem/InfoSystemWorker.h
+include/libtomahawk/jobview/AclJobItem.h
+include/libtomahawk/jobview/ErrorStatusMessage.h
+include/libtomahawk/jobview/IndexingJobItem.h
+include/libtomahawk/jobview/JobStatusDelegate.h
+include/libtomahawk/jobview/JobStatusItem.h
+include/libtomahawk/jobview/JobStatusModel.h
+include/libtomahawk/jobview/JobStatusView.h
+include/libtomahawk/jobview/LatchedStatusItem.h
+include/libtomahawk/jobview/PipelineStatusItem.h
+include/libtomahawk/jobview/TransferStatusItem.h
+include/libtomahawk/network/BufferIoDevice.h
+include/libtomahawk/network/Connection.h
+include/libtomahawk/network/ControlConnection.h
+include/libtomahawk/network/DbSyncConnection.h
+include/libtomahawk/network/Msg.h
+include/libtomahawk/network/MsgProcessor.h
+include/libtomahawk/network/PortFwdThread.h
+include/libtomahawk/network/RemoteCollection.h
+include/libtomahawk/network/Servent.h
+include/libtomahawk/network/StreamConnection.h
+include/libtomahawk/playlist/AlbumItemDelegate.h
+include/libtomahawk/playlist/AlbumModel.h
+include/libtomahawk/playlist/FlexibleHeader.h
+include/libtomahawk/playlist/FlexibleView.h
+include/libtomahawk/playlist/GridItemDelegate.h
+include/libtomahawk/playlist/GridView.h
+include/libtomahawk/playlist/LovedTracksModel.h
+include/libtomahawk/playlist/PlayableItem.h
+include/libtomahawk/playlist/PlayableModel.h
+include/libtomahawk/playlist/PlayableProxyModel.h
+include/libtomahawk/playlist/PlayableProxyModelPlaylistInterface.h
+include/libtomahawk/playlist/PlaylistChartItemDelegate.h
+include/libtomahawk/playlist/PlaylistItemDelegate.h
+include/libtomahawk/playlist/PlaylistLargeItemDelegate.h
+include/libtomahawk/playlist/PlaylistModel.h
+include/libtomahawk/playlist/PlaylistUpdaterInterface.h
+include/libtomahawk/playlist/PlaylistView.h
+include/libtomahawk/playlist/QueueProxyModel.h
+include/libtomahawk/playlist/QueueView.h
+include/libtomahawk/playlist/RecentlyAddedModel.h
+include/libtomahawk/playlist/RecentlyPlayedModel.h
+include/libtomahawk/playlist/SingleTrackPlaylistInterface.h
+include/libtomahawk/playlist/TrackView.h
+include/libtomahawk/playlist/TreeItemDelegate.h
+include/libtomahawk/playlist/TreeModel.h
+include/libtomahawk/playlist/TreeProxyModel.h
+include/libtomahawk/playlist/TreeProxyModelPlaylistInterface.h
+include/libtomahawk/playlist/TreeView.h
+include/libtomahawk/playlist/TreeWidget.h
+include/libtomahawk/playlist/ViewHeader.h
+include/libtomahawk/playlist/XspfUpdater.h
+include/libtomahawk/playlist/dynamic/DynamicControl.h
+include/libtomahawk/playlist/dynamic/DynamicModel.h
+include/libtomahawk/playlist/dynamic/DynamicPlaylist.h
+include/libtomahawk/playlist/dynamic/DynamicPlaylistRevision.h
+include/libtomahawk/playlist/dynamic/DynamicView.h
+include/libtomahawk/playlist/dynamic/GeneratorFactory.h
+include/libtomahawk/playlist/dynamic/GeneratorInterface.h
+include/libtomahawk/playlist/dynamic/database/DatabaseControl.h
+include/libtomahawk/playlist/dynamic/database/DatabaseGenerator.h
+include/libtomahawk/playlist/dynamic/echonest/EchonestControl.h
+include/libtomahawk/playlist/dynamic/echonest/EchonestGenerator.h
+include/libtomahawk/playlist/dynamic/echonest/EchonestSteerer.h
+include/libtomahawk/playlist/dynamic/widgets/CollapsibleControls.h
+include/libtomahawk/playlist/dynamic/widgets/DynamicControlList.h
+include/libtomahawk/playlist/dynamic/widgets/DynamicControlWrapper.h
+include/libtomahawk/playlist/dynamic/widgets/DynamicSetupWidget.h
+include/libtomahawk/playlist/dynamic/widgets/DynamicWidget.h
+include/libtomahawk/playlist/dynamic/widgets/MiscControlWidgets.h
+include/libtomahawk/playlist/dynamic/widgets/ReadOrWriteWidget.h
+include/libtomahawk/resolvers/ExternalResolver.h
+include/libtomahawk/resolvers/ExternalResolverGui.h
+include/libtomahawk/resolvers/QtScriptResolver.h
+include/libtomahawk/resolvers/Resolver.h
+include/libtomahawk/resolvers/ScriptCollection.h
+include/libtomahawk/resolvers/ScriptCommand.h
+include/libtomahawk/resolvers/ScriptCommandQueue.h
+include/libtomahawk/resolvers/ScriptCommand_AllAlbums.h
+include/libtomahawk/resolvers/ScriptCommand_AllArtists.h
+include/libtomahawk/resolvers/ScriptCommand_AllTracks.h
+include/libtomahawk/resolvers/ScriptResolver.h
+include/libtomahawk/sip/PeerInfo.h
+include/libtomahawk/sip/SipInfo.h
+include/libtomahawk/sip/SipPlugin.h
+include/libtomahawk/sip/SipStatusMessage.h
+include/libtomahawk/thirdparty/Qocoa/qbutton.h
+include/libtomahawk/thirdparty/Qocoa/qocoa_mac.h
+include/libtomahawk/thirdparty/Qocoa/qsearchfield.h
+include/libtomahawk/thirdparty/Qocoa/qtoolbartabdialog.h
+include/libtomahawk/thirdparty/kdsingleapplicationguard/kdlockedsharedmemorypointer.h
+include/libtomahawk/thirdparty/kdsingleapplicationguard/kdsharedmemorylocker.h
+include/libtomahawk/thirdparty/kdsingleapplicationguard/kdsingleapplicationguard.h
+include/libtomahawk/thirdparty/kdsingleapplicationguard/kdtoolsglobal.h
+include/libtomahawk/thirdparty/kdsingleapplicationguard/pimpl_ptr.h
+include/libtomahawk/utils/AnimatedSpinner.h
+include/libtomahawk/utils/BinaryExtractWorker.h
+include/libtomahawk/utils/BinaryInstallerHelper.h
+include/libtomahawk/utils/Closure.h
+include/libtomahawk/utils/DropJobNotifier.h
+include/libtomahawk/utils/ExfmParser.h
+include/libtomahawk/utils/GroovesharkParser.h
+include/libtomahawk/utils/GuiHelpers.h
+include/libtomahawk/utils/ImageRegistry.h
+include/libtomahawk/utils/ItunesParser.h
+include/libtomahawk/utils/JspfLoader.h
+include/libtomahawk/utils/Logger.h
+include/libtomahawk/utils/M3uLoader.h
+include/libtomahawk/utils/NetworkReply.h
+include/libtomahawk/utils/PixmapDelegateFader.h
+include/libtomahawk/utils/ProxyStyle.h
+include/libtomahawk/utils/Qnr_IoDeviceStream.h
+include/libtomahawk/utils/RdioParser.h
+include/libtomahawk/utils/SharedTimeLine.h
+include/libtomahawk/utils/ShortenedLinkParser.h
+include/libtomahawk/utils/SmartPointerList.h
+include/libtomahawk/utils/SoundcloudParser.h
+include/libtomahawk/utils/SpotifyParser.h
+include/libtomahawk/utils/StyleHelper.h
+include/libtomahawk/utils/TomahawkCache.h
+include/libtomahawk/utils/TomahawkUtils.h
+include/libtomahawk/utils/TomahawkUtilsGui.h
+include/libtomahawk/utils/TomahawkUtils_Mac.h
+include/libtomahawk/utils/WebResultHintChecker.h
+include/libtomahawk/utils/WidgetDragFilter.h
+include/libtomahawk/utils/XspfGenerator.h
+include/libtomahawk/utils/XspfLoader.h
+include/libtomahawk/widgets/AnimatedCounterLabel.h
+include/libtomahawk/widgets/AnimatedSplitter.h
+include/libtomahawk/widgets/BasicHeader.h
+include/libtomahawk/widgets/Breadcrumb.h
+include/libtomahawk/widgets/BreadcrumbButton.h
+include/libtomahawk/widgets/ChartDataLoader.h
+include/libtomahawk/widgets/CheckDirTree.h
+include/libtomahawk/widgets/ComboBox.h
+include/libtomahawk/widgets/ElidedLabel.h
+include/libtomahawk/widgets/FadingPixmap.h
+include/libtomahawk/widgets/FilterHeader.h
+include/libtomahawk/widgets/HeaderLabel.h
+include/libtomahawk/widgets/HeaderWidget.h
+include/libtomahawk/widgets/ImageButton.h
+include/libtomahawk/widgets/NewPlaylistWidget.h
+include/libtomahawk/widgets/NewReleasesWidget.h
+include/libtomahawk/widgets/OverlayButton.h
+include/libtomahawk/widgets/OverlayWidget.h
+include/libtomahawk/widgets/PlayableCover.h
+include/libtomahawk/widgets/PlaylistTypeSelectorDialog.h
+include/libtomahawk/widgets/QueryLabel.h
+include/libtomahawk/widgets/RecentPlaylistsModel.h
+include/libtomahawk/widgets/RecentlyPlayedPlaylistsModel.h
+include/libtomahawk/widgets/ScriptCollectionHeader.h
+include/libtomahawk/widgets/SearchWidget.h
+include/libtomahawk/widgets/SeekSlider.h
+include/libtomahawk/widgets/SocialPlaylistWidget.h
+include/libtomahawk/widgets/SourceTreePopupDialog.h
+include/libtomahawk/widgets/SourceTreePopupDialog_mac.h
+include/libtomahawk/widgets/ToggleButton.h
+include/libtomahawk/widgets/WelcomeWidget.h
+include/libtomahawk/widgets/WhatsHotWidget.h
+include/libtomahawk/widgets/infowidgets/AlbumInfoWidget.h
+include/libtomahawk/widgets/infowidgets/ArtistInfoWidget.h
+include/libtomahawk/widgets/infowidgets/SourceInfoWidget.h
+include/libtomahawk/widgets/infowidgets/TrackInfoWidget.h
+include/libtomahawk/widgets/searchlineedit/ClearButton.h
+include/libtomahawk/widgets/searchlineedit/LineEdit.h
+include/libtomahawk/widgets/searchlineedit/LineEdit_p.h
+include/libtomahawk/widgets/searchlineedit/SearchButton.h
+include/libtomahawk/widgets/searchlineedit/SearchLineEdit.h
+lib/cmake/Tomahawk/TomahawkAddPlugin.cmake
+lib/cmake/Tomahawk/TomahawkConfig.cmake
+lib/cmake/Tomahawk/TomahawkConfigVersion.cmake
+lib/cmake/Tomahawk/TomahawkLibraryDepends-release.cmake
+lib/cmake/Tomahawk/TomahawkLibraryDepends.cmake
+lib/cmake/Tomahawk/TomahawkUse.cmake
lib/libtomahawk_account_google.so
lib/libtomahawk_account_twitter.so
lib/libtomahawk_account_xmpp.so
@@ -17,6 +321,7 @@ lib/libtomahawk_infoplugin_rovi.so
lib/libtomahawk_infoplugin_spotify.so
lib/libtomahawk_portfwd.so
lib/libtomahawklib.so
+lib/libtomahawklib.so.%%PORTVERSION%%
libexec/tomahawk_crash_reporter
%%DESKTOPDIR%%/tomahawk.desktop
share/icons/hicolor/128x128-grayscale/apps/tomahawk.png
@@ -31,3 +336,32 @@ share/icons/hicolor/scalable/apps/tomahawk.svg
@dirrmtry share/icons/hicolor/128x128-grayscale
@dirrmtry share/icons/hicolor/512x512/apps
@dirrmtry share/icons/hicolor/512x512
+@dirrm lib/cmake/Tomahawk
+@dirrm include/libtomahawk/widgets/searchlineedit
+@dirrm include/libtomahawk/widgets/infowidgets
+@dirrm include/libtomahawk/widgets
+@dirrm include/libtomahawk/utils
+@dirrm include/libtomahawk/thirdparty/kdsingleapplicationguard
+@dirrm include/libtomahawk/thirdparty/Qocoa
+@dirrm include/libtomahawk/thirdparty
+@dirrm include/libtomahawk/sip
+@dirrm include/libtomahawk/resolvers
+@dirrm include/libtomahawk/playlist/dynamic/widgets
+@dirrm include/libtomahawk/playlist/dynamic/echonest
+@dirrm include/libtomahawk/playlist/dynamic/database
+@dirrm include/libtomahawk/playlist/dynamic
+@dirrm include/libtomahawk/playlist
+@dirrm include/libtomahawk/network
+@dirrm include/libtomahawk/jobview
+@dirrm include/libtomahawk/infosystem
+@dirrm include/libtomahawk/infobar
+@dirrm include/libtomahawk/filemetadata/taghandlers
+@dirrm include/libtomahawk/filemetadata
+@dirrm include/libtomahawk/database
+@dirrm include/libtomahawk/context/pages
+@dirrm include/libtomahawk/context
+@dirrm include/libtomahawk/audio
+@dirrm include/libtomahawk/accounts/spotify
+@dirrm include/libtomahawk/accounts/lastfm
+@dirrm include/libtomahawk/accounts
+@dirrm include/libtomahawk