aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-01 13:30:50 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-11-01 13:30:50 +0000
commit09e8de05c7b5230f7dfbc22f985ec39359be3780 (patch)
tree54a50ede85e62249a5edd2517eb16569dfe4e57e /audio
parent77eb461a6239d7e6b500abef9edd977fdfd662fe (diff)
downloadports-09e8de05c7b5230f7dfbc22f985ec39359be3780.tar.gz
ports-09e8de05c7b5230f7dfbc22f985ec39359be3780.zip
audio/mixxx*: don't use -march=native
Breaks runtime for package users.
Diffstat (limited to 'audio')
-rw-r--r--audio/mixxx/Makefile4
-rw-r--r--audio/mixxx22/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index 6c05d667cd70..6f4789bc34e0 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mixxx
DISTVERSION= 2.3.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MAINTAINER= acm@FreeBSD.org
@@ -47,7 +47,7 @@ USE_QT= buildtools concurrent core dbus gui linguisttools_build network \
CONFLICTS= mixxx22*
CMAKE_ARGS+= -DINSTALL_USER_UDEV_RULES:BOOL=OFF \
- -DOPTIMIZE:STRING=native \
+ -DOPTIMIZE:STRING=portable \
-DBATTERY:BOOL=OFF \
-DFAAD:BOOL=OFF \
-DMODPLUG:BOOL=ON \
diff --git a/audio/mixxx22/Makefile b/audio/mixxx22/Makefile
index 5750dbf9778c..5f7eb8480162 100644
--- a/audio/mixxx22/Makefile
+++ b/audio/mixxx22/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mixxx
DISTVERSIONPREFIX= release-
DISTVERSION= 2.2.4
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= audio
PKGNAMESUFFIX?= 22
@@ -45,7 +45,7 @@ USE_QT= buildtools concurrent core dbus gui network opengl script scripttools \
CONFLICTS= mixxx-*
MAKE_ARGS= qtdir="${PREFIX}" install_root="${PREFIX}" \
- build=release optimize=native ${GUI} battery=0 vamp=1 modplug=1 mad=1
+ build=release optimize=portable ${GUI} battery=0 vamp=1 modplug=1 mad=1
LATE_INSTALL_ARGS= --install-sandbox=${STAGEDIR}
GUI= qt5=1