aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-16 05:07:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-16 05:07:07 +0000
commit0f1cc5bd19306414164416d77fff724985ac1d91 (patch)
tree946255328bf2d037f81fc3881b26eea65c3803e6 /audio
parenta4444429a65156ae1aac41facd956f09b9afb6f1 (diff)
downloadports-0f1cc5bd19306414164416d77fff724985ac1d91.tar.gz
ports-0f1cc5bd19306414164416d77fff724985ac1d91.zip
Add a port of up-to-date implementation of the MPRIS protocol for DeaDBeeF
music player. Original MPRIS plugin (`audio/deadbeef-mpris-plugin') does not work anymore and seems to be orphaned. Original plugin supported MPRISv1 and MPRISv2; this plugin only supports version two. WWW: https://github.com/Serranya/deadbeef-mpris2-plugin
Notes
Notes: svn path=/head/; revision=401753
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/deadbeef-mpris2-plugin/Makefile26
-rw-r--r--audio/deadbeef-mpris2-plugin/distinfo2
-rw-r--r--audio/deadbeef-mpris2-plugin/pkg-descr16
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index d24dda605ce6..da39722e9ceb 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -96,6 +96,7 @@
SUBDIR += dcd
SUBDIR += deadbeef
SUBDIR += deadbeef-mpris-plugin
+ SUBDIR += deadbeef-mpris2-plugin
SUBDIR += decibel-audio-player
SUBDIR += deforaos-mixer
SUBDIR += dekagen
diff --git a/audio/deadbeef-mpris2-plugin/Makefile b/audio/deadbeef-mpris2-plugin/Makefile
new file mode 100644
index 000000000000..01a44c04c438
--- /dev/null
+++ b/audio/deadbeef-mpris2-plugin/Makefile
@@ -0,0 +1,26 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= deadbeef-mpris2-plugin
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.8
+CATEGORIES= audio
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= MPRIS protocol version 2 plugin for DeaDBeeF music player
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/include/deadbeef/deadbeef.h:${PORTSDIR}/audio/deadbeef
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_GITHUB= yes
+GH_ACCOUNT= Serranya
+
+USES= autoreconf libtool pkgconfig
+GNU_CONFIGURE= yes
+USE_GNOME= glib20
+
+PLIST_FILES= lib/deadbeef/mpris.so
+
+.include <bsd.port.mk>
diff --git a/audio/deadbeef-mpris2-plugin/distinfo b/audio/deadbeef-mpris2-plugin/distinfo
new file mode 100644
index 000000000000..625c0f25ffb3
--- /dev/null
+++ b/audio/deadbeef-mpris2-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Serranya-deadbeef-mpris2-plugin-v1.8_GH0.tar.gz) = c6601e2c1f83bfe5e76c859386fc47dad8f44508f10321dab357aa57bd82cec1
+SIZE (Serranya-deadbeef-mpris2-plugin-v1.8_GH0.tar.gz) = 9396
diff --git a/audio/deadbeef-mpris2-plugin/pkg-descr b/audio/deadbeef-mpris2-plugin/pkg-descr
new file mode 100644
index 000000000000..e1f55ff3108a
--- /dev/null
+++ b/audio/deadbeef-mpris2-plugin/pkg-descr
@@ -0,0 +1,16 @@
+This plugin aims to implement the MPRIS protocol for DeaDBeeF music player.
+
+The original MPRIS plugin for DeaDBeeF does not work anymore and seems to be
+orphaned. The original plugin supported MPRISv1 and MPRISv2. This plugin
+only supports version two.
+
+What is currently missing:
+
+ - The whole optional "org.mpris.MediaPlayer2.TrackList" interface
+ - The whole optional "org.mpris.MediaPlayer2.Playlists" interface
+ - The optional "Fullscreen" property of the org.mpris.MediaPlayer2
+ interface
+ - The optional "CanSetFullscreen" property of the org.mpris.MediaPlayer2
+ interface
+
+WWW: https://github.com/Serranya/deadbeef-mpris2-plugin