aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2017-05-07 12:17:28 +0000
committerThomas Zander <riggs@FreeBSD.org>2017-05-07 12:17:28 +0000
commit1d228dac640bf1892f0f71c70999b01f4a9f8877 (patch)
tree01e1748dba7188d2fda2fd76b9b6188939545550 /audio
parentb6a95622bb9f3a020d3d277f5c7ccf1971f5bd1d (diff)
downloadports-1d228dac640bf1892f0f71c70999b01f4a9f8877.tar.gz
ports-1d228dac640bf1892f0f71c70999b01f4a9f8877.zip
Fix library updating
Details: Apparently, clang optimises exceptions with __attribute__((pure)) more aggressively than gcc, causing mpd to not notice files removed from the library. This patch causes mpd to be built without the pure attribute. PR: 219048 Reported by: hideo@lastamericanempire.com
Notes
Notes: svn path=/head/; revision=440334
Diffstat (limited to 'audio')
-rw-r--r--audio/musicpd/Makefile2
-rw-r--r--audio/musicpd/files/patch-src_Compiler.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 034ecb2a17b3..5a0056a147cc 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= musicpd
PORTVERSION= 0.20.6
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio ipv6
MASTER_SITES= http://www.musicpd.org/download/mpd/${PORTVERSION:R}/
DISTNAME= mpd-${PORTVERSION}
diff --git a/audio/musicpd/files/patch-src_Compiler.h b/audio/musicpd/files/patch-src_Compiler.h
new file mode 100644
index 000000000000..9ab0cb052cec
--- /dev/null
+++ b/audio/musicpd/files/patch-src_Compiler.h
@@ -0,0 +1,11 @@
+--- src/Compiler.h.orig 2017-01-27 07:46:51 UTC
++++ src/Compiler.h
+@@ -86,7 +86,7 @@
+ #define gcc_noreturn __attribute__((noreturn))
+ #define gcc_packed __attribute__((packed))
+ #define gcc_printf(a,b) __attribute__((format(printf, a, b)))
+-#define gcc_pure __attribute__((pure))
++#define gcc_pure
+ #define gcc_sentinel __attribute__((sentinel))
+ #define gcc_unused __attribute__((unused))
+ #define gcc_warn_unused_result __attribute__((warn_unused_result))