aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 11:18:42 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-01-25 11:18:42 +0000
commit2c98da46a2a15ecc75eccdd99b590e0a9b402149 (patch)
tree3170d6d00b882c7662cb190d7fd132daa5dede63 /audio
parentccdec5f497dc2167a30bc74818689cb891a9978a (diff)
downloadports-2c98da46a2a15ecc75eccdd99b590e0a9b402149.tar.gz
ports-2c98da46a2a15ecc75eccdd99b590e0a9b402149.zip
Make dependency on linguisttools explicit
The binary found by the cmake configure to check for its availability found the 'wrapper' installed by misc/qtchooser, which was present always (in short: it was broken). An upcoming change will change the behaviour of qtchooser not to install links if the binaries are not present. PR: 243443 Reported by: antoine
Notes
Notes: svn path=/head/; revision=524026
Diffstat (limited to 'audio')
-rw-r--r--audio/drumkv1-lv2/Makefile3
-rw-r--r--audio/padthv1-lv2/Makefile3
-rw-r--r--audio/qmidictl/Makefile3
-rw-r--r--audio/samplv1-lv2/Makefile3
-rw-r--r--audio/synthv1-lv2/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/audio/drumkv1-lv2/Makefile b/audio/drumkv1-lv2/Makefile
index de2a59a056c6..003bc29f86d2 100644
--- a/audio/drumkv1-lv2/Makefile
+++ b/audio/drumkv1-lv2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= drumkv1
DISTVERSION= 0.9.11
+PORTREVISION= 1
CATEGORIES= audio multimedia
MASTER_SITES= SF
PKGNAMESUFFIX= -lv2
@@ -20,7 +21,7 @@ LIB_DEPENDS= libjack.so:audio/jack \
USES= compiler:c++11-lang gl gmake localbase:ldflags pkgconfig qt:5 shared-mime-info
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-alsa-midi
-USE_QT= core gui widgets xml buildtools_build qmake_build
+USE_QT= core gui widgets xml buildtools_build linguisttools_build qmake_build
USE_GL= gl
USE_LDCONFIG= yes
diff --git a/audio/padthv1-lv2/Makefile b/audio/padthv1-lv2/Makefile
index c97339bca88c..6e4ca09177e0 100644
--- a/audio/padthv1-lv2/Makefile
+++ b/audio/padthv1-lv2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= padthv1
DISTVERSIONPREFIX= ${PORTNAME}_
DISTVERSION= 0_9_11
+PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -23,7 +24,7 @@ GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= rncbc
USE_GL= gl
-USE_QT= core gui widgets xml buildtools_build qmake_build
+USE_QT= core gui widgets xml buildtools_build linguisttools_build qmake_build
CONFIGURE_ARGS= --disable-alsa-midi
diff --git a/audio/qmidictl/Makefile b/audio/qmidictl/Makefile
index 34859f22a90e..4d0dd92e7c79 100644
--- a/audio/qmidictl/Makefile
+++ b/audio/qmidictl/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qmidictl
DISTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF
@@ -13,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= compiler:c++11-lang gl gmake localbase pkgconfig qt:5
GNU_CONFIGURE= yes
-USE_QT= core gui widgets qmake_build buildtools_build
+USE_QT= core gui widgets qmake_build buildtools_build linguisttools_build
USE_GL= gl
BINARY_ALIAS= qmake=${QMAKE}
diff --git a/audio/samplv1-lv2/Makefile b/audio/samplv1-lv2/Makefile
index 6b5db9680f50..906adf9e0a35 100644
--- a/audio/samplv1-lv2/Makefile
+++ b/audio/samplv1-lv2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= samplv1
DISTVERSIONPREFIX= ${PORTNAME}_
DISTVERSION= 0_9_11
+PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -23,7 +24,7 @@ GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= rncbc
USE_GL= gl
-USE_QT= core gui widgets xml buildtools_build qmake_build
+USE_QT= core gui widgets xml buildtools_build linguisttools_build qmake_build
PLIST_SUB= SHL3=${PORTVERSION} SHL2=${PORTVERSION:R}
diff --git a/audio/synthv1-lv2/Makefile b/audio/synthv1-lv2/Makefile
index f686f590fb10..64d4b134b0e2 100644
--- a/audio/synthv1-lv2/Makefile
+++ b/audio/synthv1-lv2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= synthv1
DISTVERSIONPREFIX= ${PORTNAME}_
DISTVERSION= 0_9_11
+PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -22,7 +23,7 @@ GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= rncbc
USE_GL= gl
-USE_QT= core gui widgets xml buildtools_build qmake_build
+USE_QT= core gui widgets xml buildtools_build linguisttools_build qmake_build
PLIST_SUB= SHL3=${PORTVERSION} SHL2=${PORTVERSION:R}