aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-10-07 12:25:29 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-10-07 12:25:29 +0000
commit2d793ab9e3f104b8e9dd6e5fd33e907e7b831337 (patch)
treeb54069bdee092eb658aee4ce0b43c768d407899f /audio
parent044213c3d02d3efc0d599952b13ba3fee619d73e (diff)
downloadports-2d793ab9e3f104b8e9dd6e5fd33e907e7b831337.tar.gz
ports-2d793ab9e3f104b8e9dd6e5fd33e907e7b831337.zip
audio/decibel-audio-player: switch from py-imaging to py-pillow
- USES python With hat: python Approved by: portmgr (bdrewery, implicit)
Notes
Notes: svn path=/head/; revision=370318
Diffstat (limited to 'audio')
-rw-r--r--audio/decibel-audio-player/Makefile6
-rw-r--r--audio/decibel-audio-player/files/patch-src__modules__Covers.py20
2 files changed, 23 insertions, 3 deletions
diff --git a/audio/decibel-audio-player/Makefile b/audio/decibel-audio-player/Makefile
index 7d683d9b7277..3c99ac99412f 100644
--- a/audio/decibel-audio-player/Makefile
+++ b/audio/decibel-audio-player/Makefile
@@ -3,7 +3,7 @@
PORTNAME= decibel-audio-player
PORTVERSION= 1.08
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio multimedia gnome python
MASTER_SITES= http://decibel.silent-blade.org/uploads/Main/
@@ -15,7 +15,7 @@ RUN_DEPENDS= py*-dbus>=0.80:${PORTSDIR}/devel/py-dbus \
LICENSE= GPLv2
-USE_PYTHON= yes
+USES= python
USE_GNOME= pygnome2 pygtk2
USE_GSTREAMER= python good bad
USES= gmake gettext desktop-file-utils
@@ -33,7 +33,7 @@ EXTRAS_DESC= Extra dependencies for plugins
AUDIOCD_RUN_DEPENDS= cd-discid>=0.9:${PORTSDIR}/audio/cd-discid \
py*-cddb>=1.4:${PORTSDIR}/audio/py-cddb \
gstreamer-plugins-cdio>=0.10.16:${PORTSDIR}/sysutils/gstreamer-plugins-cdio
-EXTRAS_RUN_DEPENDS= py*-imaging>=1.1.6:${PORTSDIR}/graphics/py-imaging \
+EXTRAS_RUN_DEPENDS= py*-pillow>0:${PORTSDIR}/graphics/py-pillow \
py*-notify>=0.1.1:${PORTSDIR}/devel/py-notify
FLAC_USE= GSTREAMER=flac
MP3_USE= GSTREAMER=mp3
diff --git a/audio/decibel-audio-player/files/patch-src__modules__Covers.py b/audio/decibel-audio-player/files/patch-src__modules__Covers.py
new file mode 100644
index 000000000000..f0f7a137e3fd
--- /dev/null
+++ b/audio/decibel-audio-player/files/patch-src__modules__Covers.py
@@ -0,0 +1,20 @@
+--- src/modules/Covers.py.orig 2014-10-07 12:26:08 UTC
++++ src/modules/Covers.py
+@@ -124,7 +124,7 @@
+
+ def generateFullSizeCover(self, inFile, outFile, format):
+ """ Resize inFile if needed, and write it to outFile (outFile and inFile may be equal) """
+- import Image
++ from PIL import Image
+
+ try:
+ # Open the image
+@@ -144,7 +144,7 @@
+
+ def generateThumbnail(self, inFile, outFile, format):
+ """ Generate a thumbnail from inFile (e.g., resize it) and write it to outFile (outFile and inFile may be equal) """
+- import Image
++ from PIL import Image
+
+ try:
+ # Open the image