aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKenji Takefu <takefu@airport.fm>2022-03-01 08:01:11 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2022-03-01 15:32:02 +0000
commit3341ddfca4f9e59fb86c6519045d4c94adb13c02 (patch)
tree8989b5a8044ab4913b5fd3a096db527028886737 /audio
parent91d676d1c574542cdeae7a6e959d660362cb60aa (diff)
downloadports-3341ddfca4f9e59fb86c6519045d4c94adb13c02.tar.gz
ports-3341ddfca4f9e59fb86c6519045d4c94adb13c02.zip
audio/darkice: Delete libaacplus
* libaacplus has been abandoned * Add missing libogg dependency * Reporter becomes MAINTAINER PR: 262185 Reported by: takefu@airport.fm Reviewed by: decke@ koobs@
Diffstat (limited to 'audio')
-rw-r--r--audio/darkice/Makefile31
-rw-r--r--audio/darkice/files/darkice.in3
-rw-r--r--audio/darkice/files/pkg-message.in12
3 files changed, 22 insertions, 24 deletions
diff --git a/audio/darkice/Makefile b/audio/darkice/Makefile
index b14674926b84..dafa3f0cf218 100644
--- a/audio/darkice/Makefile
+++ b/audio/darkice/Makefile
@@ -2,53 +2,56 @@
PORTNAME= darkice
PORTVERSION= 1.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio net
MASTER_SITES= https://github.com/rafael2k/darkice/releases/download/v${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= takefu@airport.fm
COMMENT= IceCast, IceCast2, and ShoutCast live audio streamer
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lang pkgconfig
+USES= pkgconfig
USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-alsa
CONFIGURE_ENV= ac_cv_prog_acx_pthread_config=no
-
SUB_FILES= pkg-message
OPTIONS_DEFINE= JACK PULSEAUDIO
OPTIONS_DEFAULT= VORBIS
OPTIONS_MULTI= CODEC
-OPTIONS_MULTI_CODEC= AACPLUS FAAC LAME OPUS TWOLAME VORBIS
+OPTIONS_MULTI_CODEC= FAAC LAME OPUS TWOLAME VORBIS
-AACPLUS_DESC= AAC HEv2 and libsamplerate support
-AACPLUS_LIB_DEPENDS= libaacplus.so:audio/libaacplus \
- libsamplerate.so:audio/libsamplerate
-AACPLUS_CONFIGURE_ON= --with-aacplus --with-samplerate
-AACPLUS_CONFIGURE_OFF= --without-aacplus --without-samplerate
FAAC_LIB_DEPENDS= libfaac.so:audio/faac
FAAC_CONFIGURE_ON= --with-faac-prefix=${LOCALBASE}
FAAC_CONFIGURE_OFF= --without-faac
-JACK_LIB_DEPENDS= libjack.so:audio/jack
+JACK_LIB_DEPENDS= libjack.so:audio/jack\
+ libsamplerate.so:audio/libsamplerate
JACK_CONFIGURE_WITH= jack
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
LAME_CONFIGURE_ON= --with-lame-prefix=${LOCALBASE}
LAME_CONFIGURE_OFF= --without-lame
-OPUS_LIB_DEPENDS= libopus.so:audio/opus
+OPUS_LIB_DEPENDS= libopus.so:audio/opus\
+ libogg.so:audio/libogg
OPUS_CONFIGURE_WITH= opus
-PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio
+PULSEAUDIO_LIB_DEPENDS= libpulse-simple.so:audio/pulseaudio\
+ libsamplerate.so:audio/libsamplerate
PULSEAUDIO_CONFIGURE_WITH= pulseaudio
TWOLAME_LIB_DEPENDS= libtwolame.so:audio/twolame
TWOLAME_CONFIGURE_WITH= twolame
-VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
+VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis\
+ libogg.so:audio/libogg
VORBIS_CONFIGURE_WITH= vorbis
+SOURCE_URL= man/darkice.1 man/darkice.cfg.5 src/IceCast2.cpp src/main.cpp
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2 -pedantic||g' ${WRKSRC}/src/Makefile.in
+.for i in ${SOURCE_URL}
+ @${REINPLACE_CMD} -e 's|http://code.google.com/p/darkice/|http://darkice.org/|' ${WRKSRC}/${i}
+.endfor
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/audio/darkice/files/darkice.in b/audio/darkice/files/darkice.in
index 7008c51f1bba..37d4d61ee207 100644
--- a/audio/darkice/files/darkice.in
+++ b/audio/darkice/files/darkice.in
@@ -1,7 +1,8 @@
#!/bin/sh
# PROVIDE: darkice
-# REQUIRE: LOGIN
+# REQUIRE: DAEMON
+# BEFORE: LOGIN
# KEYWORD: SHUTDOWN
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
diff --git a/audio/darkice/files/pkg-message.in b/audio/darkice/files/pkg-message.in
index 6b2e5b95ab17..d5bdb51e263d 100644
--- a/audio/darkice/files/pkg-message.in
+++ b/audio/darkice/files/pkg-message.in
@@ -8,16 +8,10 @@ Please edit it according to your needs.
********************************************************************
-The darkice will *not* be started automatically. To allow it
-to start, put this line in /etc/rc.conf:
+In order to enable darkice Server service at startup and start it please run:
+# service darkice enable
+# service darkice start
-darkice_enable="YES"
-
-Then, it will be started on the next boot. If this line is already
-present, the client will be started now. Otherwise, edit
-/etc/rc.conf and execute this command:
-
- %%PREFIX%%/etc/rc.d/darkice start
EOM
}
]