aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2015-10-27 07:50:02 +0000
committerThomas Zander <riggs@FreeBSD.org>2015-10-27 07:50:02 +0000
commit3353965f4f3494ad728f53f67fe801100edbfeb2 (patch)
tree124130795b15fb308aac94c6f6eb7f2a69c33032 /audio
parentf0387992858af2073f1eb8c09896602e13f3abc0 (diff)
downloadports-3353965f4f3494ad728f53f67fe801100edbfeb2.tar.gz
ports-3353965f4f3494ad728f53f67fe801100edbfeb2.zip
Update to upstream version 6.06
PR: 203795 Submitted by: tkato432@yahoo.com
Notes
Notes: svn path=/head/; revision=400219
Diffstat (limited to 'audio')
-rw-r--r--audio/csound6/Makefile12
-rw-r--r--audio/csound6/distinfo4
-rw-r--r--audio/csound6/files/patch-Opcodes-urandom.c10
-rw-r--r--audio/csound6/pkg-plist2
4 files changed, 14 insertions, 14 deletions
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
index 5cb258fe4f2b..a3775942faf5 100644
--- a/audio/csound6/Makefile
+++ b/audio/csound6/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= csound
-PORTVERSION= 6.05
+PORTVERSION= 6.06
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION}
PKGNAMESUFFIX= 6
@@ -18,7 +18,8 @@ BUILD_DEPENDS= boost-libs>0:${PORTSDIR}/devel/boost-libs \
swig>2:${PORTSDIR}/devel/swig20 \
eigen>0:${PORTSDIR}/math/eigen3 \
gmm++>0:${PORTSDIR}/math/gmm++
-LIB_DEPENDS= libsndfile.so:${PORTSDIR}/audio/libsndfile
+LIB_DEPENDS= libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
+ libsndfile.so:${PORTSDIR}/audio/libsndfile
USES= bison cmake python:2
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
@@ -57,6 +58,7 @@ DSSI_LIB_DEPENDS= libdssialsacompat.so:${PORTSDIR}/audio/libdssialsacompat
DSSI_RUN_DEPENDS= dssi>0:${PORTSDIR}/audio/dssi
DSSI_CMAKE_OFF= -DBUILD_DSSI_OPCODES:BOOL=OFF
DSSI_CFLAGS= -isystem ${LOCALBASE}/include/dssi
+DSSI_PREVENTS= ALSA
FLTK_DESC= Build FLTK plugin and GUI
FLTK_LIB_DEPENDS= libfltk.so:${PORTSDIR}/x11-toolkits/fltk
FLTK_CMAKE_ON= -DBUILD_WINSOUND:BOOL=ON
@@ -131,10 +133,16 @@ post-patch:
@${REINPLACE_CMD} -e \
's| mixer)| csmixer)|' \
${WRKSRC}/util/CMakeLists.txt
+.for i in Engine/auxfd.c H/prototyp.h OOps/diskin2.c OOps/dumpf.c \
+ Opcodes/partials.c Top/csound.c
+ @${REINPLACE_CMD} -e \
+ 's|\([[:blank:]]fd\)\(close\)|\1__\2|' ${WRKSRC}/${i}
+.endfor
post-install:
@${LN} -sf libcsnd6.so.6.0 ${STAGEDIR}${PREFIX}/lib/libcsnd6.so.6
@${LN} -sf libcsound64.so.6.0 ${STAGEDIR}${PREFIX}/lib/libcsound64.so.6
+
post-install-FLTK-on:
@${LN} -sf libCsoundAC.so.6.0 ${STAGEDIR}${PREFIX}/lib/libCsoundAC.so.6
diff --git a/audio/csound6/distinfo b/audio/csound6/distinfo
index aeb6988857a5..0b92ba698b6e 100644
--- a/audio/csound6/distinfo
+++ b/audio/csound6/distinfo
@@ -1,2 +1,2 @@
-SHA256 (csound/Csound6.05.tar.gz) = 0d0ab4c1804265f4947e07c5e41ee72bc1a122b873bd77b9e7179f4c4db43a28
-SIZE (csound/Csound6.05.tar.gz) = 26208635
+SHA256 (csound/Csound6.06.tar.gz) = 03e6542d60eaffc9b4c5e81f36243e8872dedbe94c036adaa8e07c27938feb11
+SIZE (csound/Csound6.06.tar.gz) = 27232172
diff --git a/audio/csound6/files/patch-Opcodes-urandom.c b/audio/csound6/files/patch-Opcodes-urandom.c
deleted file mode 100644
index 8d6cd1efca52..000000000000
--- a/audio/csound6/files/patch-Opcodes-urandom.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- Opcodes/urandom.c.orig 2015-04-25 19:06:23 UTC
-+++ Opcodes/urandom.c
-@@ -22,7 +22,6 @@
- */
-
- #include "csdl.h"
--#include <ieee754.h>
-
- typedef struct {
- OPDS h;
diff --git a/audio/csound6/pkg-plist b/audio/csound6/pkg-plist
index 6268519154e3..af7398d52042 100644
--- a/audio/csound6/pkg-plist
+++ b/audio/csound6/pkg-plist
@@ -27,6 +27,7 @@ bin/scot
bin/scsort
bin/sdif2ad
bin/sndinfo
+bin/src_conv
bin/srconv
%%FLTK%%bin/winsound
include/csound/CppSound.hpp
@@ -70,6 +71,7 @@ lib/csound/plugins-6.0/libexciter.so
lib/csound/plugins-6.0/libfareygen.so
%%FLUIDSYNTH%%lib/csound/plugins-6.0/libfluidOpcodes.so
lib/csound/plugins-6.0/libfractalnoise.so
+lib/csound/plugins-6.0/libframebuffer.so
%%HDF5%%lib/csound/plugins-6.0/libhdf5.so
%%PNG%%lib/csound/plugins-6.0/libimage.so
lib/csound/plugins-6.0/libipmidi.so