aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2013-07-13 13:24:27 +0000
committerMark Felder <feld@FreeBSD.org>2013-07-13 13:24:27 +0000
commit33fc1368380eabf8dbe9f4b25238d6012a1a58e4 (patch)
tree3d6760e6fb352d98a952bd2bfe2bf42f1ef5b222 /audio
parent7867c10fd51bc6bd54ae6667887c5a0330ddfc52 (diff)
downloadports-33fc1368380eabf8dbe9f4b25238d6012a1a58e4.tar.gz
ports-33fc1368380eabf8dbe9f4b25238d6012a1a58e4.zip
Add py-discogs-client 1.1.1, python interface to Discogs website.
Notes
Notes: svn path=/head/; revision=322923
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-discogs-client/Makefile20
-rw-r--r--audio/py-discogs-client/distinfo2
-rw-r--r--audio/py-discogs-client/pkg-descr3
-rw-r--r--audio/py-discogs-client/pkg-plist1
5 files changed, 27 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 69c431ec6578..ea7eaca2e2ee 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -635,6 +635,7 @@
SUBDIR += py-pyacoustid
SUBDIR += py-pyaudio
SUBDIR += py-cddb
+ SUBDIR += py-discogs-client
SUBDIR += py-eyed3
SUBDIR += py-fastaudio
SUBDIR += py-id3
diff --git a/audio/py-discogs-client/Makefile b/audio/py-discogs-client/Makefile
new file mode 100644
index 000000000000..00bd08ab0c70
--- /dev/null
+++ b/audio/py-discogs-client/Makefile
@@ -0,0 +1,20 @@
+# Created by: Mark Felder <feld@feld.me>
+# $FreeBSD$
+
+PORTNAME= discogs-client
+PORTVERSION= 1.1.1
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@feld.me
+COMMENT= Python interface to Discogs website
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=1.0.0:${PORTSDIR}/www/py-requests
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+
+.include <bsd.port.mk>
diff --git a/audio/py-discogs-client/distinfo b/audio/py-discogs-client/distinfo
new file mode 100644
index 000000000000..20fc8795a7b2
--- /dev/null
+++ b/audio/py-discogs-client/distinfo
@@ -0,0 +1,2 @@
+SHA256 (discogs-client-1.1.1.tar.gz) = ea806ee9764674756777337d0061f629ba05aa1e9c08b7ad0408b8b84406dac2
+SIZE (discogs-client-1.1.1.tar.gz) = 3160
diff --git a/audio/py-discogs-client/pkg-descr b/audio/py-discogs-client/pkg-descr
new file mode 100644
index 000000000000..99a419d2525e
--- /dev/null
+++ b/audio/py-discogs-client/pkg-descr
@@ -0,0 +1,3 @@
+Official Python Client for the Discogs API
+
+WWW: https://github.com/discogs/discogs_client
diff --git a/audio/py-discogs-client/pkg-plist b/audio/py-discogs-client/pkg-plist
new file mode 100644
index 000000000000..f4a7e443d7c3
--- /dev/null
+++ b/audio/py-discogs-client/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/discogs_client-1.1.1-py2.7.egg