aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-14 20:12:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-14 20:12:55 +0000
commit65593a3386e15b70ba45e43b4926401f4626551a (patch)
tree6f159de0ef152e37b7a1d7a9e665b1d075bfb595 /audio
parent49d15089adcc00d288f83bc46c4a97a2f166b804 (diff)
downloadports-65593a3386e15b70ba45e43b4926401f4626551a.tar.gz
ports-65593a3386e15b70ba45e43b4926401f4626551a.zip
Add bmp-scrobbler, a Beep-Media-Player plugin for Audioscrobbler.com social
network. PR: ports/76252 Submitted by: Roman Bogorodskiy <bogorodskiy@inbox.ru>
Notes
Notes: svn path=/head/; revision=126452
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/bmp-scrobbler/Makefile31
-rw-r--r--audio/bmp-scrobbler/distinfo2
-rw-r--r--audio/bmp-scrobbler/pkg-descr5
-rw-r--r--audio/bmp-scrobbler/pkg-plist2
5 files changed, 41 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 08bc66dbd039..96978b3d3a50 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -36,6 +36,7 @@
SUBDIR += bladeenc
SUBDIR += blop
SUBDIR += bmp-faad
+ SUBDIR += bmp-scrobbler
SUBDIR += bmp-wma
SUBDIR += bonk
SUBDIR += boodler
diff --git a/audio/bmp-scrobbler/Makefile b/audio/bmp-scrobbler/Makefile
new file mode 100644
index 000000000000..4155fee7c88f
--- /dev/null
+++ b/audio/bmp-scrobbler/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: bmp-scrobbler
+# Date created: 01-14-2005
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+
+PORTNAME= bmp-scrobbler
+PORTVERSION= 0.3.6
+CATEGORIES= audio
+MASTER_SITES= http://static.audioscrobbler.com/plugins/
+DISTNAME= xmms-scrobbler-${PORTVERSION}
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= BMP plugin for Audioscrobbler.com
+
+LIB_DEPENDS= musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
+ beep.2:${PORTSDIR}/multimedia/beep-media-player \
+ curl.3:${PORTSDIR}/ftp/curl
+
+CONFIGURE_ARGS= --disable-xmms-plugin
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+USE_GMAKE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITH_APE)
+CONFIGURE_ARGS+= --enable-prefer-ape
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/bmp-scrobbler/distinfo b/audio/bmp-scrobbler/distinfo
new file mode 100644
index 000000000000..57cf7becc113
--- /dev/null
+++ b/audio/bmp-scrobbler/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-scrobbler-0.3.6.tar.bz2) = eb5b53815eb91f5294f76ca424369b7f
+SIZE (xmms-scrobbler-0.3.6.tar.bz2) = 338393
diff --git a/audio/bmp-scrobbler/pkg-descr b/audio/bmp-scrobbler/pkg-descr
new file mode 100644
index 000000000000..8fac6800b59c
--- /dev/null
+++ b/audio/bmp-scrobbler/pkg-descr
@@ -0,0 +1,5 @@
+This is a BMP Plugin which sends the Playlist data to
+audioscrobbler.com
+
+WWW: http://www.audioscrobbler.com
+Author: pipian@pipian.com
diff --git a/audio/bmp-scrobbler/pkg-plist b/audio/bmp-scrobbler/pkg-plist
new file mode 100644
index 000000000000..cf789cc2f2c7
--- /dev/null
+++ b/audio/bmp-scrobbler/pkg-plist
@@ -0,0 +1,2 @@
+lib/bmp/General/libbmp_scrobbler.so
+@unexec rmdir %D/lib/bmp/General 2> /dev/null || true