aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-29 12:30:30 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-29 12:30:30 +0000
commit803d412667d031a58499133fb5f1669a1b060410 (patch)
treec446e539fba3f850cd3fec4803c2327c10b05d85 /audio
parent47efe65491566c3c7cd48d9a29f33212940caa88 (diff)
downloadports-803d412667d031a58499133fb5f1669a1b060410.tar.gz
ports-803d412667d031a58499133fb5f1669a1b060410.zip
audio/cmus: Update to 2.8.0
Notes
Notes: svn path=/head/; revision=491556
Diffstat (limited to 'audio')
-rw-r--r--audio/cmus/Makefile19
-rw-r--r--audio/cmus/distinfo10
-rw-r--r--audio/cmus/files/patch-ip_ffmpeg.c15
-rw-r--r--audio/cmus/pkg-plist1
4 files changed, 12 insertions, 33 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 8c98274c829c..27bdf519da0e 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -3,14 +3,8 @@
PORTNAME= cmus
DISTVERSIONPREFIX= v
-DISTVERSION= 2.8.0-rc0
-PORTREVISION= 9
+DISTVERSION= 2.8.0
CATEGORIES= audio
-DIST_SUBDIR= cmus
-
-# Fixes for playback of 24-bit files with the sndio/OSS output plugins
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES= 6a85680.patch:-p1 0fb39d8.patch:-p1
MAINTAINER= tobik@FreeBSD.org
COMMENT= Console-based music player with really cool features
@@ -24,13 +18,16 @@ USE_GITHUB= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= prefix=${PREFIX} mandir=${MANPREFIX}/man \
exampledir=${EXAMPLESDIR}
-
# So the build does not use gcc for compiling ttman
CONFIGURE_ARGS+= HOSTCC=${CC}
# Verbose build makes it easier to spot problems
-MAKE_ARGS= V=2 ${MAKE_ARGS_${ARCH:U}}
-MAKE_ARGS_powerpc= COMPAT_LIBS="-latomic" # undefined reference to `__atomic_fetch_add_8'
+MAKE_ARGS= ICONV_CFLAGS="-I${ICONV_INCLUDE_PATH}" \
+ ICONV_LIBS="-L${ICONV_PREFIX}/lib ${ICONV_LIB}" \
+ ${MAKE_ARGS_${ARCH:U}} \
+ V=2
+# undefined reference to `__atomic_fetch_add_8'
+MAKE_ARGS_powerpc= COMPAT_LIBS="-latomic"
# Disable all configure options first. These will be overwritten by
# enabled port options later. The args to cmus' configure script
@@ -38,7 +35,7 @@ MAKE_ARGS_powerpc= COMPAT_LIBS="-latomic" # undefined reference to `__atomic_fet
# previous assignments. The options here appear in the same order as
# ${WRKSRC}/configure --help. Please keep it that way.
_CMUS_CONFIGURE_OPTS= AAC ALSA AO ARTS CDDB CDIO COREAUDIO CUE DISCID \
- FFMPEG FLAC JACK MAD MIKMOD MODPLUG MP4 MPC MPRIS OPUS OSS \
+ FFMPEG FLAC JACK MAD MIKMOD BASS MODPLUG MP4 MPC MPRIS OPUS OSS \
PULSE ROAR SAMPLERATE SNDIO SUN TREMOR VORBIS VTX WAVEOUT \
WAVPACK WAV
.for opt in ${_CMUS_CONFIGURE_OPTS}
diff --git a/audio/cmus/distinfo b/audio/cmus/distinfo
index 70cc78353f79..df95313a1d13 100644
--- a/audio/cmus/distinfo
+++ b/audio/cmus/distinfo
@@ -1,7 +1,3 @@
-TIMESTAMP = 1490271541
-SHA256 (cmus/cmus-cmus-v2.8.0-rc0_GH0.tar.gz) = b594087f16053f4db49e89d72b1c6dbb12e221373e806e62b3e97c327de1dac9
-SIZE (cmus/cmus-cmus-v2.8.0-rc0_GH0.tar.gz) = 315613
-SHA256 (cmus/6a85680.patch) = 504c3c792be330d0f7bfda2101c4d7a24bd94aa38761def5e58f91d6fe081778
-SIZE (cmus/6a85680.patch) = 3400
-SHA256 (cmus/0fb39d8.patch) = 6b35f6e4e1a4e78598c3b125a764e2975298189467c82e868e19c6569901e3f7
-SIZE (cmus/0fb39d8.patch) = 785
+TIMESTAMP = 1548755814
+SHA256 (cmus-cmus-v2.8.0_GH0.tar.gz) = 756ce2c6241b2104dc19097488225de559ac1802a175be0233cfb6fbc02f3bd2
+SIZE (cmus-cmus-v2.8.0_GH0.tar.gz) = 317243
diff --git a/audio/cmus/files/patch-ip_ffmpeg.c b/audio/cmus/files/patch-ip_ffmpeg.c
deleted file mode 100644
index 1d284089d5be..000000000000
--- a/audio/cmus/files/patch-ip_ffmpeg.c
+++ /dev/null
@@ -1,15 +0,0 @@
-https://github.com/cmus/cmus/commit/b595b8cd7fee
-
---- ip/ffmpeg.c.orig 2016-11-20 12:29:46 UTC
-+++ ip/ffmpeg.c
-@@ -252,8 +252,8 @@ static int ffmpeg_open(struct input_plugin_data *ip_da
- break;
- }
-
-- if (codec->capabilities & CODEC_CAP_TRUNCATED)
-- cc->flags |= CODEC_FLAG_TRUNCATED;
-+ if (codec->capabilities & AV_CODEC_CAP_TRUNCATED)
-+ cc->flags |= AV_CODEC_FLAG_TRUNCATED;
-
- #if (LIBAVCODEC_VERSION_INT < ((53<<16)+(8<<8)+0))
- if (avcodec_open(cc, codec) < 0) {
diff --git a/audio/cmus/pkg-plist b/audio/cmus/pkg-plist
index 0107bac04767..faf7b81c07b3 100644
--- a/audio/cmus/pkg-plist
+++ b/audio/cmus/pkg-plist
@@ -4,6 +4,7 @@
%%CUE%%lib/cmus/ip/cue.so
%%DATADIR%%/cyan.theme
%%DATADIR%%/default.theme
+%%DATADIR%%/dracula.theme
%%DATADIR%%/gray-88.theme
%%DATADIR%%/green-mono-88.theme
%%DATADIR%%/green.theme