aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-06 19:18:09 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-12-06 19:18:09 +0000
commit84263f126313f4632e66fecacbc5e0bb18835afe (patch)
treebf7b6a3ca4240119ff7964d3a534aa782b6cd6ff /audio
parent7585b74ac7d0148036f25476174cd0f4d1176174 (diff)
downloadports-84263f126313f4632e66fecacbc5e0bb18835afe.tar.gz
ports-84263f126313f4632e66fecacbc5e0bb18835afe.zip
o Update to 2.0.3
o Style fix: replace all spaces with tabs where appropriate o Add WITH_OPTMIZED_CFLAGS knob, build without any unless defined o Advertise WITH* options PR: 32139 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=51156
Diffstat (limited to 'audio')
-rw-r--r--audio/ecasound/Makefile29
-rw-r--r--audio/ecasound/distinfo2
-rw-r--r--audio/ecasound/files/extra-patch-configure.in-optimizations20
-rw-r--r--audio/ecasound/files/patch-kvutils:temporary_file_directory.cpp53
-rw-r--r--audio/ecasound/files/patch-libecasound:audioio-wave.h11
-rw-r--r--audio/ecasound/pkg-comment2
-rw-r--r--audio/ecasound/pkg-plist1
7 files changed, 110 insertions, 8 deletions
diff --git a/audio/ecasound/Makefile b/audio/ecasound/Makefile
index 20480e4a4b05..559fdc1a85db 100644
--- a/audio/ecasound/Makefile
+++ b/audio/ecasound/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ecasound
-PORTVERSION= 2.0.2
-PORTREVISION= 1
+PORTVERSION= 2.0.3
CATEGORIES= audio
MASTER_SITES= http://ecasound.seul.org/download/ \
${MASTER_SITE_SOURCEFORGE}
@@ -23,7 +22,7 @@ USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS+= --enable-sys-readline
-MAKE_ENV+= ${CONFIGURE_ENV}
+MAKE_ENV+= ${CONFIGURE_ENV}
.if defined(WITH_MPG123)
RUN_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
@@ -39,9 +38,9 @@ RUN_DEPENDS+= mikmod:${PORTSDIR}/audio/mikmod
.if defined(WITH_AUDIOFILE)
# very crappy hack to detect audiofile properly
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ CFLAGS="-I${LOCALBASE}/include ${CFLAGS}" \
CXXFLAGS="-I${LOCALBASE}/include ${CXXFLAGS}"
LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
.else
@@ -56,9 +55,27 @@ CONFIGURE_ARGS+= --disable-pyecasound
PLIST_SUB+= WITH_PYECASOUND="@comment "
#.endif
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-configure.in-optimizations
+.endif
+
MAN1= ecasound-iam.1 ecasound.1 ecatools.1
MAN5= ecasoundrc.5
+pre-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "You can enable additional compilation optimizations"
+ @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.endif
+.if !defined(WITH_AUDIOFILE)
+ @${ECHO_MSG} "You can enable AUDIOFILE support by defining WITH_AUDIOFILE."
+.endif
+
+post-patch:
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${PERL} -pi -e 's!-O2 -ffast-math!!' ${WRKSRC}/kvutils/Makefile.am
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/ecasound
diff --git a/audio/ecasound/distinfo b/audio/ecasound/distinfo
index bb866a06f594..e13f69c3b8c5 100644
--- a/audio/ecasound/distinfo
+++ b/audio/ecasound/distinfo
@@ -1 +1 @@
-MD5 (ecasound-2.0.2.tar.gz) = 33e42f52792bfebfe44b06879493631f
+MD5 (ecasound-2.0.3.tar.gz) = d5a696c869e3a68905086db3a2697382
diff --git a/audio/ecasound/files/extra-patch-configure.in-optimizations b/audio/ecasound/files/extra-patch-configure.in-optimizations
new file mode 100644
index 000000000000..292be49ecfc7
--- /dev/null
+++ b/audio/ecasound/files/extra-patch-configure.in-optimizations
@@ -0,0 +1,20 @@
+--- configure.in.orig Tue Dec 4 12:42:12 2001
++++ configure.in Tue Dec 4 12:42:51 2001
+@@ -74,7 +74,7 @@
+ dnl ---
+ dnl Set CXXFLAGS.
+ dnl ---
+-CXXFLAGS="-O2 -D_REENTRANT -DNDEBUG -ffast-math -fstrict-aliasing -funroll-loops"
++CXXFLAGS="-D_REENTRANT -DNDEBUG"
+ dnl CXXFLAGS="-O2 -D_REENTRANT -fomit-frame-pointer -finline-functions -ffast-math -funroll-loops -Wall -Wstrict-prototypes -pedantic -fstrict-aliasing"
+
+ dnl ------------------------------------------------------------------
+@@ -84,7 +84,7 @@
+ include_debug=yes)
+ AM_CONDITIONAL(INCLUDE_DEBUG, test x$include_debug = xyes)
+ if test x$include_debug = xyes; then
+-CXXFLAGS="-D_REENTRANT -g -Wall -Wstrict-prototypes -ffast-math"
++CXXFLAGS="-D_REENTRANT -g -Wall -Wstrict-prototypes"
+ dnl CXXFLAGS="-D_REENTRANT -DENABLE_DBC -g -Wall -Wstrict-prototypes -ffast-math"
+ dnl LDFLAGS="-pg -pedantic -funroll-loops"
+ fi
diff --git a/audio/ecasound/files/patch-kvutils:temporary_file_directory.cpp b/audio/ecasound/files/patch-kvutils:temporary_file_directory.cpp
new file mode 100644
index 000000000000..9079e5b475a4
--- /dev/null
+++ b/audio/ecasound/files/patch-kvutils:temporary_file_directory.cpp
@@ -0,0 +1,53 @@
+--- kvutils/temporary_file_directory.cpp.orig Thu Mar 22 15:08:28 2001
++++ kvutils/temporary_file_directory.cpp Sat Nov 24 09:22:36 2001
+@@ -64,7 +64,7 @@
+ }
+ }
+ else {
+-// cerr << "(kvutils) " << "mkdir(" << tdir_rep << ") failed" << endl;
++ cerr << "(kvutils) " << "mkdir(" << tdir_rep << ") failed" << endl;
+ valid_rep = false;
+ }
+ }
+@@ -97,32 +97,32 @@
+
+ if (statbuf.st_uid != geteuid()) {
+ valid_rep = false;
+-// cerr << "(kvutils) " << "st_uid doesn't match." << endl;
++ cerr << "(kvutils) " << "st_uid doesn't match." << endl;
+ }
+
+- if (statbuf.st_gid != getegid()) {
+- valid_rep = false;
+-// cerr << "(kvutils) " << "st_gid doesn't match." << endl;
+- }
++ //if (statbuf.st_gid != getegid()) {
++ //valid_rep = false;
++ //cerr << "(kvutils) " << "st_gid doesn't match." << endl;
++ //}
+
+ if (!S_ISDIR(statbuf.st_mode)) {
+ valid_rep = false;
+-// cerr << "(kvutils) " << "st_mode - not a directory." << endl;
++ cerr << "(kvutils) " << "st_mode - not a directory." << endl;
+ }
+
+ if (S_ISLNK(statbuf.st_mode)) {
+ valid_rep = false;
+-// cerr << "(kvutils) " << "st_mode - a symbolic link." << endl;
++ cerr << "(kvutils) " << "st_mode - a symbolic link." << endl;
+ }
+
+ if ((statbuf.st_mode & S_IRWXG) > 0) {
+ valid_rep = false;
+-// cerr << "(kvutils) " << "st_mode - group has access." << endl;
++ cerr << "(kvutils) " << "st_mode - group has access." << endl;
+ }
+
+ if ((statbuf.st_mode & S_IRWXO) > 0) {
+ valid_rep = false;
+-// cerr << "(kvutils) " << "st_mode - others have access." << endl;
++ cerr << "(kvutils) " << "st_mode - others have access." << endl;
+ }
+ }
+
diff --git a/audio/ecasound/files/patch-libecasound:audioio-wave.h b/audio/ecasound/files/patch-libecasound:audioio-wave.h
new file mode 100644
index 000000000000..7f27fe826099
--- /dev/null
+++ b/audio/ecasound/files/patch-libecasound:audioio-wave.h
@@ -0,0 +1,11 @@
+--- libecasound/audioio-wave.h.orig Sun Sep 23 10:50:32 2001
++++ libecasound/audioio-wave.h Sat Nov 24 09:22:36 2001
+@@ -3,7 +3,7 @@
+
+ #include <string>
+ #include <iostream>
+-#include <stdint.h>
++/* #include <stdint.h> */
+ #include <sys/types.h>
+
+ #include "audioio-types.h"
diff --git a/audio/ecasound/pkg-comment b/audio/ecasound/pkg-comment
index 3a64301b4b14..ecde0135bcc1 100644
--- a/audio/ecasound/pkg-comment
+++ b/audio/ecasound/pkg-comment
@@ -1 +1 @@
-Multitrack audio processing software package
+Multitrack audio processing software
diff --git a/audio/ecasound/pkg-plist b/audio/ecasound/pkg-plist
index 0fd2d8960fdd..cd976f1166e7 100644
--- a/audio/ecasound/pkg-plist
+++ b/audio/ecasound/pkg-plist
@@ -140,6 +140,7 @@ share/ecasound/generic_oscillators
%%PORTDOCS%%share/doc/ecasound/ecatools_manpage.html
%%PORTDOCS%%share/doc/ecasound/examples.html
%%PORTDOCS%%share/doc/ecasound/index.html
+%%PORTDOCS%%share/doc/ecasound/edi-list.txt
%%PORTDOCS%%share/doc/ecasound/programmers_guide/eci_doc.html
%%PORTDOCS%%share/doc/ecasound/programmers_guide/programmers_guide.html
%%PORTDOCS%%share/doc/ecasound/users_guide/users_guide.html