aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-12 22:50:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-05-13 14:24:16 +0000
commit864ec5fbb959dbadd463378ea4b65e1ea31cda41 (patch)
tree94d04e38969f710880f6fde50b848e91eb530ef7 /audio
parentbbc32cc1f8ee1b148b4f7279679f2e3a11b28cb1 (diff)
downloadports-864ec5fbb959dbadd463378ea4b65e1ea31cda41.tar.gz
ports-864ec5fbb959dbadd463378ea4b65e1ea31cda41.zip
audio/play: Unbreak on HEAD
- Add LICENSE NONE - Pet portclippy - Adopt port
Diffstat (limited to 'audio')
-rw-r--r--audio/play/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/audio/play/Makefile b/audio/play/Makefile
index 3a9732a8e630..978f9cf410d4 100644
--- a/audio/play/Makefile
+++ b/audio/play/Makefile
@@ -1,24 +1,33 @@
PORTNAME= play
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= PORTS_JP
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bofh@FreeBSD.org
COMMENT= Simple audio file player
-CONFLICTS= sox
+LICENSE= NONE
USES= uidfix
+
MAKE_ARGS= CFLAGS="${CFLAGS}" MANDIR="${PREFIX}/man/ja/man" BINDIR="${PREFIX}/bin"
# XXX PIE static libraries are not supported by base system /usr/share/mk
MAKE_ARGS+= WITHOUT_PIE=true
+CONFLICTS= sox
+
PLIST_FILES= bin/play man/ja/man1/play.1.gz
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400079
+CFLAGS+= -Wno-error=int-conversion
+.endif
+
post-patch:
-.for file in play_audio.c mixer_ctl.c encode_sun.c encode_riff.c speed.c
+.for file in play_audio.c mixer_ctl.c encode_sun.c speed.c
@${REINPLACE_CMD} '/soundcard\.h/s,machine,sys,' ${WRKSRC}/${file}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>