aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-05 13:58:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-02-05 13:58:57 +0000
commit87e080d1d9c8cb57ac556aef8af0a3811be9583d (patch)
tree6f8c1ece65690a60c11be5ace9ccf90adb0df038 /audio
parent964ea2eb7e686830f1e6aac5d7ac72241bc041a8 (diff)
downloadports-87e080d1d9c8cb57ac556aef8af0a3811be9583d.tar.gz
ports-87e080d1d9c8cb57ac556aef8af0a3811be9583d.zip
- Fix LICENSE
- Add LICENSE_FILE - Convert USE_SDL=yes to USE_SDL=sdl - Switch to options helpers - Remove leftover noop SDL(12) hack - Convert INSTALL+STRIP to more correct INSTALL_PROGRAM Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=492230
Diffstat (limited to 'audio')
-rw-r--r--audio/sidplayer/Makefile18
1 files changed, 6 insertions, 12 deletions
diff --git a/audio/sidplayer/Makefile b/audio/sidplayer/Makefile
index 5867fa2d3f10..54821e985bf0 100644
--- a/audio/sidplayer/Makefile
+++ b/audio/sidplayer/Makefile
@@ -12,27 +12,21 @@ DISTNAME= SIDPlayer-${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= C64 SID tune player
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
-USE_SDL= yes
+USE_SDL= sdl
GNU_CONFIGURE= yes
-SDLINCLUDEDIR= SDL
-
OPTIONS_DEFINE= DOCS
OPTIONS_SUB= yes
SUB_FILES= pkg-message
-post-patch:
- @${REINPLACE_CMD} -e 's|SDL/SDL_endian\.h|${SDLINCLUDEDIR}/SDL_endian\.h|' \
- ${WRKSRC}/src/main_sdl.cpp
-
do-install:
- ${INSTALL} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/PSID\ Demo/* ${STAGEDIR}${DOCSDIR}
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
-
.include <bsd.port.mk>