aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /audio
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadports-9346b215f04cc84bbb7125ff2fcf03978f859a21.tar.gz
ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Notes
Notes: svn path=/head/; revision=301539
Diffstat (limited to 'audio')
-rw-r--r--audio/ardour/Makefile4
-rw-r--r--audio/gogglesmm/Makefile2
-rw-r--r--audio/libbs2b/Makefile2
-rw-r--r--audio/libmtp/Makefile3
-rw-r--r--audio/libsidplay2/Makefile3
-rw-r--r--audio/lv2core/Makefile3
-rw-r--r--audio/opus-tools/Makefile3
-rw-r--r--audio/sidplay2/Makefile1
-rw-r--r--audio/slv2/Makefile4
9 files changed, 12 insertions, 13 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index ba4bb5037336..6bb54065382a 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -98,7 +98,9 @@ SCONS_ENV+= FPU_OPTIMIZATION=0
CFLAGS:= ${CFLAGS:N-fno-strict-aliasing}
post-patch:
- ${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|g" ${WRKSRC}/SConstruct
+ ${REINPLACE_CMD} -e "s|%%CFLAGS%%|${CFLAGS}|g" \
+ -e "s|soundtouch-1.4|soundtouch-1.6|g" \
+ ${WRKSRC}/SConstruct
${REINPLACE_CMD} -e "s|alsa_pcm|oss|g" ${WRKSRC}/templates/*.template
post-install:
diff --git a/audio/gogglesmm/Makefile b/audio/gogglesmm/Makefile
index 6b2afc5c30df..5fef9cfdd9b3 100644
--- a/audio/gogglesmm/Makefile
+++ b/audio/gogglesmm/Makefile
@@ -16,7 +16,6 @@ COMMENT= Music collection manager and player
LICENSE= GPLv3
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine \
tag.1:${PORTSDIR}/audio/taglib \
sqlite3.8:${PORTSDIR}/databases/sqlite3
@@ -35,6 +34,7 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --mandir=${PREFIX}/man --prefix=${PREFIX}
MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
+USE_PKGCONFIG= yes
USE_XZ= yes
INSTALLS_ICONS= yes
MAN1= gogglesmm.1
diff --git a/audio/libbs2b/Makefile b/audio/libbs2b/Makefile
index b9d15d2328f9..38a13f51418e 100644
--- a/audio/libbs2b/Makefile
+++ b/audio/libbs2b/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= SF/bs2b/bs2b/${PORTVERSION}
MAINTAINER= liangtai.s4@gmail.com
COMMENT= Bauer Stereophonic-to-Binaural DSP
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile \
ogg:${PORTSDIR}/audio/libogg \
FLAC:${PORTSDIR}/audio/flac \
@@ -23,6 +22,7 @@ LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile \
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CFLAGS=`pkg-config --cflags sndfile` \
LDFLAGS=`pkg-config --libs-only-L sndfile`
diff --git a/audio/libmtp/Makefile b/audio/libmtp/Makefile
index 6dd23d2d8993..0b8b7825e45f 100644
--- a/audio/libmtp/Makefile
+++ b/audio/libmtp/Makefile
@@ -16,8 +16,6 @@ COMMENT= Media Transfer Protocol (MTP) library
LICENSE= LGPL21
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
OPTIONS_DEFINE= MTPZ
OPTIONS_DEFAULT= MTPZ
MTPZ_DESC= Enable functionality to connect to MTPZ devices
@@ -26,6 +24,7 @@ USE_GNOME= gnomehack
USE_ICONV= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/audio/libsidplay2/Makefile b/audio/libsidplay2/Makefile
index 68eaa971767c..4c68292f68d1 100644
--- a/audio/libsidplay2/Makefile
+++ b/audio/libsidplay2/Makefile
@@ -15,11 +15,10 @@ DISTNAME= sidplay-libs-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to play Commodore 64 SID-tunes cycle accurate
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_GNOME= gnomehack
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
+USE_PKGCONFIG= yes
LIBTOOLFILES= builders/hardsid-builder/configure \
builders/resid-builder/configure \
libsidplay/configure \
diff --git a/audio/lv2core/Makefile b/audio/lv2core/Makefile
index 2a3a6a5d738e..f59d1a4fc572 100644
--- a/audio/lv2core/Makefile
+++ b/audio/lv2core/Makefile
@@ -16,10 +16,9 @@ COMMENT= LV2 Core Package
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= pkg-config>0:${PORTSDIR}/devel/pkg-config
-
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/audio/opus-tools/Makefile b/audio/opus-tools/Makefile
index a8682d525024..c25d70321070 100644
--- a/audio/opus-tools/Makefile
+++ b/audio/opus-tools/Makefile
@@ -17,9 +17,8 @@ COMMENT= Encode, inspect, and decode Opus files
LIB_DEPENDS= ogg.8:${PORTSDIR}/audio/libogg \
opus:${PORTSDIR}/audio/opus
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
-
GNU_CONFIGURE= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
PLIST_FILES= bin/opusdec bin/opusenc bin/opusinfo
diff --git a/audio/sidplay2/Makefile b/audio/sidplay2/Makefile
index ee07cda1341e..f1f2beab1ca6 100644
--- a/audio/sidplay2/Makefile
+++ b/audio/sidplay2/Makefile
@@ -18,6 +18,7 @@ LIB_DEPENDS= sidplay2.1:${PORTSDIR}/audio/libsidplay2
MAN1= sidplay2.1
PLIST_FILES= bin/sidplay2
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/audio/slv2/Makefile b/audio/slv2/Makefile
index 046c2b8b4f5f..73e47281901b 100644
--- a/audio/slv2/Makefile
+++ b/audio/slv2/Makefile
@@ -16,14 +16,14 @@ COMMENT= LV2 Application Support Library
LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= ${LOCALBASE}/include/lv2.h:${PORTSDIR}/audio/lv2core \
- pkg-config>0:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS= ${LOCALBASE}/include/lv2.h:${PORTSDIR}/audio/lv2core
LIB_DEPENDS= jack.0:${PORTSDIR}/audio/jack \
rdf.0:${PORTSDIR}/textproc/redland
USE_BZIP2= yes
USE_PYTHON_BUILD= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>