aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-22 20:33:17 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-22 20:33:17 +0000
commit93a544d409acc43cd7ea11a84de2877ad97bbfab (patch)
tree346123d81fe48319e98d57edde9668338dcf6fb9 /audio
parentfedb6e57676bd54f6ac8d1afba35cf3aab77e107 (diff)
downloadports-93a544d409acc43cd7ea11a84de2877ad97bbfab.tar.gz
ports-93a544d409acc43cd7ea11a84de2877ad97bbfab.zip
Add gtkgep, a GTK guitar effects processor.
PR: 47779 Submitted by: Mark Linimon <linimon@lonesome.com>
Notes
Notes: svn path=/head/; revision=76197
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gtkgep/Makefile23
-rw-r--r--audio/gtkgep/distinfo1
-rw-r--r--audio/gtkgep/files/patch-Makefile.in11
-rw-r--r--audio/gtkgep/files/patch-configure10
-rw-r--r--audio/gtkgep/pkg-descr8
-rw-r--r--audio/gtkgep/pkg-plist24
7 files changed, 78 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 9786a5b3a9f6..3cfbba4587a5 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -101,6 +101,7 @@
SUBDIR += grip
SUBDIR += gsi
SUBDIR += gsm
+ SUBDIR += gtkgep
SUBDIR += holyshout
SUBDIR += icecast
SUBDIR += icecast2
diff --git a/audio/gtkgep/Makefile b/audio/gtkgep/Makefile
new file mode 100644
index 000000000000..379f7aa0934b
--- /dev/null
+++ b/audio/gtkgep/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: GtkGEP
+# Date created: Sun Jan 26 19:15:57 CST 2003
+# Whom: Mark Linimon <linimon@lonesome.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtkgep
+PORTVERSION= 0.2.3
+CATEGORIES= audio
+MASTER_SITES= http://gtkgep.republika.pl/
+
+MAINTAINER= linimon@lonesome.com
+COMMENT= A guitar effects processor for GTK
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+PLIST_SUB= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/audio/gtkgep/distinfo b/audio/gtkgep/distinfo
new file mode 100644
index 000000000000..5d8361d12302
--- /dev/null
+++ b/audio/gtkgep/distinfo
@@ -0,0 +1 @@
+MD5 (gtkgep-0.2.3.tar.gz) = 3405e30d600edc9885b27951792358dc
diff --git a/audio/gtkgep/files/patch-Makefile.in b/audio/gtkgep/files/patch-Makefile.in
new file mode 100644
index 000000000000..4f02ec7505c4
--- /dev/null
+++ b/audio/gtkgep/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.dist Wed Jan 22 18:48:48 2003
++++ Makefile.in Thu Jan 30 22:11:51 2003
+@@ -338,7 +338,7 @@
+
+ top_distdir = .
+ # Avoid unsightly `./'.
+-distdir = $(PACKAGE)-$(VERSION)
++distdir = $(PACKAGE)
+
+ GZIP_ENV = --best
+
diff --git a/audio/gtkgep/files/patch-configure b/audio/gtkgep/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/audio/gtkgep/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/gtkgep/pkg-descr b/audio/gtkgep/pkg-descr
new file mode 100644
index 000000000000..de8fdd941de4
--- /dev/null
+++ b/audio/gtkgep/pkg-descr
@@ -0,0 +1,8 @@
+GtkGEP turns your computer into a realtime effects processor. You can plug
+your guitar into the computer and play with cool distortion effects, for
+example. It has a modular plugin structure, with standard plugins including
+distortion, overdrive, delay, reverb, equalizers, and a flanger. It works
+in 16-bit resolution, in mono mode, and with frequencies from 11khz to
+44khz. The sound quality is very good.
+
+WWW: http://gtkgep.prv.pl
diff --git a/audio/gtkgep/pkg-plist b/audio/gtkgep/pkg-plist
new file mode 100644
index 000000000000..08629124620b
--- /dev/null
+++ b/audio/gtkgep/pkg-plist
@@ -0,0 +1,24 @@
+bin/gtkgep
+lib/libfilter.a
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/bandeq1.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/bandeq12.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/bandeq3.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/compressor.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/distorthard.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/distortnormal.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/distortsoft.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/echo.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/flanger.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/guitarfilter.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/highpass4.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/lowpass.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/lowpass4.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/ngexp.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/noisegate.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/overdrive.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/reverb.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/simplehighpass.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/simplelowpass.so
+lib/%%PORTNAME%%-%%PORTVERSION%%/plugins/volume.so
+@dirrm lib/%%PORTNAME%%-%%PORTVERSION%%/plugins
+@dirrm lib/%%PORTNAME%%-%%PORTVERSION%%