aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-14 09:38:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-14 09:38:26 +0000
commit9546826d288534cba41d63afe364a27deb71b97f (patch)
tree6ceb907ee2ba42da9a44f011e82bcfdcbe217383 /audio
parentfd5b9c3f5842f49ed3b15f2d559ddb7d26467122 (diff)
downloadports-9546826d288534cba41d63afe364a27deb71b97f.tar.gz
ports-9546826d288534cba41d63afe364a27deb71b97f.zip
- Fix COMMENT
- Add LICENSE - Cosmetic changes
Notes
Notes: svn path=/head/; revision=406101
Diffstat (limited to 'audio')
-rw-r--r--audio/vagalume/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index 11c3b47692eb..ffa136a8c924 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -9,7 +9,10 @@ MASTER_SITES= http://vagalume.igalia.com/files/source/ \
DEBIAN_POOL/pool/main/v/vagalume/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A GTK+-based client for the Last.fm online radio
+COMMENT= GTK+-based client for the Last.fm online radio
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
libcurl.so:${PORTSDIR}/ftp/curl
@@ -25,7 +28,6 @@ OPTIONS_DEFAULT= DBUS TRAY
OPTIONS_SUB= NLS DBUS
TRAY_DESC= Tray icon and libnotify support
-
DBUS_LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
DBUS_CONFIGURE_ON= --enable-dbus --enable-im-status
DBUS_CONFIGURE_OFF= --disable-dbus --disable-im-status
@@ -35,21 +37,23 @@ TRAY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
TRAY_CONFIGURE_ENABLE= tray-icon
NLS_USES= gettext
-NLS_CPPFLAGS= -I${LOCALBASE}/include
-NLS_LDFLAGS= -L${LOCALBASE}/lib
+NLS_CPPFLAGS= -I${LOCALBASE}/include
+NLS_LDFLAGS= -L${LOCALBASE}/lib
NLS_CONFIGURE_ENABLE= nls
+NLS_USES_OFF= gettext-tools
-GCONF_USE= GNOME=gconf2
+GCONF_USE= GNOME=gconf2
GCONF_CONFIGURE_ENABLE= gconf
post-patch:
@${REINPLACE_CMD} -e 's|serviceentrydir = @serviceentrydir@|serviceentrydir = ${PREFIX}/share/dbus-1/services|' \
${WRKSRC}/Makefile.in
+
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|SUBDIRS = src po|SUBDIRS = src|' \
${WRKSRC}/Makefile.in
post-install:
- ${CP} ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>