aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2010-01-14 23:16:30 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2010-01-14 23:16:30 +0000
commit96278172d88fa26c68483e562eaaec1a521bf56f (patch)
tree87bf1d5c1c0b5d17644074f71fe3211cde9e9c73 /audio
parentab3852a1a619eb05f7b9ed09ece34474b7545c91 (diff)
downloadports-96278172d88fa26c68483e562eaaec1a521bf56f.tar.gz
ports-96278172d88fa26c68483e562eaaec1a521bf56f.zip
- Update to 1.0.3
Notes
Notes: svn path=/head/; revision=247893
Diffstat (limited to 'audio')
-rw-r--r--audio/vitunes/Makefile15
-rw-r--r--audio/vitunes/distinfo6
-rw-r--r--audio/vitunes/files/patch-medialib.c11
-rw-r--r--audio/vitunes/files/patch-meta_info.c11
-rw-r--r--audio/vitunes/files/patch-meta_info.h12
-rw-r--r--audio/vitunes/files/patch-uinterface.h6
-rw-r--r--audio/vitunes/files/patch-vitunes.h6
7 files changed, 23 insertions, 44 deletions
diff --git a/audio/vitunes/Makefile b/audio/vitunes/Makefile
index 032eed551c60..87efb8ecf8f9 100644
--- a/audio/vitunes/Makefile
+++ b/audio/vitunes/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= vitunes
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.3
CATEGORIES= audio
MASTER_SITES= http://www.vitunes.org/files/ \
http://mirror.4bit.ws/ \
@@ -18,22 +18,13 @@ MAINTAINER= dhn@FreeBSD.org
COMMENT= A curses-based media player with vim-like keybinds
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
-LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
- vorbis.4:${PORTSDIR}/audio/libvorbis \
- mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
-
-MAKE_ARGS= LDFLAGS_DEPS="-L${LOCALBASE}/lib -lid3tag -lmp4v2 -logg -lvorbis -lvorbisfile" \
- CFLAGS_DEPS="-I${LOCALBASE}/include"
+LIB_DEPENDS= tag:${PORTSDIR}/audio/taglib
ALL_TARGET= vitunes
PLIST_FILES= bin/vitunes
MAN1= vitunes.1
post-patch:
- @${REINPLACE_CMD} -e 's|8|9|g' ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/audio/vitunes/distinfo b/audio/vitunes/distinfo
index b3a69c0bec3a..a6378fb61c3b 100644
--- a/audio/vitunes/distinfo
+++ b/audio/vitunes/distinfo
@@ -1,3 +1,3 @@
-MD5 (vitunes-1.0.2.tgz) = 0a76e955938ab3879ffe929a2eec5820
-SHA256 (vitunes-1.0.2.tgz) = 80427ad0e87391f0208a5a7840fe5b0e5f17d21a97098b257a80970c678badf2
-SIZE (vitunes-1.0.2.tgz) = 55143
+MD5 (vitunes-1.0.3.tgz) = 66a66e7e99b747f5316dfdbd200e76c4
+SHA256 (vitunes-1.0.3.tgz) = fb01a30551b94f92e10b8c57e574539bb754effca1ef8fcd312d6beebe069fed
+SIZE (vitunes-1.0.3.tgz) = 56656
diff --git a/audio/vitunes/files/patch-medialib.c b/audio/vitunes/files/patch-medialib.c
index 00cfb58826e9..290fd22473ed 100644
--- a/audio/vitunes/files/patch-medialib.c
+++ b/audio/vitunes/files/patch-medialib.c
@@ -1,16 +1,15 @@
---- ./medialib.c.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./medialib.c 2010-01-05 18:32:53.000000000 +0100
-@@ -287,7 +287,8 @@
+--- ./medialib.c.orig 2010-01-14 21:05:31.000000000 +0100
++++ ./medialib.c 2010-01-14 21:07:02.000000000 +0100
+@@ -351,7 +351,7 @@
* last extracted meta-info from it (otherwise we ignore)
*/
- if (sb.st_mtim.tv_sec > mdb.library->files[i]->last_updated) {
-+ //if (sb.st_mtim > mdb.library->files[i]->last_updated) {
+ if (sb.st_mtime > mdb.library->files[i]->last_updated) {
- mi = meta_extract(filename);
+ mi = mi_extract(filename);
if (mi == NULL) {
-@@ -385,7 +386,7 @@
+@@ -457,7 +457,7 @@
if (idx != -1) {
/* file already exists in library database - update */
diff --git a/audio/vitunes/files/patch-meta_info.c b/audio/vitunes/files/patch-meta_info.c
deleted file mode 100644
index fe8287910aa8..000000000000
--- a/audio/vitunes/files/patch-meta_info.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./meta_info.c.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./meta_info.c 2010-01-05 18:33:03.000000000 +0100
-@@ -678,7 +678,7 @@
- const char *errstr = NULL;
-
- /* note that the range is here what libid3tag can handle */
-- gindex = strtonum(mi->cinfo[MI_CINFO_GENRE], 0, 147, &errstr);
-+ gindex = atoll(mi->cinfo[MI_CINFO_GENRE]);
- if (errstr != NULL) { /* check for invalid genre number */
- free(mi->cinfo[MI_CINFO_GENRE]);
- mi->cinfo[MI_CINFO_GENRE] = NULL;
diff --git a/audio/vitunes/files/patch-meta_info.h b/audio/vitunes/files/patch-meta_info.h
index 9b89a8799d70..0e52786509e7 100644
--- a/audio/vitunes/files/patch-meta_info.h
+++ b/audio/vitunes/files/patch-meta_info.h
@@ -1,10 +1,10 @@
---- ./meta_info.h.orig 2010-01-04 03:17:55.000000000 +0100
-+++ ./meta_info.h 2010-01-05 18:33:09.000000000 +0100
-@@ -5,6 +5,7 @@
- #include <limits.h>
+--- ./meta_info.h.orig 2010-01-14 06:38:34.000000000 +0100
++++ ./meta_info.h 2010-01-14 21:03:35.000000000 +0100
+@@ -22,6 +22,7 @@
+ #include <stdint.h>
#include <stdlib.h>
#include <string.h>
+#include <strings.h>
#include <ctype.h>
- #include <time.h>
- #include <err.h>
+ #include <stdio.h>
+ #include <errno.h>
diff --git a/audio/vitunes/files/patch-uinterface.h b/audio/vitunes/files/patch-uinterface.h
index ffafd4383ec1..89fa58d4ffd5 100644
--- a/audio/vitunes/files/patch-uinterface.h
+++ b/audio/vitunes/files/patch-uinterface.h
@@ -1,6 +1,6 @@
---- ./uinterface.h.orig 2010-01-14 18:24:04.000000000 +0100
-+++ ./uinterface.h 2010-01-14 18:24:15.000000000 +0100
-@@ -17,7 +17,6 @@
+--- ./uinterface.h.orig 2010-01-14 06:38:34.000000000 +0100
++++ ./uinterface.h 2010-01-14 21:03:35.000000000 +0100
+@@ -18,7 +18,6 @@
#define UINTERFACE_H
#include <sys/ioctl.h>
diff --git a/audio/vitunes/files/patch-vitunes.h b/audio/vitunes/files/patch-vitunes.h
index 38d2414f26f1..d1c93d4f60f7 100644
--- a/audio/vitunes/files/patch-vitunes.h
+++ b/audio/vitunes/files/patch-vitunes.h
@@ -1,6 +1,6 @@
---- ./vitunes.h.orig 2010-01-14 18:28:36.000000000 +0100
-+++ ./vitunes.h 2010-01-14 18:28:43.000000000 +0100
-@@ -6,7 +6,6 @@
+--- ./vitunes.h.orig 2010-01-14 06:38:34.000000000 +0100
++++ ./vitunes.h 2010-01-14 21:03:35.000000000 +0100
+@@ -22,7 +22,6 @@
#include <getopt.h>
#include <signal.h>
#include <unistd.h>