aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-11-05 01:19:19 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-11-05 01:19:19 +0000
commitb94204b3eabd83542a68057e473aa71e101098dd (patch)
tree70d2cdc462d457a8fc59d8c1c849bad99461a934 /audio
parent50b76a190ad91c88b3a6438a07e5fb8449e67870 (diff)
downloadports-b94204b3eabd83542a68057e473aa71e101098dd.tar.gz
ports-b94204b3eabd83542a68057e473aa71e101098dd.zip
audio/lv2: fix substitution in lv2core.pc
Only noticed by broken -export-symbols-regex (libtool) in audio/calf. --- /usr/local/libdata/pkgconfig/lv2core.pc before +++ /usr/local/libdata/pkgconfig/lv2core.pc after @@ -1,10 +1,10 @@ prefix=/usr/local -exec_prefix= -libdir=/usr/local/lib -includedir=/usr/local/include +exec_prefix=${prefix} +libdir=${exec_prefix}/lib +includedir=${prefix}/include Name: lv2core -Version: +Version: 12.0 Description: An audio plugin interface specification. Libs: Cflags: -I${includedir} PR: 213285 Submitted by: Michael Beer <beerml@sigma6audio.de> (maintainer)
Notes
Notes: svn path=/head/; revision=425366
Diffstat (limited to 'audio')
-rw-r--r--audio/lv2/Makefile4
-rw-r--r--audio/lv2/files/patch-pkgconf30
2 files changed, 4 insertions, 30 deletions
diff --git a/audio/lv2/Makefile b/audio/lv2/Makefile
index efb4ec955e85..2602cab5cdd9 100644
--- a/audio/lv2/Makefile
+++ b/audio/lv2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lv2
PORTVERSION= 1.14.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://lv2plug.in/spec/
@@ -38,6 +39,9 @@ EXAMPLES_USE= GNOME=cairo,gtk20
EXAMPLES_CONFIGURE_ENV= CC='${CC} -Wl,--as-needed' # Gtk deps
post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/lib/pkgconfig/*.pc \
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig/
+ @${RMDIR} ${STAGEDIR}${PREFIX}/lib/pkgconfig/
# Waf doesn't have built-in strip support
@${FIND} ${STAGEDIR}${PREFIX}/lib/${PORTNAME} \
-name '*.so' -exec ${STRIP_CMD} {} +
diff --git a/audio/lv2/files/patch-pkgconf b/audio/lv2/files/patch-pkgconf
deleted file mode 100644
index 30144576d0c0..000000000000
--- a/audio/lv2/files/patch-pkgconf
+++ /dev/null
@@ -1,30 +0,0 @@
-Waf doesn't support changing pkg-config data install path
-
---- wscript.orig 2016-09-20 01:34:12 UTC
-+++ wscript
-@@ -400,7 +400,7 @@ def build(bld):
- bld(features = 'subst',
- source = 'lv2.pc.in',
- target = 'lv2.pc',
-- install_path = '${LIBDIR}/pkgconfig',
-+ install_path = '${LIBDIR}data/pkgconfig',
- PREFIX = bld.env.PREFIX,
- INCLUDEDIR = bld.env.INCLUDEDIR,
- VERSION = VERSION)
---- lv2/lv2plug.in/ns/lv2core/wscript.orig 2016-09-10 13:54:00 UTC
-+++ lv2/lv2plug.in/ns/lv2core/wscript
-@@ -52,7 +52,13 @@ def build(bld):
- bld.install_files('${LV2DIR}/lv2core.lv2', 'lv2.h')
-
- # Pkgconfig file
-- autowaf.build_pc(bld, 'LV2CORE', LV2CORE_VERSION, '', [])
-+ bld(features = 'subst',
-+ source = 'lv2core.pc.in',
-+ target = 'lv2core.pc',
-+ install_path = '${LIBDIR}data/pkgconfig',
-+ PREFIX = bld.env.PREFIX,
-+ INCLUDEDIR = bld.env.INCLUDEDIR,
-+ VERSION = LV2CORE_VERSION)
-
- # URI-like header include
- include_dir = os.path.join(bld.env['INCLUDEDIR'], 'lv2/lv2plug.in/ns')