aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-03-04 06:43:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-03-04 06:43:06 +0000
commitbd41d880237a81c2d442294ab1f4eb784c8a2d97 (patch)
tree5601f354021bbafea84ad784c8561c2ffc1cc26a /audio
parent94c3f1d657c98cdb14a6fb57efd86bc78ec9932b (diff)
downloadports-bd41d880237a81c2d442294ab1f4eb784c8a2d97.tar.gz
ports-bd41d880237a81c2d442294ab1f4eb784c8a2d97.zip
audio/skype-call-recorder: unbreak with libc++ 8
In file included from call.cpp:24: In file included from /usr/local/include/qt4/QtCore/QStringList:1: In file included from /usr/local/include/qt4/QtCore/qstringlist.h:45: In file included from /usr/local/include/qt4/QtCore/qalgorithms.h:45: In file included from /usr/local/include/qt4/QtCore/qglobal.h:68: In file included from /usr/include/c++/v1/algorithm:640: In file included from /usr/include/c++/v1/initializer_list:47: In file included from /usr/include/c++/v1/cstddef:38: version:1:1: error: expected unqualified-id 0.11 ^ PR: 236192 Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=494553
Diffstat (limited to 'audio')
-rw-r--r--audio/skype-call-recorder/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/skype-call-recorder/Makefile b/audio/skype-call-recorder/Makefile
index ee956898a1df..74b74a01336d 100644
--- a/audio/skype-call-recorder/Makefile
+++ b/audio/skype-call-recorder/Makefile
@@ -31,5 +31,9 @@ post-patch:
${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e 's,date --utc,TZ=UTC date,' \
${WRKSRC}/makeversion
+# Avoid conflict with C++20 <version> by adding .txt suffix
+ @${MV} ${WRKSRC}/version ${WRKSRC}/version.txt
+ @${REINPLACE_CMD} -i .c++20 's,src/version,&.txt,' \
+ ${WRKSRC}/makeversion
.include <bsd.port.mk>