aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-18 18:09:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-12-18 18:09:06 +0000
commitd1d25fdd684f876f6f7be3438ccc3fd8e8603e48 (patch)
treea628ea64e7b9eb063daf9940d8e1d7c131708b7b /audio
parent3d8b5b23e748cb2de72c5b59c7dcfd468bb2f310 (diff)
downloadports-d1d25fdd684f876f6f7be3438ccc3fd8e8603e48.tar.gz
ports-d1d25fdd684f876f6f7be3438ccc3fd8e8603e48.zip
Temporarily fix the detection of libid3tag. This fixes MP3 support in
new installations. The better fix would be to add a pkg-config file to the libid3tag port.
Notes
Notes: svn path=/head/; revision=96161
Diffstat (limited to 'audio')
-rw-r--r--audio/rhythmbox-devel/Makefile4
-rw-r--r--audio/rhythmbox-devel/files/patch-configure39
-rw-r--r--audio/rhythmbox/Makefile4
-rw-r--r--audio/rhythmbox/files/patch-configure39
4 files changed, 78 insertions, 8 deletions
diff --git a/audio/rhythmbox-devel/Makefile b/audio/rhythmbox-devel/Makefile
index c023ab84f7a5..c6d19e1f32f7 100644
--- a/audio/rhythmbox-devel/Makefile
+++ b/audio/rhythmbox-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
@@ -26,7 +27,8 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_LIBTOOL= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LOCALBASE="${LOCALBASE}"
.ifdef (WITH_XINE)
LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
diff --git a/audio/rhythmbox-devel/files/patch-configure b/audio/rhythmbox-devel/files/patch-configure
index f195f07b43c6..2ecff7bd2a0f 100644
--- a/audio/rhythmbox-devel/files/patch-configure
+++ b/audio/rhythmbox-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Dec 11 18:31:51 2002
-+++ configure Thu Dec 12 12:07:17 2002
-@@ -7414,6 +7414,7 @@
+--- configure.orig Wed Dec 17 23:50:24 2003
++++ configure Thu Dec 18 13:02:58 2003
+@@ -19377,6 +19377,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,36 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -21080,20 +21081,20 @@
+ echo "$as_me:$LINENO: checking for id3tag >= 0.15.0b" >&5
+ echo $ECHO_N "checking for id3tag >= 0.15.0b... $ECHO_C" >&6
+
+- if $PKG_CONFIG --exists "id3tag >= 0.15.0b" ; then
++ if true ; then
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ succeeded=yes
+
+ echo "$as_me:$LINENO: checking ID3TAG_CFLAGS" >&5
+ echo $ECHO_N "checking ID3TAG_CFLAGS... $ECHO_C" >&6
+- ID3TAG_CFLAGS=`$PKG_CONFIG --cflags "id3tag >= 0.15.0b"`
++ ID3TAG_CFLAGS=""
+ echo "$as_me:$LINENO: result: $ID3TAG_CFLAGS" >&5
+ echo "${ECHO_T}$ID3TAG_CFLAGS" >&6
+
+ echo "$as_me:$LINENO: checking ID3TAG_LIBS" >&5
+ echo $ECHO_N "checking ID3TAG_LIBS... $ECHO_C" >&6
+- ID3TAG_LIBS=`$PKG_CONFIG --libs "id3tag >= 0.15.0b"`
++ ID3TAG_LIBS="-L$LOCALBASE/lib -lid3tag -lz"
+ echo "$as_me:$LINENO: result: $ID3TAG_LIBS" >&5
+ echo "${ECHO_T}$ID3TAG_LIBS" >&6
+ else
+@@ -21101,7 +21102,7 @@
+ ID3TAG_LIBS=""
+ ## If we have a custom action on failure, don't print errors, but
+ ## do set a variable so people can do so.
+- ID3TAG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "id3tag >= 0.15.0b"`
++ ID3TAG_PKG_ERRORS=
+
+ fi
+
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index c023ab84f7a5..c6d19e1f32f7 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rhythmbox
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.6
@@ -26,7 +27,8 @@ USE_GMAKE= yes
USE_GNOME= gnomehack gnomeprefix libgnomeui
USE_LIBTOOL= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
- CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LOCALBASE="${LOCALBASE}"
.ifdef (WITH_XINE)
LIB_DEPENDS+= xine.7:${PORTSDIR}/multimedia/libxine
diff --git a/audio/rhythmbox/files/patch-configure b/audio/rhythmbox/files/patch-configure
index f195f07b43c6..2ecff7bd2a0f 100644
--- a/audio/rhythmbox/files/patch-configure
+++ b/audio/rhythmbox/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Dec 11 18:31:51 2002
-+++ configure Thu Dec 12 12:07:17 2002
-@@ -7414,6 +7414,7 @@
+--- configure.orig Wed Dec 17 23:50:24 2003
++++ configure Thu Dec 18 13:02:58 2003
+@@ -19377,6 +19377,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
@@ -8,3 +8,36 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -21080,20 +21081,20 @@
+ echo "$as_me:$LINENO: checking for id3tag >= 0.15.0b" >&5
+ echo $ECHO_N "checking for id3tag >= 0.15.0b... $ECHO_C" >&6
+
+- if $PKG_CONFIG --exists "id3tag >= 0.15.0b" ; then
++ if true ; then
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ succeeded=yes
+
+ echo "$as_me:$LINENO: checking ID3TAG_CFLAGS" >&5
+ echo $ECHO_N "checking ID3TAG_CFLAGS... $ECHO_C" >&6
+- ID3TAG_CFLAGS=`$PKG_CONFIG --cflags "id3tag >= 0.15.0b"`
++ ID3TAG_CFLAGS=""
+ echo "$as_me:$LINENO: result: $ID3TAG_CFLAGS" >&5
+ echo "${ECHO_T}$ID3TAG_CFLAGS" >&6
+
+ echo "$as_me:$LINENO: checking ID3TAG_LIBS" >&5
+ echo $ECHO_N "checking ID3TAG_LIBS... $ECHO_C" >&6
+- ID3TAG_LIBS=`$PKG_CONFIG --libs "id3tag >= 0.15.0b"`
++ ID3TAG_LIBS="-L$LOCALBASE/lib -lid3tag -lz"
+ echo "$as_me:$LINENO: result: $ID3TAG_LIBS" >&5
+ echo "${ECHO_T}$ID3TAG_LIBS" >&6
+ else
+@@ -21101,7 +21102,7 @@
+ ID3TAG_LIBS=""
+ ## If we have a custom action on failure, don't print errors, but
+ ## do set a variable so people can do so.
+- ID3TAG_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "id3tag >= 0.15.0b"`
++ ID3TAG_PKG_ERRORS=
+
+ fi
+