aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-02-06 00:44:28 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-02-06 00:44:28 +0000
commitddeff5e294edd6667708993fe103741704a12da6 (patch)
treed57572a0a5dbaa41747bfa2d530ac1c6fd564b45 /audio
parent1a8f294b029cfa0f53309185e61c6efb2961974c (diff)
downloadports-ddeff5e294edd6667708993fe103741704a12da6.tar.gz
ports-ddeff5e294edd6667708993fe103741704a12da6.zip
If compiling with base GCC, -fnested-functions needs to be passed.
PR: 235541 Submitted by: Piotr Kubaj
Notes
Notes: svn path=/head/; revision=492284
Diffstat (limited to 'audio')
-rw-r--r--audio/funktrackergold/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/audio/funktrackergold/Makefile b/audio/funktrackergold/Makefile
index 2c127d024f6e..bc7b70fc3a52 100644
--- a/audio/funktrackergold/Makefile
+++ b/audio/funktrackergold/Makefile
@@ -15,9 +15,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_armv6= fails to compile: function definition is not allowed here
BROKEN_armv7= fails to compile: function definition is not allowed here
-BROKEN_mips= fails to compile: nested functions are disabled, use -fnested-functions to re-enable
-BROKEN_mips64= fails to compile: nested functions are disabled, use -fnested-functions to re-enable
-BROKEN_powerpc64= fails to compile: nested functions are disabled, use -fnested-functions to re-enable
USES= compiler:nestedfct ncurses tar:tgz
@@ -29,6 +26,12 @@ PLIST_FILES= bin/funkgold
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE:Mgcc}
+CFLAGS+= -fnested-functions
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/funkgold ${STAGEDIR}${PREFIX}/bin
@@ -38,4 +41,4 @@ do-install-DOCS-on:
${INSTALL_DATA} ${WRKSRC}/${docs} ${STAGEDIR}${DOCSDIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>