aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-24 17:30:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-24 17:30:52 +0000
commiteec059384ab2e28a4da15868cf3c278b95906974 (patch)
tree4bb74b8d7f8e97fdc08c8f37a69a14faa8edbdf6 /audio
parent16ba1ecdeda41fca340b2eb7c1c3816f7ee36e4e (diff)
downloadports-eec059384ab2e28a4da15868cf3c278b95906974.tar.gz
ports-eec059384ab2e28a4da15868cf3c278b95906974.zip
audio/gmsynth-lv2: fix build with GCC-based architectures
It was a missing patch for Makefile, that the port option was relying on. Also, rename the option SSE->SIMD. PR: 235987 Reported by: Piotr Kubaj <pkubaj@anongoth.pl>
Notes
Notes: svn path=/head/; revision=493774
Diffstat (limited to 'audio')
-rw-r--r--audio/gmsynth-lv2/Makefile11
-rw-r--r--audio/gmsynth-lv2/files/patch-Makefile11
2 files changed, 17 insertions, 5 deletions
diff --git a/audio/gmsynth-lv2/Makefile b/audio/gmsynth-lv2/Makefile
index 1448f4b36c41..1b614c168d1b 100644
--- a/audio/gmsynth-lv2/Makefile
+++ b/audio/gmsynth-lv2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmsynth
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.2
+PORTREVISION= 1
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -26,11 +27,11 @@ PLIST_FILES= lib/lv2/${PORTNAME}.lv2/GeneralUser_LV2.sf2 \
lib/lv2/${PORTNAME}.lv2/${PORTNAME}.ttl \
lib/lv2/${PORTNAME}.lv2/manifest.ttl
-OPTIONS_DEFINE_amd64= SSE
-OPTIONS_DEFINE_i386= SSE
-OPTIONS_DEFAULT_amd64= SSE
-OPTIONS_DEFAULT_i386= SSE
+OPTIONS_DEFINE_amd64= SIMD
+OPTIONS_DEFINE_i386= SIMD
+OPTIONS_DEFAULT_amd64= SIMD
+OPTIONS_DEFAULT_i386= SIMD
-SSE_MAKE_ENV= PORT_SIMD_FLAGS="-msse -msse2 -mfpmath=sse"
+SIMD_MAKE_ENV= PORT_SIMD_FLAGS="-msse -msse2 -mfpmath=sse"
.include <bsd.port.mk>
diff --git a/audio/gmsynth-lv2/files/patch-Makefile b/audio/gmsynth-lv2/files/patch-Makefile
new file mode 100644
index 000000000000..b83236b423d9
--- /dev/null
+++ b/audio/gmsynth-lv2/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2019-02-24 17:24:37 UTC
++++ Makefile
+@@ -9,7 +9,7 @@ MANDIR ?= $(PREFIX)/share/man/man1
+ # see http://lv2plug.in/pages/filesystem-hierarchy-standard.html, don't use libdir
+ LV2DIR ?= $(PREFIX)/lib/lv2
+
+-OPTIMIZATIONS ?= -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only -DNDEBUG
++OPTIMIZATIONS ?= $(PORT_SIMD_FLAGS) -ffast-math -fomit-frame-pointer -fno-finite-math-only -DNDEBUG
+ CFLAGS ?= -Wall -g -Wno-unused-function
+ STRIP ?= strip
+