aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-02-13 11:07:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-02-13 11:07:12 +0000
commitf3581f6772342079c2e6771bf34cdaf01d151a52 (patch)
tree5f0c0fa840c2e9ff55e0f9dc2715a33588c26a62 /audio
parent94e5787cf4a158437aa6bd758530d5ac798e2e28 (diff)
downloadports-f3581f6772342079c2e6771bf34cdaf01d151a52.tar.gz
ports-f3581f6772342079c2e6771bf34cdaf01d151a52.zip
QUIMUP is a 'graphical' client for the music player daemon (MPD)
written in C++ and QT4. Features include: * Support for (locally stored) albumart. * Support for audio streams (url). * Drag & drop playlist management. * Database browser (artist, album, genre, folder & playlist mode) * Database search (artist, album, genre & title mode). * Quick search-and-select in the playlist. * Mini-mode interface for basic control only. * Open folder in external programs to edit tags etc. * Generally a quick and clean application. WWW: http://coonsden.com/?page_id=145 PR: ports/154702 Submitted by: Cezary Morga <cm at therek.net>
Notes
Notes: svn path=/head/; revision=269056
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/quimup/Makefile59
-rw-r--r--audio/quimup/distinfo2
-rw-r--r--audio/quimup/pkg-descr16
4 files changed, 78 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5f8fa39080a6..81d19d3cf2bb 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -649,6 +649,7 @@
SUBDIR += qmpdclient
SUBDIR += qsampler
SUBDIR += qsynth
+ SUBDIR += quimup
SUBDIR += raop_play
SUBDIR += raproxy
SUBDIR += raul
diff --git a/audio/quimup/Makefile b/audio/quimup/Makefile
new file mode 100644
index 000000000000..7b9e31b55b3d
--- /dev/null
+++ b/audio/quimup/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: quimup
+# Date created: 2011-02-08
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= quimup
+PORTVERSION= 1.2.0
+CATEGORIES= audio
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=musicpd/Quimup/${PORTVERSION}
+DISTNAME= ${PORTNAME}_${DISTVERSION}_source
+
+MAINTAINER= cm@therek.net
+COMMENT= QT4 Client for MPD (the Music Player Daemon)
+
+LIB_DEPENDS= mpdclient.2:${PORTSDIR}/audio/libmpdclient
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui network \
+ qmake_build moc_build rcc_build uic_build
+QMAKE_ARGS= PREFIX=${PREFIX}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+
+PLIST_FILES= bin/${PORTNAME} \
+ share/icons/hicolor/32x32/apps/${PORTNAME}.png \
+ share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ share/icons/hicolor/64x64/apps/${PORTNAME}.png
+PLIST_DIRS= share/icons/hicolor/32x32/apps \
+ share/icons/hicolor/32x32 \
+ share/icons/hicolor/48x48/apps \
+ share/icons/hicolor/48x48 \
+ share/icons/hicolor/64x64/apps \
+ share/icons/hicolor/64x64 \
+ share/icons/hicolor \
+ share/icons
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ ${REINPLACE_CMD} -e 's|/usr/lib/libmpdclient.so|${LOCALBASE}/lib/libmpdclient.so|' \
+ ${WRKSRC}/${PORTNAME}.pro
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} ${QMAKE_ARGS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/32x32/apps
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/48x48/apps
+ ${MKDIR} ${PREFIX}/share/icons/hicolor/64x64/apps
+ ${INSTALL_DATA} ${WRKSRC}/Icons/${PORTNAME}32.png \
+ ${PREFIX}/share/icons/hicolor/32x32/apps/${PORTNAME}.png
+ ${INSTALL_DATA} ${WRKSRC}/Icons/${PORTNAME}48.png \
+ ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png
+ ${INSTALL_DATA} ${WRKSRC}/Icons/${PORTNAME}64.png \
+ ${PREFIX}/share/icons/hicolor/64x64/apps/${PORTNAME}.png
+
+.include <bsd.port.post.mk>
diff --git a/audio/quimup/distinfo b/audio/quimup/distinfo
new file mode 100644
index 000000000000..25372cb6ade7
--- /dev/null
+++ b/audio/quimup/distinfo
@@ -0,0 +1,2 @@
+SHA256 (quimup_1.2.0_source.tar.gz) = 194632a593df5c326222d61cd12fd2d0fa96438e25bf79efc82877070e12ebac
+SIZE (quimup_1.2.0_source.tar.gz) = 231147
diff --git a/audio/quimup/pkg-descr b/audio/quimup/pkg-descr
new file mode 100644
index 000000000000..081a44251ca7
--- /dev/null
+++ b/audio/quimup/pkg-descr
@@ -0,0 +1,16 @@
+QUIMUP is a 'graphical' client for the music player daemon (MPD)
+written in C++ and QT4.
+
+Features include:
+
+* Support for (locally stored) albumart.
+* Support for audio streams (url).
+* Drag & drop playlist management.
+* Database browser (artist, album, genre, folder & playlist mode)
+* Database search (artist, album, genre & title mode).
+* Quick search-and-select in the playlist.
+* Mini-mode interface for basic control only.
+* Open folder in external programs to edit tags etc.
+* Generally a quick and clean application.
+
+WWW: http://coonsden.com/?page_id=145