aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2011-04-09 14:06:28 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2011-04-09 14:06:28 +0000
commitf6e97d2598de4e2c591ddaa7f1c1d663f35e1166 (patch)
treedc1d4364c2d6b9fd30f76401fb87a26dd6ab553d /audio
parent73a261a79cc790549a9fc856f48e99c48f01a0f4 (diff)
downloadports-f6e97d2598de4e2c591ddaa7f1c1d663f35e1166.tar.gz
ports-f6e97d2598de4e2c591ddaa7f1c1d663f35e1166.zip
Add autotalen, a LADSPA plugin for real-time pitch correction
PR: 155914 Submitted by: Richard Neese
Notes
Notes: svn path=/head/; revision=272438
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/autotalent/Makefile36
-rw-r--r--audio/autotalent/distinfo2
-rw-r--r--audio/autotalent/pkg-descr3
4 files changed, 42 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f8959ad720ec..ef43d9aae888 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -60,6 +60,7 @@
SUBDIR += aumix
SUBDIR += aureal-kmod
SUBDIR += autocd
+ SUBDIR += autotalent
SUBDIR += autozen
SUBDIR += aylet
SUBDIR += baudline
diff --git a/audio/autotalent/Makefile b/audio/autotalent/Makefile
new file mode 100644
index 000000000000..f93f33aa4474
--- /dev/null
+++ b/audio/autotalent/Makefile
@@ -0,0 +1,36 @@
+# New ports collection Makefile for: autotalent
+# Date created: 03/24/11
+# Whom: Rich Neese <r.neese@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= autotalent
+PORTVERSION= 0.2
+CATEGORIES= audio
+MASTER_SITES= http://web.mit.edu/tbaran/www/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= A real-time pitch correction plugin for ladspa
+
+BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+RUN_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+
+USE_GMAKE= yes
+
+MAKE_ARGS= CXX="${CXX}" \
+ CXXFLAGS="${CXXFLAGS} -fPIC -I${LOCALBASE}/include"
+
+ALL_TARGET= targets
+
+PLIST_FILES= lib/ladspa/autotalent.so
+
+post-patch:
+ @${FIND} ${BUILD_WRKSRC} -name '*.cpp' | ${XARGS} \
+ ${REINPLACE_CMD} -e "s|<malloc.h>|<stdlib.h>|g"
+ ${REINPLACE_CMD} -e "s,-O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math,${CFLAGS}," ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/autotalent.so ${PREFIX}/lib/ladspa/
+
+.include <bsd.port.mk>
diff --git a/audio/autotalent/distinfo b/audio/autotalent/distinfo
new file mode 100644
index 000000000000..3be11920608c
--- /dev/null
+++ b/audio/autotalent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (autotalent-0.2.tar.gz) = c0d2962ac9f49a96a20b60413802f18e629034d3cb78d1c7b056c3487be4ebf5
+SIZE (autotalent-0.2.tar.gz) = 31419
diff --git a/audio/autotalent/pkg-descr b/audio/autotalent/pkg-descr
new file mode 100644
index 000000000000..2552f2972379
--- /dev/null
+++ b/audio/autotalent/pkg-descr
@@ -0,0 +1,3 @@
+real-time pitch correction plugin for ladspa
+
+WWW: http://web.mit.edu/tbaran/www/autotalent.html