aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-02-10 22:28:16 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-02-10 22:28:16 +0000
commitf93674fb9c909f272a86347b86ddff7a7974bcb5 (patch)
tree1f336bdf421fdeb33c8a96c10346160f2f5235a4 /audio
parentb333c99733b5a4725d3a99a07643c36bb7b05d47 (diff)
downloadports-f93674fb9c909f272a86347b86ddff7a7974bcb5.tar.gz
ports-f93674fb9c909f272a86347b86ddff7a7974bcb5.zip
multimedia/mythtv: Update to 30.0 and unbreak
Changes: https://www.mythtv.org/wiki/Release_Notes_-_30 PR: 234551 Submitted by: fernando.e.vilas@gmail.com
Notes
Notes: svn path=/head/; revision=492655
Diffstat (limited to 'audio')
-rw-r--r--audio/mythplugin-mythmusic/Makefile15
-rw-r--r--audio/mythplugin-mythmusic/distinfo6
-rw-r--r--audio/mythplugin-mythmusic/files/patch-configure15
-rw-r--r--audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.cpp13
-rw-r--r--audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.h15
-rw-r--r--audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cdrip.cpp25
6 files changed, 14 insertions, 75 deletions
diff --git a/audio/mythplugin-mythmusic/Makefile b/audio/mythplugin-mythmusic/Makefile
index 76bd87582f97..5ba089643b6f 100644
--- a/audio/mythplugin-mythmusic/Makefile
+++ b/audio/mythplugin-mythmusic/Makefile
@@ -3,8 +3,8 @@
PORTNAME= mythmusic
DISTVERSIONPREFIX= v
-DISTVERSION= 29.1
-PORTREVISION= 2
+DISTVERSION= 30.0
+PORTREVISION= 0
CATEGORIES= audio
PKGNAMEPREFIX= mythplugin-
@@ -18,9 +18,9 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libmp3lame.so:audio/lame \
libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis \
- libmyth-29.so:multimedia/mythtv
+ libmyth-30.so:multimedia/mythtv
-USES= qt:5
+USES= gmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= MythTV
GH_PROJECT= mythtv
@@ -28,8 +28,13 @@ USE_LDCONFIG= yes
USE_QT= buildtools_build core gui qmake_build sql xml
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix="${PREFIX}" --disable-all \
+CONFIGURE_ARGS= --prefix="${PREFIX}" --cc="${CC}" --cxx="${CXX}" \
+ --disable-all \
--enable-mythmusic
+CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" MOC="${MOC}" \
+ QTDIR="${PREFIX}" PKG_CONFIG_PATH="${LOCALBASE}/libdata/pkgconfig"
+MAKE_ENV= QTDIR="${PREFIX}" \
+ QMAKESPEC="${QMAKESPEC}"
DESTDIRNAME= INSTALL_ROOT
PLIST_SUB= MYTHSHARE="share/mythtv"
WRKSRC_SUBDIR= mythplugins
diff --git a/audio/mythplugin-mythmusic/distinfo b/audio/mythplugin-mythmusic/distinfo
index 509afc6897a2..2f3e5d623a72 100644
--- a/audio/mythplugin-mythmusic/distinfo
+++ b/audio/mythplugin-mythmusic/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520813358
-SHA256 (MythTV-mythtv-v29.1_GH0.tar.gz) = 04a84eb0ded2d2b123624ab2b2e1b8cf824ff4bf8216e452b2516deb929082b2
-SIZE (MythTV-mythtv-v29.1_GH0.tar.gz) = 105616234
+TIMESTAMP = 1549080114
+SHA256 (MythTV-mythtv-v30.0_GH0.tar.gz) = 7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43
+SIZE (MythTV-mythtv-v30.0_GH0.tar.gz) = 101169041
diff --git a/audio/mythplugin-mythmusic/files/patch-configure b/audio/mythplugin-mythmusic/files/patch-configure
index 4f38e634a2db..98e9512a3f40 100644
--- a/audio/mythplugin-mythmusic/files/patch-configure
+++ b/audio/mythplugin-mythmusic/files/patch-configure
@@ -11,7 +11,7 @@
check_cxx(){
log check_cxx "$@"
cat > $TMPCXX
-@@ -559,6 +563,10 @@ CXXPPFLAGS=${CXXPPFLAGS#CXXPPFLAGS=}
+@@ -582,6 +586,10 @@ CXXPPFLAGS=${CXXPPFLAGS#CXXPPFLAGS=}
OPENGLV=$(cat mythconfig.mak | grep -e "^CONFIG_OPENGL_VIDEO=yes")
OPENGLES=$(cat mythconfig.mak | grep -e "^HAVE_GLES2_GL2_H=yes")
@@ -22,16 +22,3 @@
EXTRALIBS=$(cat mythconfig.mak | grep -e "^EXTRALIBS=")
EXTRALIBS=${EXTRALIBS#EXTRALIBS=}
-@@ -689,8 +697,10 @@ if enabled music ; then
- echo "MythMusic requires FLAC."
- fi
-
-- if ! check_lib cdio/cdio.h cdio_open -lcdio || ! check_lib cdio/cdda.h cdio_cddap_open -lcdio_cdda || ! check_lib cdio/paranoia.h cdio_paranoia_init -lcdio_paranoia ; then
-- disable cdio
-+ if enabled cdio; then
-+ if ! check_lib cdio/cdio.h cdio_open -lcdio || ! check_lib cdio/paranoia/cdda.h cdio_cddap_open -lcdio_cdda || ! check_lib cdio/paranoia/paranoia.h cdio_paranoia_init -lcdio_paranoia ; then
-+ disable cdio
-+ fi
- fi
-
- if ! check_lib lame/lame.h lame_init -lmp3lame ; then
diff --git a/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.cpp b/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.cpp
deleted file mode 100644
index b8a5cc2689c5..000000000000
--- a/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-libcdio-paranoia header location changed after moving to separate project circa 2012
-
---- mythmusic/mythmusic/cddecoder.cpp.orig 2018-02-01 11:15:37 UTC
-+++ mythmusic/mythmusic/cddecoder.cpp
-@@ -14,7 +14,7 @@
- #include <QString>
-
- // libcdio
--#include <cdio/cdda.h>
-+#include <cdio/paranoia/cdda.h>
- #include <cdio/logging.h>
-
- // MythTV
diff --git a/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.h b/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.h
deleted file mode 100644
index 25f866faeb3d..000000000000
--- a/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cddecoder.h
+++ /dev/null
@@ -1,15 +0,0 @@
-libcdio-paranoia header location changed after moving to separate project circa 2012
-
---- mythmusic/mythmusic/cddecoder.h.orig 2018-02-01 11:15:37 UTC
-+++ mythmusic/mythmusic/cddecoder.h
-@@ -11,8 +11,8 @@ using std::vector;
- #endif
-
- #ifdef HAVE_CDIO
--# include <cdio/cdda.h>
--# include <cdio/paranoia.h>
-+# include <cdio/paranoia/cdda.h>
-+# include <cdio/paranoia/paranoia.h>
- #endif
-
- class MusicMetadata;
diff --git a/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cdrip.cpp b/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cdrip.cpp
deleted file mode 100644
index 85b4665d1756..000000000000
--- a/audio/mythplugin-mythmusic/files/patch-mythmusic_mythmusic_cdrip.cpp
+++ /dev/null
@@ -1,25 +0,0 @@
-libcdio-paranoia header location changed after moving to separate project circa 2012
-Fix warning: logical not is only applied to the left hand side of comparison
-
---- mythmusic/mythmusic/cdrip.cpp.orig 2018-02-01 11:15:37 UTC
-+++ mythmusic/mythmusic/cdrip.cpp
-@@ -8,8 +8,8 @@
-
- #include "config.h"
- #ifdef HAVE_CDIO
--# include <cdio/cdda.h>
--# include <cdio/paranoia.h>
-+# include <cdio/paranoia/cdda.h>
-+# include <cdio/paranoia/paranoia.h>
- #endif //def HAVE_CDIO
-
- // C++ includes
-@@ -219,7 +219,7 @@ void CDRipperThread::run(void)
- {
- RunProlog();
-
-- if (!m_tracks->size() > 0)
-+ if (!(m_tracks->size() > 0))
- {
- RunEpilog();
- return;