aboutsummaryrefslogtreecommitdiff
path: root/base
diff options
context:
space:
mode:
authorAlexander Kabaev <kan@FreeBSD.org>2018-05-15 14:07:26 +0000
committerAlexander Kabaev <kan@FreeBSD.org>2018-05-15 14:07:26 +0000
commit08e13126f15c3341615e3800f8ebc970dfa76bf2 (patch)
tree7d83b6c005505279f23aeadd6d0371eda1b787c1 /base
parented2d25ddb068fcecb28577c3ea1baa33a82f71b1 (diff)
downloadports-08e13126f15c3341615e3800f8ebc970dfa76bf2.tar.gz
ports-08e13126f15c3341615e3800f8ebc970dfa76bf2.zip
Upgrade base/gcc port to 6.4.0 to match xtoolchain
Reviewed by: jhb, bapt
Notes
Notes: svn path=/head/; revision=470018
Diffstat (limited to 'base')
-rw-r--r--base/gcc/Makefile8
-rw-r--r--base/gcc/distinfo5
2 files changed, 8 insertions, 5 deletions
diff --git a/base/gcc/Makefile b/base/gcc/Makefile
index 418115bcc385..494cfb39413a 100644
--- a/base/gcc/Makefile
+++ b/base/gcc/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= gcc
-PORTVERSION= 6.3.0
+PORTVERSION= 6.4.0
CATEGORIES= base
MASTER_SITES= GCC/releases/gcc-${DISTVERSION} \
http://www.mpfr.org/mpfr-3.1.6/:mpfr \
@@ -28,14 +28,15 @@ LICENSE_COMB= multi
.error Please define CROSS_SYSROOT before building
.endif
+GCC_TARGET= ${ARCH}-unknown-${OPSYS:tl}${OSREL}
+
PREFIX= /usr
CONFIGURE_ENV= gcc_gxx_include_dir="/usr/include/c++/v1" \
NM=/usr/bin/nm \
AS_FOR_TARGET=/usr/bin/as \
LD_FOR_TARGET=/usr/bin/ld \
NM_FOR_TARGET=/usr/bin/nm
-GCC_TARGET= ${ARCH}-unknown-${OPSYS:tl}${OSREL}
-USES= gmake libtool tar:bzip2 makeinfo
+USES= gmake libtool tar:xz makeinfo
PLIST_SUB= TARGETARCH=${ARCH} \
OPSYS=${OPSYS:tl} \
GCC_TARGET=${GCC_TARGET} \
@@ -49,6 +50,7 @@ CONFIGURE_OUTSOURCE= yes
CONFIGURE_ARGS+= \
--target=${GCC_TARGET} \
--enable-languages=c,c++ \
+ --enable-gnu-indirect-function \
--disable-nls \
--without-headers \
--with-gxx-include-dir=/usr/include/c++/v1/ \
diff --git a/base/gcc/distinfo b/base/gcc/distinfo
index 9561c2f04b2b..47f6c3519d27 100644
--- a/base/gcc/distinfo
+++ b/base/gcc/distinfo
@@ -1,6 +1,7 @@
TIMESTAMP = 1508105556
-SHA256 (gcc-6.3.0.tar.bz2) = f06ae7f3f790fbf0f018f6d40e844451e6bc3b7bc96e128e63b09825c1f8b29f
-SIZE (gcc-6.3.0.tar.bz2) = 99903185
+TIMESTAMP = 1514072608
+SHA256 (gcc-6.4.0.tar.xz) = 850bf21eafdfe5cd5f6827148184c08c4a0852a37ccf36ce69855334d2c914d4
+SIZE (gcc-6.4.0.tar.xz) = 76156220
SHA256 (mpfr-3.1.6.tar.xz) = 7a62ac1a04408614fccdc506e4844b10cf0ad2c2b1677097f8f35d3a1344a950
SIZE (mpfr-3.1.6.tar.xz) = 1133672
SHA256 (gmp-6.1.2.tar.xz) = 87b565e89a9a684fe4ebeeddb8399dce2599f9c9049854ca8c0dfbdea0e21912