aboutsummaryrefslogtreecommitdiff
path: root/base
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2020-01-03 21:09:18 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2020-01-03 21:09:18 +0000
commit8622a73b5e70d3c7145ba564d843b6c3dcfaf8f6 (patch)
tree387af098e7cd7b7d20eaab969afc93be373023fa /base
parent1afaf51bfa758998b14eef478b22f67cf2eda178 (diff)
downloadports-8622a73b5e70d3c7145ba564d843b6c3dcfaf8f6.tar.gz
ports-8622a73b5e70d3c7145ba564d843b6c3dcfaf8f6.zip
Update instructions to use freebsd-gcc6 packages.
Reported by: Mark Millard Reviewed by: bapt Differential Revision: https://reviews.freebsd.org/D23011
Notes
Notes: svn path=/head/; revision=521962
Diffstat (limited to 'base')
-rw-r--r--base/README16
1 files changed, 8 insertions, 8 deletions
diff --git a/base/README b/base/README
index 3a13d6953653..dd4993052be8 100644
--- a/base/README
+++ b/base/README
@@ -5,26 +5,26 @@ How to cross build initial toolchain
Example with sparc64
1/ install a cross toolchain
-pkg install sparc64-xtoolchain-gcc
+pkg install sparc64-gcc6
2/ cross build world
-make CROSS_TOOLCHAIN=sparc64-gcc TARGET=sparc64 TARGET_ARCH=sparc64 buildworld
+make CROSS_TOOLCHAIN=sparc64-gcc6 TARGET=sparc64 TARGET_ARCH=sparc64 buildworld
3/ install the world in a sysroot
-make CROSS_TOOLCHAIN=sparc64-gcc TARGET=sparc64 TARGET_ARCH=sparc64 installworld DESTDIR=/sysroots/sparc64
+make CROSS_TOOLCHAIN=sparc64-gcc6 TARGET=sparc64 TARGET_ARCH=sparc64 installworld DESTDIR=/sysroots/sparc64
4/ build the required port
$ cd base/binutils
-make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 package
+make CROSS_TOOLCHAIN=sparc64-gcc6 CROSS_SYSROOT=/sysroots/sparc64 package
-$ cd base/gcc
-make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 package
+$ cd base/gcc6
+make CROSS_TOOLCHAIN=sparc64-gcc6 CROSS_SYSROOT=/sysroots/sparc64 package
-the package are in base/gcc/work/pkg/*.txz and base/binutils/work/pkg/*.txz
+The packages are in base/gcc6/work/pkg/*.txz and base/binutils/work/pkg/*.txz
To add a plist for a new binutils target
$ cd base/binutils
-make CROSS_TOOLCHAIN=sparc64-gcc CROSS_SYSROOT=/sysroots/sparc64 makeplist > pkg-plist
+make CROSS_TOOLCHAIN=sparc64-gcc6 CROSS_SYSROOT=/sysroots/sparc64 makeplist > pkg-plist
edit the pkg-plist and remove everything which base does not provide via the
elftoolchain