aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/bonnie++
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2014-04-28 11:39:52 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2014-04-28 11:39:52 +0000
commit0436ef631b72dd0f4546c793d38aaa6d02c8b70b (patch)
tree2b67ab5761a0045bec61f198bc178379610e0005 /benchmarks/bonnie++
parent0ae9e27a67e5e3710feee7943a164379415e9652 (diff)
downloadports-0436ef631b72dd0f4546c793d38aaa6d02c8b70b.tar.gz
ports-0436ef631b72dd0f4546c793d38aaa6d02c8b70b.zip
- Remove GCC dependency
- Fix several compilation warnings PR: ports/188678 Submitted by: Matthew Rezny <matthew@reztek.cz>
Notes
Notes: svn path=/head/; revision=352485
Diffstat (limited to 'benchmarks/bonnie++')
-rw-r--r--benchmarks/bonnie++/Makefile1
-rw-r--r--benchmarks/bonnie++/files/patch-bonnie.h.in20
-rw-r--r--benchmarks/bonnie++/files/patch-duration.cpp17
-rw-r--r--benchmarks/bonnie++/files/patch-port.h.in30
-rw-r--r--benchmarks/bonnie++/files/patch-rand.h15
5 files changed, 74 insertions, 9 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index 3cdbbca27ae8..ca07e64a0a14 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -14,7 +14,6 @@ COMMENT= Performance Test of Filesystem I/O
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USE_GCC= any
USES= shebangfix
SHEBANG_FILES= bon_csv2txt.in
diff --git a/benchmarks/bonnie++/files/patch-bonnie.h.in b/benchmarks/bonnie++/files/patch-bonnie.h.in
new file mode 100644
index 000000000000..de7547755d19
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-bonnie.h.in
@@ -0,0 +1,20 @@
+--- bonnie.h.in.orig 2009-08-21 18:45:50.068536643 +0000
++++ bonnie.h.in 2009-08-21 18:45:58.564755017 +0000
+@@ -1,8 +1,6 @@
+ #ifndef BONNIE
+ #define BONNIE
+
+-using namespace std;
+-
+ #define BON_VERSION "@version@"
+ #define CSV_VERSION "@csv_version@"
+
+@@ -12,6 +10,8 @@
+ #include <sys/stat.h>
+ #include <fcntl.h>
+
++using namespace std;
++
+ typedef FILE *PFILE;
+
+ #define SemKey 4711
diff --git a/benchmarks/bonnie++/files/patch-duration.cpp b/benchmarks/bonnie++/files/patch-duration.cpp
new file mode 100644
index 000000000000..d24d13c0da1a
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-duration.cpp
@@ -0,0 +1,17 @@
+--- duration.cpp.orig 2009-08-21 18:45:50.068536643 +0000
++++ duration.cpp 2009-08-21 18:45:58.564755017 +0000
+@@ -1,5 +1,3 @@
+-using namespace std;
+-
+ #include <stdlib.h>
+
+ #include "duration.h"
+@@ -20,6 +18,8 @@
+ #endif
+ #endif
+
++using namespace std;
++
+ Duration_Base::Duration_Base()
+ : m_start(0.0)
+ , m_max(0.0)
diff --git a/benchmarks/bonnie++/files/patch-port.h.in b/benchmarks/bonnie++/files/patch-port.h.in
index cce0fa045dc7..2bad1853b0bd 100644
--- a/benchmarks/bonnie++/files/patch-port.h.in
+++ b/benchmarks/bonnie++/files/patch-port.h.in
@@ -1,21 +1,35 @@
--- port.h.in.orig 2009-08-21 18:45:50.068536643 +0000
+++ port.h.in 2009-08-21 18:45:58.564755017 +0000
-@@ -3,18 +3,8 @@
-
+@@ -4,12 +4,12 @@
#include "conf.h"
--#ifndef HAVE_MIN_MAX
+ #ifndef HAVE_MIN_MAX
-#if defined(HAVE_ALGO_H) || defined(HAVE_ALGO)
-#ifdef HAVE_ALGO
--#include <algo>
++#if defined(HAVE_ALGORITHM)
++#include <algorithm>
++#elif defined(HAVE_ALGO)
+ #include <algo>
-#else
--#include <algo.h>
++#elif defined(HAVE_ALGO_H)
+ #include <algo.h>
-#endif
--#else
+ #else
#define min(XX,YY) ((XX) < (YY) ? (XX) : (YY))
#define max(XX,YY) ((XX) > (YY) ? (XX) : (YY))
+@@ -19,14 +19,7 @@
+ @semun@
+ @bool@
+ @snprintf@
+-#ifndef _LARGEFILE64_SOURCE
+-@large_file@
-#endif
+-#ifdef _LARGEFILE64_SOURCE
+-#define OFF_T_PRINTF "%lld"
+-#else
+-#define OFF_T_PRINTF "%d"
-#endif
++#define OFF_T_PRINTF "%ld"
- @semun@
- @bool@
+ #if @true_false@
+ #define false 0
diff --git a/benchmarks/bonnie++/files/patch-rand.h b/benchmarks/bonnie++/files/patch-rand.h
new file mode 100644
index 000000000000..9d411036e6bb
--- /dev/null
+++ b/benchmarks/bonnie++/files/patch-rand.h
@@ -0,0 +1,15 @@
+--- rand.h.orig 2009-08-21 18:45:50.068536643 +0000
++++ rand.h 2009-08-21 18:45:58.564755017 +0000
+@@ -1,11 +1,11 @@
+ #ifndef RAND_H
+ #define RAND_H
+
+-using namespace std;
+ #include "port.h"
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string>
++using namespace std;
+
+ class Rand
+ {