aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/bonnie++
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-22 00:46:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-22 00:46:43 +0000
commitd53f53c3b1cc126d4a5daab1c0f58fd04bb39b16 (patch)
tree719eb025b8e95c4be83724a77817adbc3e8b703b /benchmarks/bonnie++
parent7ec54f887911308313622b9f0b42d01cd79560a7 (diff)
downloadports-d53f53c3b1cc126d4a5daab1c0f58fd04bb39b16.tar.gz
ports-d53f53c3b1cc126d4a5daab1c0f58fd04bb39b16.zip
- Our other two 64-bit platforms needs min(int, int) workaround too
- Unmark broken as it builds on Bento at least for i386. I got some feedback that it builds with gcc 3.3.3, but not with 3.3.1 Tested by: Koop Mast (on sparc64) Approved by: adamw (mentor)
Notes
Notes: svn path=/head/; revision=94685
Diffstat (limited to 'benchmarks/bonnie++')
-rw-r--r--benchmarks/bonnie++/Makefile8
-rw-r--r--benchmarks/bonnie++/files/patch-getc_putc.cpp2
2 files changed, 2 insertions, 8 deletions
diff --git a/benchmarks/bonnie++/Makefile b/benchmarks/bonnie++/Makefile
index a5d777e8ad65..d8115e211166 100644
--- a/benchmarks/bonnie++/Makefile
+++ b/benchmarks/bonnie++/Makefile
@@ -19,12 +19,6 @@ COMMENT= Performance Test of Filesystem I/O
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501103
-BROKEN= "Does not build with gcc 3.3; author is aware of the problem"
-.endif
-
MAN1= bon_csv2html.1 bon_csv2txt.1 generate_randfile.1
MAN8= bonnie++.8 getc_putc.8 zcav.8
@@ -35,4 +29,4 @@ post-install:
@${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/readme.html ${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/benchmarks/bonnie++/files/patch-getc_putc.cpp b/benchmarks/bonnie++/files/patch-getc_putc.cpp
index fbabf3e53905..bad9550b0938 100644
--- a/benchmarks/bonnie++/files/patch-getc_putc.cpp
+++ b/benchmarks/bonnie++/files/patch-getc_putc.cpp
@@ -4,7 +4,7 @@
#include "duration.h"
#include "getc_putc.h"
-+#if defined(__alpha__) || defined(__sparc64__)
++#if defined(__alpha__) || defined(__sparc64__) || defined(__amd64__) || defined(__ia64__)
+/* Work around for: line 168, no matching function for call to `min(long unsigned int, unsigned int)' */
+#include <sys/param.h>
+#define min MIN