aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/clpeak
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2016-06-27 10:56:14 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2016-06-27 10:56:14 +0000
commit542cd0842607c909c877863a282853066c72bca9 (patch)
tree24bbabda50b12b9697bd79e36a336f80cda07de2 /benchmarks/clpeak
parent1b90788d0e23801f6780bbcffed7c6180a6a00bc (diff)
downloadports-542cd0842607c909c877863a282853066c72bca9.tar.gz
ports-542cd0842607c909c877863a282853066c72bca9.zip
Add clpeak 1.0, benchmarking tool to measure peak capabilities of opencl
devices. PR: 209849 Submitted by: Johannes Dieterich <dieterich@ogolem.org>
Notes
Notes: svn path=/head/; revision=417650
Diffstat (limited to 'benchmarks/clpeak')
-rw-r--r--benchmarks/clpeak/Makefile38
-rw-r--r--benchmarks/clpeak/distinfo2
-rw-r--r--benchmarks/clpeak/files/patch-src_include_common.h31
-rw-r--r--benchmarks/clpeak/pkg-descr9
4 files changed, 80 insertions, 0 deletions
diff --git a/benchmarks/clpeak/Makefile b/benchmarks/clpeak/Makefile
new file mode 100644
index 000000000000..165af0a717dd
--- /dev/null
+++ b/benchmarks/clpeak/Makefile
@@ -0,0 +1,38 @@
+# Created by: Johannes Dieterich <dieterich@ogolem.org>
+# $FreeBSD$
+
+PORTNAME= clpeak
+PORTVERSION= 1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= benchmarks
+
+MAINTAINER= dieterich@ogolem.org
+COMMENT= Benchmarking tool to measure peak capabilities of opencl devices
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= opencl>=0:devel/opencl
+LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
+ libGL.so:graphics/libGL
+RUN_DEPENDS= opencl>=0:devel/opencl
+
+BROKEN_FreeBSD_9= clpeak is only supported on FreeBSD 10.1 and newer
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON_amd64= only builds and is supported on amd64
+
+USE_GITHUB= yes
+GH_ACCOUNT= krrishnarraj
+GH_PROJECT= clpeak
+
+USE_LDCONFIG= yes
+USES= cmake
+
+CXXFLAGS+= -std=c++11
+
+PLIST_FILES= bin/clpeak
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/clpeak ${STAGEDIR}${PREFIX}/bin/clpeak
+
+.include <bsd.port.mk>
diff --git a/benchmarks/clpeak/distinfo b/benchmarks/clpeak/distinfo
new file mode 100644
index 000000000000..1825942ae634
--- /dev/null
+++ b/benchmarks/clpeak/distinfo
@@ -0,0 +1,2 @@
+SHA256 (krrishnarraj-clpeak-v1.0_GH0.tar.gz) = 97b738c80319807d9b20294f778dfbbe81f83bf903dd3b46619b1a71a067e469
+SIZE (krrishnarraj-clpeak-v1.0_GH0.tar.gz) = 95681
diff --git a/benchmarks/clpeak/files/patch-src_include_common.h b/benchmarks/clpeak/files/patch-src_include_common.h
new file mode 100644
index 000000000000..a82d8d3f4fe5
--- /dev/null
+++ b/benchmarks/clpeak/files/patch-src_include_common.h
@@ -0,0 +1,31 @@
+--- src/include/common.h.orig 2016-05-28 05:15:40 UTC
++++ src/include/common.h
+@@ -8,13 +8,19 @@
+ #include <CL/cl.hpp>
+ #endif
+
++#ifdef __FreeBSD__
++ #include <sys/types.h>
++#endif
++
+ #include <stdlib.h>
+ #include <chrono>
+ #include <string>
+
+ #define TAB " "
+ #define NEWLINE "\n"
++#ifndef __FreeBSD__
+ #define uint unsigned int
++#endif
+
+ #define MAX(X, Y) \
+ (X > Y)? X: Y;
+@@ -41,6 +47,8 @@
+ #elif defined(__arm__)
+ #define OS_NAME "Linux ARM"
+ #endif
++#elif defined(__FreeBSD__)
++ #define OS_NAME "FreeBSD"
+ #endif
+
+
diff --git a/benchmarks/clpeak/pkg-descr b/benchmarks/clpeak/pkg-descr
new file mode 100644
index 000000000000..0dc6bfc7706e
--- /dev/null
+++ b/benchmarks/clpeak/pkg-descr
@@ -0,0 +1,9 @@
+clpeak
+
+a synthetic benchmarking tool to measure peak capabilities of opencl devices
+
+A synthetic benchmarking tool to measure peak capabilities of opencl devices.
+It only measures the peak metrics that can be achieved using vector operations
+and does not represent a real-world use case
+
+WWW: https://github.com/krrishnarraj/clpeak