aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/dbench/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2002-02-24 03:46:12 +0000
committerMark Pulford <markp@FreeBSD.org>2002-02-24 03:46:12 +0000
commitc89ab4991bdbcc2f20608f1f1095b2e5e23c1e6b (patch)
treeb759a19c29737cfe1a80494c287e353ff8d4c108 /benchmarks/dbench/Makefile
parent9ad8337c754f20e08a9f4c152de38131b074cc4d (diff)
downloadports-c89ab4991bdbcc2f20608f1f1095b2e5e23c1e6b.tar.gz
ports-c89ab4991bdbcc2f20608f1f1095b2e5e23c1e6b.zip
Add dbench 1.3, a simulation of the Ziff-Davis netbench benchmark.
PR: 35055 Submitted by: Andrew Shevtsov <nyxo@dnuc.polyn.kiae.su>
Notes
Notes: svn path=/head/; revision=55154
Diffstat (limited to 'benchmarks/dbench/Makefile')
-rw-r--r--benchmarks/dbench/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/benchmarks/dbench/Makefile b/benchmarks/dbench/Makefile
new file mode 100644
index 000000000000..f70dc13c8bd6
--- /dev/null
+++ b/benchmarks/dbench/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: dbench
+# Date created: 18 Febrary 2002
+# Whom: Andrew Shevtsov <nyxo@dnuc.polyn.kiae.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbench
+PORTVERSION= 1.3
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://samba.org/pub/tridge/dbench/
+
+MAINTAINER= nyxo@dnuc.polyn.kiae.su
+
+WRKSRC= ${WRKDIR}/dbench
+
+post-patch:
+ @${PERL} -pi -e 's/^CFLAGS.+//g' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dbench ${PREFIX}/bin/dbench
+ ${INSTALL_PROGRAM} ${WRKSRC}/tbench ${PREFIX}/bin/tbench
+ ${INSTALL_PROGRAM} ${WRKSRC}/tbench_srv ${PREFIX}/bin/tbench_srv
+
+.include <bsd.port.mk>