aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/fio
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-06-13 04:12:58 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-06-13 04:12:58 +0000
commitbcb54d3123322d1ffd5d92500f77bfeda158918c (patch)
treea6357ac9daccd6e77d946826078f4228d36568be /benchmarks/fio
parent1377dcaf29d80a1de9682aa9eb111caf9e3c5a3e (diff)
downloadports-bcb54d3123322d1ffd5d92500f77bfeda158918c.tar.gz
ports-bcb54d3123322d1ffd5d92500f77bfeda158918c.zip
Fix build on armv6, unbreak on aarch64
PR: 228042 Submitted by: mikael.urankar Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=472282
Diffstat (limited to 'benchmarks/fio')
-rw-r--r--benchmarks/fio/Makefile3
-rw-r--r--benchmarks/fio/files/patch-arch_arch-arm.h16
2 files changed, 16 insertions, 3 deletions
diff --git a/benchmarks/fio/Makefile b/benchmarks/fio/Makefile
index e7e68a5dd42c..fca23c03c99b 100644
--- a/benchmarks/fio/Makefile
+++ b/benchmarks/fio/Makefile
@@ -11,9 +11,6 @@ COMMENT= FIO - flexible IO tester
LICENSE= GPLv2
-BROKEN_armv6= Fails to compile: unsupported ARM architecture
-BROKEN_armv7= Fails to compile: unsupported ARM architecture
-
USES= gmake tar:bzip2
OPTIONS_DEFINE= GNUPLOT EXAMPLES
diff --git a/benchmarks/fio/files/patch-arch_arch-arm.h b/benchmarks/fio/files/patch-arch_arch-arm.h
new file mode 100644
index 000000000000..d1c9500a8deb
--- /dev/null
+++ b/benchmarks/fio/files/patch-arch_arch-arm.h
@@ -0,0 +1,16 @@
+--- benchmarks/fio/files/patch-arch_arch-arm.h (nonexistent)
++++ benchmarks/fio/files/patch-arch_arch-arm.h (working copy)
+@@ -0,0 +1,12 @@
++--- arch/arch-arm.h.orig 2018-05-07 14:59:32 UTC
+++++ arch/arch-arm.h
++@@ -6,7 +6,8 @@
++ #if defined (__ARM_ARCH_4__) || defined (__ARM_ARCH_4T__) \
++ || defined (__ARM_ARCH_5__) || defined (__ARM_ARCH_5T__) || defined (__ARM_ARCH_5E__)\
++ || defined (__ARM_ARCH_5TE__) || defined (__ARM_ARCH_5TEJ__) \
++- || defined(__ARM_ARCH_6__) || defined(__ARM_ARCH_6J__) || defined(__ARM_ARCH_6Z__) || defined(__ARM_ARCH_6ZK__)
+++ || defined(__ARM_ARCH_6__) || defined(__ARM_ARCH_6J__) || defined(__ARM_ARCH_6Z__) || defined(__ARM_ARCH_6ZK__) \
+++ || defined(__ARM_ARCH_6KZ__)
++ #define nop __asm__ __volatile__("mov\tr0,r0\t@ nop\n\t")
++ #define read_barrier() __asm__ __volatile__ ("" : : : "memory")
++ #define write_barrier() __asm__ __volatile__ ("" : : : "memory")
+