aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/forkbomb
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-01-22 17:57:44 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-01-22 17:57:44 +0000
commit22aca060671c5917f46c615ded445a512de28fdb (patch)
tree6b964a3369d72376b3593b3201e36cfe44d6574c /benchmarks/forkbomb
parent4be888969202b385551a3580c4be9c5049abdf41 (diff)
downloadports-22aca060671c5917f46c615ded445a512de28fdb.tar.gz
ports-22aca060671c5917f46c615ded445a512de28fdb.zip
Add forkbomb 1.0, system stress testing tool.
PR: ports/61717 Submitted by: Radim Kolar Approved by: nork (mentor/implicitly)
Notes
Notes: svn path=/head/; revision=98814
Diffstat (limited to 'benchmarks/forkbomb')
-rw-r--r--benchmarks/forkbomb/Makefile20
-rw-r--r--benchmarks/forkbomb/distinfo1
-rw-r--r--benchmarks/forkbomb/files/patch-forkbomb.813
-rw-r--r--benchmarks/forkbomb/pkg-descr9
-rw-r--r--benchmarks/forkbomb/pkg-plist1
5 files changed, 44 insertions, 0 deletions
diff --git a/benchmarks/forkbomb/Makefile b/benchmarks/forkbomb/Makefile
new file mode 100644
index 000000000000..b784505e5c44
--- /dev/null
+++ b/benchmarks/forkbomb/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: forkbomb
+# Date created: 21 Jan 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= forkbomb
+PORTVERSION= 1.0
+CATEGORIES= benchmarks
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= system/benchmark
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= System stress testing tool
+
+USE_GETOPT_LONG=yes
+MAN8= forkbomb.8
+
+.include <bsd.port.mk>
diff --git a/benchmarks/forkbomb/distinfo b/benchmarks/forkbomb/distinfo
new file mode 100644
index 000000000000..36d93977fe41
--- /dev/null
+++ b/benchmarks/forkbomb/distinfo
@@ -0,0 +1 @@
+MD5 (forkbomb-1.0.tar.gz) = 9419b7740fab3e36e2b275c931363b41
diff --git a/benchmarks/forkbomb/files/patch-forkbomb.8 b/benchmarks/forkbomb/files/patch-forkbomb.8
new file mode 100644
index 000000000000..7306c1d469b1
--- /dev/null
+++ b/benchmarks/forkbomb/files/patch-forkbomb.8
@@ -0,0 +1,13 @@
+--- forkbomb.8.orig Thu Jan 22 18:50:56 2004
++++ forkbomb.8 Thu Jan 22 18:51:54 2004
+@@ -86,8 +86,10 @@
+ .TP
+ .B Linux 2.4
+ dead.
++.TP
+ .B Linux 2.6
+ ls command takes between 100 to 200 seconds. System load was 840.
++.TP
+ .B FreeBSD 5.2
+ ls command takes 70 seconds to execute. System load was 800.
+ .SH "TODO"
diff --git a/benchmarks/forkbomb/pkg-descr b/benchmarks/forkbomb/pkg-descr
new file mode 100644
index 000000000000..efac7a99671f
--- /dev/null
+++ b/benchmarks/forkbomb/pkg-descr
@@ -0,0 +1,9 @@
+forkbomb is tool for stress testing. It can create many processes using fork(),
+eats all available memory using realloc() and accesses this memory. It has
+different switches for fine-tuning operation. While classic fork() bomb is good
+only for fun, running multiple memory-eaters can be useful for determining
+maximum memory which can be given to servers (bind or squid) without taking
+machine down. You can test different operation systems with this tool and see
+how they are handling the load.
+
+WWW: http://home.worldonline.cz/~cz210552/forkbomb.html
diff --git a/benchmarks/forkbomb/pkg-plist b/benchmarks/forkbomb/pkg-plist
new file mode 100644
index 000000000000..7c3d45c645a8
--- /dev/null
+++ b/benchmarks/forkbomb/pkg-plist
@@ -0,0 +1 @@
+sbin/forkbomb