aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/hpl/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2010-01-11 20:02:23 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2010-01-11 20:02:23 +0000
commit2342b92830f4f885be726c2d3657eb52a66b5970 (patch)
treea9ff4a1793a662c6e32fbab3bc6fe8d558aeef20 /benchmarks/hpl/Makefile
parent3af52d3b79ad9ba8982be7b7e0b105c24e3ac602 (diff)
downloadports-2342b92830f4f885be726c2d3657eb52a66b5970.tar.gz
ports-2342b92830f4f885be726c2d3657eb52a66b5970.zip
specifiy explicit RUN_DEPENDS instead of RUN=BUILD
PR: 142176 Submitted by: Sevan Janiyan <venture37@geeklan.co.uk>
Notes
Notes: svn path=/head/; revision=247627
Diffstat (limited to 'benchmarks/hpl/Makefile')
-rw-r--r--benchmarks/hpl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index 9a385e984d77..14d95dbfbe74 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= hpl
PORTVERSION= 2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= benchmarks
MASTER_SITES= http://www.netlib.org/benchmark/hpl/
@@ -16,13 +16,14 @@ COMMENT= High Performance Computing Linpack Benchmark
.if !defined(WITH_LAM)
BUILD_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
.else
BUILD_DEPENDS= ${LOCALBASE}/bin/lamd:${PORTSDIR}/net/lam
+RUN_DEPENDS= ${LOCALBASE}/bin/lamd:${PORTSDIR}/net/lam
CC= ${LOCALBASE}/bin/mpicc
FC= ${LOCALBASE}/bin/mpicc
.endif
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_FORTRAN= yes
.include <bsd.port.pre.mk>