aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/hpl/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-02-16 17:15:31 +0000
commit564a799c7173c288d4d3a9be78ac3d2db983d512 (patch)
tree49e521faa408bc4bd163bfb0febf91e262772c1c /benchmarks/hpl/Makefile
parentaf1790bfbbcd5831281907db9c04f3776b8d601c (diff)
downloadports-564a799c7173c288d4d3a9be78ac3d2db983d512.tar.gz
ports-564a799c7173c288d4d3a9be78ac3d2db983d512.zip
Convert all USE_FORTRAN=yes to "USES=fortran, USE_GCC=yes". In most cases
USE_GCC=yes has been omitted though. Remove USE_FORTRAN handling from bsd.port.mk and bsd.gcc.mk. Minor cleanups in some ports like USE_GMAKE, NOPORTDOCS,... Exp-run: bdrewery Approved by: portmgr (bdrewery)
Notes
Notes: svn path=/head/; revision=344614
Diffstat (limited to 'benchmarks/hpl/Makefile')
-rw-r--r--benchmarks/hpl/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index 2db524d36734..3a302e8b5073 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -14,7 +14,7 @@ COMMENT= High Performance Computing Linpack Benchmark
LIB_DEPENDS= libblas.so:${PORTSDIR}/math/blas \
libmpich.so:${PORTSDIR}/net/mpich2
-USE_FORTRAN= yes
+USES= fortran
USE_LDCONFIG= yes
HPL_ARCH?= FreeBSD_PIV_CBLAS
MAKE_ARGS= arch=${HPL_ARCH}