aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/hpl
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2009-01-24 08:29:47 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2009-01-24 08:29:47 +0000
commite58eb79416f0b2f34c2947ded1439fc272b57257 (patch)
tree7fccd0e9ac5834151b5e4f327cafd1f2f91eafe5 /benchmarks/hpl
parentc23079440bbf8723ff5ec3a1e64cb63cdb5f6915 (diff)
downloadports-e58eb79416f0b2f34c2947ded1439fc272b57257.tar.gz
ports-e58eb79416f0b2f34c2947ded1439fc272b57257.zip
reactivate mpich - but mpich2 this time
Notes
Notes: svn path=/head/; revision=226763
Diffstat (limited to 'benchmarks/hpl')
-rw-r--r--benchmarks/hpl/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/benchmarks/hpl/Makefile b/benchmarks/hpl/Makefile
index 1124bc68a062..3bf0e1a0d638 100644
--- a/benchmarks/hpl/Makefile
+++ b/benchmarks/hpl/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: physfs
+# New ports collection makefile for: hpl
# Date Created: 22 February 2003
# Whom: Oliver Lehmann <oliver@FreeBSD.org>
#
@@ -7,16 +7,20 @@
PORTNAME= hpl
PORTVERSION= 2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= benchmarks
MASTER_SITES= http://www.netlib.org/benchmark/hpl/
MAINTAINER= oliver@FreeBSD.org
COMMENT= High Performance Computing Linpack Benchmark
+.if !defined(WITH_LAM)
+BUILD_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+.else
BUILD_DEPENDS= ${LOCALBASE}/bin/lamd:${PORTSDIR}/net/lam
CC= ${LOCALBASE}/bin/mpicc
FC= ${LOCALBASE}/bin/mpicc
+.endif
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_FORTRAN= yes
@@ -71,18 +75,24 @@ MAN3= HPL_abort.3 HPL_all_reduce.3 HPL_barrier.3 HPL_bcast.3 \
post-patch:
@${REINPLACE_CMD} -e 's|^TOPdir[ ]*=.*$$|TOPdir = ${WRKSRC}| ; \
- s|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}/mpich| ; \
+ s|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}/mpich2| ; \
s|^LAdir[ ]*=.*$$|LAdir = ${LOCALBASE}/lib| ; \
s|^CC[ ]*=.*$$|CC = ${CC}| ; \
s|^CCFLAGS[ ]*=.*$$|CCFLAGS = $$\(HPL_DEFS\) ${CFLAGS} -fomit-frame-pointer -funroll-loops| ; \
s|^LINKER[ ]*=.*$$|LINKER = ${FC}| ; \
s|^ARCHIVER[ ]*=.*$$|ARCHIVER = ${AR}| ; \
- s|ARCH[ )]|_&|g' \
+ s|ARCH[ )]|_&|g ; \
+ s|libpmpich|libmpich|g' \
${WRKSRC}/setup/Make.${HPL_ARCH}
+.if defined(WITH_LAM)
@${REINPLACE_CMD} -e 's|^MPdir[ ]*=.*$$|#&| ; s|^MPinc[ ]*=.*$$|#&| ; \
s|^MPlib[ ]*=.*$$|MPlib = /usr/lib/libg2c.a|' \
${WRKSRC}/setup/Make.${HPL_ARCH}
+.else
+ @${REINPLACE_CMD} -e 's|^MPdir[ ]*=.*$$|MPdir = ${LOCALBASE}/mpich2|' \
+ ${WRKSRC}/setup/Make.${HPL_ARCH}
+.endif
.if defined(WITH_BLAS)
@${REINPLACE_CMD} -e 's|^HPL_OPTS[ ]*=.*$$|HPL_OPTS =| ; \