aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/hyperfine/Makefile
diff options
context:
space:
mode:
authorLuca Pizzamiglio <pizzamig@FreeBSD.org>2022-03-11 09:10:27 +0000
committerLuca Pizzamiglio <pizzamig@FreeBSD.org>2022-03-11 09:10:27 +0000
commit81292c9a2074f8e87078c028f00be0b8a237a395 (patch)
tree46f1a7a3615860dda78046c75c4d71f27fbee7d2 /benchmarks/hyperfine/Makefile
parent034fd79175f0ed6e199c616373d457d86f0a2755 (diff)
benchmarks/hyperfine: Update to v1.13.0
Diffstat (limited to 'benchmarks/hyperfine/Makefile')
-rw-r--r--benchmarks/hyperfine/Makefile79
1 files changed, 43 insertions, 36 deletions
diff --git a/benchmarks/hyperfine/Makefile b/benchmarks/hyperfine/Makefile
index 522a65eb98e2..a9145b61f00b 100644
--- a/benchmarks/hyperfine/Makefile
+++ b/benchmarks/hyperfine/Makefile
@@ -1,7 +1,7 @@
PORTNAME= hyperfine
DISTVERSIONPREFIX= v
-DISTVERSION= 1.12.0
-PORTREVISION= 3
+DISTVERSION= 1.13.0
+PORTREVISION= 0
CATEGORIES= benchmarks
MAINTAINER= pizzamig@FreeBSD.org
@@ -21,17 +21,18 @@ GH_ACCOUNT= sharkdp
PLIST_FILES= bin/hyperfine
CARGO_CRATES= aho-corasick-0.7.18 \
- ansi_term-0.11.0 \
- approx-0.5.0 \
- arrayvec-0.5.2 \
- assert_cmd-2.0.2 \
+ anyhow-1.0.55 \
+ approx-0.5.1 \
+ arrayvec-0.7.2 \
+ assert_cmd-2.0.4 \
atty-0.2.14 \
- autocfg-0.1.7 \
- autocfg-1.0.1 \
+ autocfg-0.1.8 \
+ autocfg-1.1.0 \
bitflags-1.3.2 \
bstr-0.2.17 \
cfg-if-1.0.0 \
- clap-2.33.3 \
+ clap-3.1.5 \
+ clap_complete-3.1.1 \
cloudabi-0.0.3 \
colored-2.0.0 \
console-0.15.0 \
@@ -41,15 +42,20 @@ CARGO_CRATES= aho-corasick-0.7.18 \
doc-comment-0.3.3 \
either-1.6.1 \
encode_unicode-0.3.6 \
+ fastrand-1.7.0 \
float-cmp-0.9.0 \
fuchsia-cprng-0.1.1 \
- getrandom-0.2.3 \
+ getrandom-0.2.5 \
+ hashbrown-0.11.2 \
hermit-abi-0.1.19 \
+ indexmap-1.8.0 \
indicatif-0.16.2 \
- itertools-0.10.1 \
+ instant-0.1.12 \
+ itertools-0.10.3 \
itoa-0.4.8 \
+ itoa-1.0.1 \
lazy_static-1.4.0 \
- libc-0.2.104 \
+ libc-0.2.119 \
memchr-2.4.1 \
normalize-line-endings-0.3.0 \
num-0.2.1 \
@@ -60,54 +66,55 @@ CARGO_CRATES= aho-corasick-0.7.18 \
num-rational-0.2.4 \
num-traits-0.2.14 \
number_prefix-0.4.0 \
- once_cell-1.8.0 \
- ppv-lite86-0.2.14 \
- predicates-2.0.3 \
- predicates-core-1.0.2 \
- predicates-tree-1.0.4 \
- proc-macro2-1.0.30 \
- quote-1.0.10 \
+ once_cell-1.10.0 \
+ os_str_bytes-6.0.0 \
+ ppv-lite86-0.2.16 \
+ predicates-2.1.1 \
+ predicates-core-1.0.3 \
+ predicates-tree-1.0.5 \
+ proc-macro2-1.0.36 \
+ quote-1.0.15 \
rand-0.6.5 \
- rand-0.8.4 \
+ rand-0.8.5 \
rand_chacha-0.1.1 \
rand_chacha-0.3.1 \
rand_core-0.3.1 \
rand_core-0.4.2 \
rand_core-0.6.3 \
rand_hc-0.1.0 \
- rand_hc-0.3.1 \
rand_isaac-0.1.1 \
rand_jitter-0.1.4 \
rand_os-0.1.3 \
rand_pcg-0.1.2 \
rand_xorshift-0.1.1 \
rdrand-0.4.0 \
- redox_syscall-0.2.10 \
+ redox_syscall-0.2.11 \
regex-1.5.4 \
regex-automata-0.1.10 \
regex-syntax-0.6.25 \
remove_dir_all-0.5.3 \
- rust_decimal-1.16.0 \
- ryu-1.0.5 \
- serde-1.0.130 \
- serde_derive-1.0.130 \
- serde_json-1.0.68 \
- shell-words-1.0.0 \
+ rust_decimal-1.22.0 \
+ ryu-1.0.9 \
+ serde-1.0.136 \
+ serde_derive-1.0.136 \
+ serde_json-1.0.79 \
+ shell-words-1.1.0 \
statistical-1.0.0 \
- strsim-0.8.0 \
- syn-1.0.80 \
- tempfile-3.2.0 \
- term_size-0.3.2 \
+ strsim-0.10.0 \
+ syn-1.0.86 \
+ tempfile-3.3.0 \
+ termcolor-1.1.3 \
terminal_size-0.1.17 \
- termtree-0.2.1 \
- textwrap-0.11.0 \
- unicode-width-0.1.9 \
+ termtree-0.2.4 \
+ textwrap-0.15.0 \
+ thiserror-1.0.30 \
+ thiserror-impl-1.0.30 \
unicode-xid-0.2.2 \
- vec_map-0.8.2 \
wait-timeout-0.2.0 \
wasi-0.10.2+wasi-snapshot-preview1 \
winapi-0.3.9 \
winapi-i686-pc-windows-gnu-0.4.0 \
+ winapi-util-0.1.5 \
winapi-x86_64-pc-windows-gnu-0.4.0
post-install: