aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/imb
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-03 18:34:46 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-03 18:34:46 +0000
commitc2844ed37527438fb8b3fd17b2ed9ca60360b5dc (patch)
tree534adab6e962a18d453a7902b2338052421b3ddf /benchmarks/imb
parent08322758f0b52cc1498e769ceccf28283cd0d68b (diff)
downloadports-c2844ed37527438fb8b3fd17b2ed9ca60360b5dc.tar.gz
ports-c2844ed37527438fb8b3fd17b2ed9ca60360b5dc.zip
Allow the port to go a bit further in the build process.
Instead of complaining that `gmake' does not exist, the port fails a bit later and at least starts building. The previous failure was caused because we used USES=gmake but then re-set BUILD_DEPENDS and MAKE_ENV a few lines below in the Makefile.
Notes
Notes: svn path=/head/; revision=332638
Diffstat (limited to 'benchmarks/imb')
-rw-r--r--benchmarks/imb/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/benchmarks/imb/Makefile b/benchmarks/imb/Makefile
index 6cba9277d630..bbc6c7c7b0e6 100644
--- a/benchmarks/imb/Makefile
+++ b/benchmarks/imb/Makefile
@@ -39,13 +39,13 @@ WITH_OPENMPI= yes
.endif
.if defined(WITH_OPENMPI)
-BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
-RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
-MAKE_ENV= MPI_HOME=${LOCALBASE}/mpi/openmpi
+BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:${PORTSDIR}/net/openmpi
+RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+MAKE_ENV+= MPI_HOME=${LOCALBASE}/mpi/openmpi
.else
-BUILD_DEPENDS= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
-MAKE_ENV= MPI_HOME=${LOCALBASE}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+MAKE_ENV+= MPI_HOME=${LOCALBASE}
.endif
do-install: