aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/iozone
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-09-20 06:23:33 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-09-20 06:23:33 +0000
commitc184a462da44d2b2df49ab4b22b23538fdcc8293 (patch)
treee1eb374b53aac448982f6ab3d17cef3c8e3fea34 /benchmarks/iozone
parentcacc8b9757d24e871a9a325beb65ab8963c5763b (diff)
downloadports-c184a462da44d2b2df49ab4b22b23538fdcc8293.tar.gz
ports-c184a462da44d2b2df49ab4b22b23538fdcc8293.zip
- update to 3.420
PR: 182111 Submitted by: cmt@burggraben.net Approved by: chifeng@gmail.com ( maintainer )
Notes
Notes: svn path=/head/; revision=327656
Diffstat (limited to 'benchmarks/iozone')
-rw-r--r--benchmarks/iozone/Makefile4
-rw-r--r--benchmarks/iozone/distinfo4
-rw-r--r--benchmarks/iozone/files/patch-libasync.c4
-rw-r--r--benchmarks/iozone/files/patch-libbif.c4
4 files changed, 8 insertions, 8 deletions
diff --git a/benchmarks/iozone/Makefile b/benchmarks/iozone/Makefile
index 370840a3873f..36995150dd55 100644
--- a/benchmarks/iozone/Makefile
+++ b/benchmarks/iozone/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= iozone
-PORTVERSION= 3.397
+PORTVERSION= 3.420
CATEGORIES= benchmarks
MASTER_SITES= http://www.iozone.org/src/current/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
@@ -46,6 +46,6 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iozone ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/iozone.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKDIR}/${DISTNAME}/docs/iozone.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/benchmarks/iozone/distinfo b/benchmarks/iozone/distinfo
index 9b7b66a352e6..122fdefcdce9 100644
--- a/benchmarks/iozone/distinfo
+++ b/benchmarks/iozone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (iozone3_397.tar) = 213d8dcc6f70ca93a903b5fbb92cf758fd25617db4c65d188d29594f12b30d30
-SIZE (iozone3_397.tar) = 1679360
+SHA256 (iozone3_420.tar) = f793cc68e86aea5c93fb3010f4088653138a610c3b14047b2314ab6a1f8d5b8e
+SIZE (iozone3_420.tar) = 1832960
diff --git a/benchmarks/iozone/files/patch-libasync.c b/benchmarks/iozone/files/patch-libasync.c
index e0779a5d247c..2ae5ce6b4062 100644
--- a/benchmarks/iozone/files/patch-libasync.c
+++ b/benchmarks/iozone/files/patch-libasync.c
@@ -13,8 +13,8 @@
#include <stdlib.h>
#endif
--#if ((defined(solaris) && defined(__LP64__)) || defined(__s390x__))
-+#if ((defined(solaris) && defined(__LP64__)) || defined(__s390x__)) || defined(__FreeBSD__)
+-#if (defined(solaris) && defined(__LP64__)) || defined(__s390x__) || defined(FreeBSD)
++#if (defined(solaris) && defined(__LP64__)) || defined(__s390x__) || defined(__FreeBSD__)
/* If we are building for 64-bit Solaris, all functions that return pointers
* must be declared before they are used; otherwise the compiler will assume
* that they return ints and the top 32 bits of the pointer will be lost,
diff --git a/benchmarks/iozone/files/patch-libbif.c b/benchmarks/iozone/files/patch-libbif.c
index 9baf918fff6f..b4bdee65849c 100644
--- a/benchmarks/iozone/files/patch-libbif.c
+++ b/benchmarks/iozone/files/patch-libbif.c
@@ -4,8 +4,8 @@
#include <string.h>
#endif
--#if defined(linux) || defined(__DragonFly__) || defined(macosx)
-+#if defined(linux) || defined(__DragonFly__) || defined(macosx) || defined(__FreeBSD__)
+-#if defined(linux) || defined(__DragonFly__) || defined(IOZ_macosx)
++#if defined(linux) || defined(__DragonFly__) || defined(IOZ_macosx) || defined(__FreeBSD__)
#include <unistd.h>
#include <stdlib.h>
#endif