aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/tsung
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-06-04 21:30:22 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-06-04 21:30:22 +0000
commit2a345a381e02ee7f971811285bade052b701a892 (patch)
tree9027238cbe6fdc36979ddb1f2cbbbdf60565aab9 /benchmarks/tsung
parent992ae451699e8992a31c4cb5566d35a091912b62 (diff)
Add tsung 1.2.1, multi-protocol distributed load testing tool.
Notes
Notes: svn path=/head/; revision=192763
Diffstat (limited to 'benchmarks/tsung')
-rw-r--r--benchmarks/tsung/Makefile35
-rw-r--r--benchmarks/tsung/distinfo3
-rw-r--r--benchmarks/tsung/pkg-descr5
-rw-r--r--benchmarks/tsung/pkg-plist176
4 files changed, 219 insertions, 0 deletions
diff --git a/benchmarks/tsung/Makefile b/benchmarks/tsung/Makefile
new file mode 100644
index 000000000000..142e9086f7a7
--- /dev/null
+++ b/benchmarks/tsung/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: tsung
+# Date created: 04 June 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tsung
+PORTVERSION= 1.2.1
+CATEGORIES= benchmarks
+MASTER_SITES= http://tsung.erlang-projects.org/dist/
+DIST_SUBDIR= erlang
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Multi-protocol distributed load testing tool
+
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
+ bash:${PORTSDIR}/shells/bash \
+ gnuplot:${PORTSDIR}/math/gnuplot \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-erlang=${LOCALBASE}
+USE_GMAKE= yes
+USE_PERL5= yes
+
+MAN1= tsung.1
+
+PLIST_SUB+= VERSION="${PORTVERSION}"
+
+post-patch:
+ ${REINPLACE_CMD} -E 's!datadir)/man!prefix)/man!' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/benchmarks/tsung/distinfo b/benchmarks/tsung/distinfo
new file mode 100644
index 000000000000..5cc51dd46436
--- /dev/null
+++ b/benchmarks/tsung/distinfo
@@ -0,0 +1,3 @@
+MD5 (erlang/tsung-1.2.1.tar.gz) = cb784691b3cb8604446cc56819b6b278
+SHA256 (erlang/tsung-1.2.1.tar.gz) = 1835abe088ff6e86aed39bcf99f9960bbd756e4154198e7c7788e3fb70df0de1
+SIZE (erlang/tsung-1.2.1.tar.gz) = 378877
diff --git a/benchmarks/tsung/pkg-descr b/benchmarks/tsung/pkg-descr
new file mode 100644
index 000000000000..cc11b483f543
--- /dev/null
+++ b/benchmarks/tsung/pkg-descr
@@ -0,0 +1,5 @@
+Tsung is a distributed load testing tool. It is protocol-independent
+and can currently be used to stress HTTP, SOAP, PostgreSQL and Jabber
+servers.
+
+WWW: http://tsung.erlang-projects.org/
diff --git a/benchmarks/tsung/pkg-plist b/benchmarks/tsung/pkg-plist
new file mode 100644
index 000000000000..6922ac8372c8
--- /dev/null
+++ b/benchmarks/tsung/pkg-plist
@@ -0,0 +1,176 @@
+bin/tsung
+lib/erlang/lib/tsung-%%VERSION%%/BUILD_OPTIONS
+lib/erlang/lib/tsung-%%VERSION%%/ebin/builder.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/gregexp.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/pgsql_proto.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/pgsql_util.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/snmp_mgr.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/snmp_mgr_misc.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_client.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_client_sup.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_digest.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_http.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_http_common.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_jabber.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_jabber_common.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_launcher.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_pgsql.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_search.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_session_cache.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_stats.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_sup.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/ts_utils.beam
+lib/erlang/lib/tsung-%%VERSION%%/ebin/tsung.app
+lib/erlang/lib/tsung-%%VERSION%%/ebin/tsung.beam
+lib/erlang/lib/tsung-%%VERSION%%/include/rrdtool.hrl
+lib/erlang/lib/tsung-%%VERSION%%/include/ts_config.hrl
+lib/erlang/lib/tsung-%%VERSION%%/include/ts_http.hrl
+lib/erlang/lib/tsung-%%VERSION%%/include/ts_jabber.hrl
+lib/erlang/lib/tsung-%%VERSION%%/include/ts_pgsql.hrl
+lib/erlang/lib/tsung-%%VERSION%%/include/ts_profile.hrl
+lib/erlang/lib/tsung-%%VERSION%%/include/ts_recorder.hrl
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung.boot
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung.rel
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung.script
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_controller.boot
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_controller.rel
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_controller.script
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_controller_load.boot
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_controller_load.script
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_load.boot
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_load.script
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_recorder.boot
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_recorder.rel
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_recorder.script
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_recorder_load.boot
+lib/erlang/lib/tsung-%%VERSION%%/priv/tsung_recorder_load.script
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_client.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_client_sup.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_digest.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_http.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_http_common.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_jabber.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_jabber_common.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_launcher.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_pgsql.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_search.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_session_cache.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_stats.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_sup.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/ts_utils.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/tsung.app.src
+lib/erlang/lib/tsung-%%VERSION%%/src/tsung.erl
+lib/erlang/lib/tsung-%%VERSION%%/src/tsung.rel.src
+lib/tsung/bin/log2tsung.pl
+lib/tsung/bin/tsung_stats.pl
+lib/erlang/lib/tsung_controller-%%VERSION%%/BUILD_OPTIONS
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_config.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_config_http.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_config_jabber.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_config_pgsql.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_config_server.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_controller_sup.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_file_server.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_mon.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_msg_server.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_os_mon.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_timer.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/ts_user_server.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/tsung_controller.app
+lib/erlang/lib/tsung_controller-%%VERSION%%/ebin/tsung_controller.beam
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/rrdtool.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/ts_config.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/ts_http.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/ts_jabber.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/ts_pgsql.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/ts_profile.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/include/ts_recorder.hrl
+lib/erlang/lib/tsung_controller-%%VERSION%%/priv/tsung_controller.boot
+lib/erlang/lib/tsung_controller-%%VERSION%%/priv/tsung_controller.rel
+lib/erlang/lib/tsung_controller-%%VERSION%%/priv/tsung_controller.script
+lib/erlang/lib/tsung_controller-%%VERSION%%/priv/tsung_controller_load.boot
+lib/erlang/lib/tsung_controller-%%VERSION%%/priv/tsung_controller_load.script
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_config.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_config_http.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_config_jabber.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_config_pgsql.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_config_server.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_controller_sup.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_file_server.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_mon.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_msg_server.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_os_mon.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_timer.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/ts_user_server.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/tsung_controller.app.src
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/tsung_controller.erl
+lib/erlang/lib/tsung_controller-%%VERSION%%/src/tsung_controller.rel.src
+lib/erlang/lib/tsung_recorder-%%VERSION%%/BUILD_OPTIONS
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_client_proxy.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_client_proxy_sup.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_proxy_http.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_proxy_listener.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_proxy_pgsql.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_proxy_recorder.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/ts_recorder_sup.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/tsung_recorder.app
+lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin/tsung_recorder.beam
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/rrdtool.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/ts_config.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/ts_http.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/ts_jabber.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/ts_pgsql.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/ts_profile.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/include/ts_recorder.hrl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/priv/tsung_recorder.boot
+lib/erlang/lib/tsung_recorder-%%VERSION%%/priv/tsung_recorder.rel
+lib/erlang/lib/tsung_recorder-%%VERSION%%/priv/tsung_recorder.script
+lib/erlang/lib/tsung_recorder-%%VERSION%%/priv/tsung_recorder_load.boot
+lib/erlang/lib/tsung_recorder-%%VERSION%%/priv/tsung_recorder_load.script
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_client_proxy.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_client_proxy_sup.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_proxy_http.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_proxy_listener.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_proxy_pgsql.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_proxy_recorder.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/ts_recorder_sup.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/tsung_recorder.app.src
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/tsung_recorder.erl
+lib/erlang/lib/tsung_recorder-%%VERSION%%/src/tsung_recorder.rel.src
+%%DATADIR%%/tsung-1.0.dtd
+%%DATADIR%%/templates/footer.thtml
+%%DATADIR%%/templates/graph.thtml
+%%DATADIR%%/templates/header.thtml
+%%DATADIR%%/templates/report.thtml
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%
+@dirrm lib/tsung/bin
+@dirrm lib/tsung
+@dirrm lib/erlang/lib/tsung_recorder-%%VERSION%%/src
+@dirrm lib/erlang/lib/tsung_recorder-%%VERSION%%/priv
+@dirrm lib/erlang/lib/tsung_recorder-%%VERSION%%/include
+@dirrm lib/erlang/lib/tsung_recorder-%%VERSION%%/ebin
+@dirrm lib/erlang/lib/tsung_recorder-%%VERSION%%
+@dirrm lib/erlang/lib/tsung_controller-%%VERSION%%/src
+@dirrm lib/erlang/lib/tsung_controller-%%VERSION%%/priv
+@dirrm lib/erlang/lib/tsung_controller-%%VERSION%%/include
+@dirrm lib/erlang/lib/tsung_controller-%%VERSION%%/ebin
+@dirrm lib/erlang/lib/tsung_controller-%%VERSION%%
+@dirrm lib/erlang/lib/tsung-%%VERSION%%/src
+@dirrm lib/erlang/lib/tsung-%%VERSION%%/priv
+@dirrm lib/erlang/lib/tsung-%%VERSION%%/include
+@dirrm lib/erlang/lib/tsung-%%VERSION%%/ebin
+@dirrm lib/erlang/lib/tsung-%%VERSION%%
+@dirrmtry lib/erlang/lib
+@dirrmtry lib/erlang
+%%DOCSDIR%%/IDXDOC.css
+%%DOCSDIR%%/user_manual.html
+%%DOCSDIR%%/examples/http_distributed.xml
+%%DOCSDIR%%/examples/http_simple.xml
+%%DOCSDIR%%/examples/jabber.xml
+%%DOCSDIR%%/examples/pgsql.xml
+%%DOCSDIR%%/images/tsung-graph.png
+%%DOCSDIR%%/images/tsung-report.png
+@dirrm %%DOCSDIR%%/images
+@dirrm %%DOCSDIR%%/examples
+@dirrm %%DOCSDIR%%