aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/typometer
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-07-01 18:30:30 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-07-01 18:30:30 +0000
commitdda97564c01af79032ee7239d4d881245ac44301 (patch)
tree18c4e44b9802309988bb345dd76b262bab3dc446 /benchmarks/typometer
parentb2f3d8e6b96e139387d6dd86b5efb2e342e86e67 (diff)
downloadports-dda97564c01af79032ee7239d4d881245ac44301.tar.gz
ports-dda97564c01af79032ee7239d4d881245ac44301.zip
Add a port of Typometer, text/code editor typing latency analyzer.
Unfortunately, it's written in Java, but is a nice tool nonetheless. WWW: https://pavelfatin.com/typometer/
Notes
Notes: svn path=/head/; revision=444832
Diffstat (limited to 'benchmarks/typometer')
-rw-r--r--benchmarks/typometer/Makefile39
-rw-r--r--benchmarks/typometer/distinfo3
-rw-r--r--benchmarks/typometer/pkg-descr19
3 files changed, 61 insertions, 0 deletions
diff --git a/benchmarks/typometer/Makefile b/benchmarks/typometer/Makefile
new file mode 100644
index 000000000000..30da496b8410
--- /dev/null
+++ b/benchmarks/typometer/Makefile
@@ -0,0 +1,39 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= typometer
+PORTVERSION= 1.0
+DISTVERSIONSUFFIX= -bin
+CATEGORIES= benchmarks java
+MASTER_SITES= http://freebsd.nsu.ru/distfiles/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Text/code editor typing latency analyzer
+
+LICENSE= GPLv3
+
+USES= zip
+USE_JAVA= yes
+JAVA_VERSION= 1.8+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/${PORTNAME} bin/${PORTNAME}-${PORTVERSION}.jar
+PORTDOCS= README.html
+
+OPTIONS_DEFINE= DOCS
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar \
+ ${STAGEDIR}${PREFIX}/bin
+ ${PRINTF} "!#/bin/sh\n\n%s %s\n" "${JAVA} -jar" \
+ "${PREFIX}/bin/${PORTNAME}-${PORTVERSION}.jar" \
+ > ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+ ${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/benchmarks/typometer/distinfo b/benchmarks/typometer/distinfo
new file mode 100644
index 000000000000..39a11159b6cb
--- /dev/null
+++ b/benchmarks/typometer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1495384190
+SHA256 (typometer-1.0-bin.zip) = e1215b858ea189706d482da56b454bf38b04782cded662dd80c4945f6a942f32
+SIZE (typometer-1.0-bin.zip) = 488689
diff --git a/benchmarks/typometer/pkg-descr b/benchmarks/typometer/pkg-descr
new file mode 100644
index 000000000000..09b9337dedff
--- /dev/null
+++ b/benchmarks/typometer/pkg-descr
@@ -0,0 +1,19 @@
+Typometer is a tool to measure and analyze visual latency of text/code
+editors. Its features:
+
+ - Cross-platform (Windows, Mac, Unix)
+ - Native API calls for faster screen access
+ - Synchronous and asynchronous modes
+ - Import and export of CSV data
+ - Summary statistics, frequency distribution
+ - Line/bar charts (including comparative ones)
+ - Chart image export (with legend)
+
+Editor latency is delay between an input event and a corresponding screen
+update, in particular -- delay between keystroke and character appearance.
+While there are many kinds of delays (caret movement, line editing, etc.),
+typing latency is a major predictor of editor usability.
+
+Java 8 or latter is required to run the program.
+
+WWW: https://pavelfatin.com/typometer/