aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/webbench
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-01-13 22:37:34 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-01-13 22:37:34 +0000
commit878eb58a1e141bfee190a34e47ae54590976ecd0 (patch)
tree7aa672db8cbffa2c1cb66a0c3a0ab876e445a4f9 /benchmarks/webbench
parent4908226c2ea1a32202d004f1ca47b781dee51d9f (diff)
downloadports-878eb58a1e141bfee190a34e47ae54590976ecd0.tar.gz
ports-878eb58a1e141bfee190a34e47ae54590976ecd0.zip
Add webbench 1.3, simple forking web benchmark.
PR: ports/61307 Submitted by: Radim Kolar <hsn@netmag.cz> Approved by: nork (mentor/implicitly)
Notes
Notes: svn path=/head/; revision=98119
Diffstat (limited to 'benchmarks/webbench')
-rw-r--r--benchmarks/webbench/Makefile19
-rw-r--r--benchmarks/webbench/distinfo1
-rw-r--r--benchmarks/webbench/files/patch-Makefile23
-rw-r--r--benchmarks/webbench/pkg-descr7
-rw-r--r--benchmarks/webbench/pkg-plist4
5 files changed, 54 insertions, 0 deletions
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
new file mode 100644
index 000000000000..3cb3f63270ae
--- /dev/null
+++ b/benchmarks/webbench/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: webbench
+# Date created: 10 Jan 2004
+# Whom: Radim Kolar
+#
+# $FreeBSD$
+#
+
+PORTNAME= webbench
+PORTVERSION= 1.3
+CATEGORIES= benchmarks www
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/www/servers
+
+MAINTAINER= hsn@netmag.cz
+COMMENT= Simple forking web benchmark
+
+MAN1= webbench.1
+
+.include <bsd.port.mk>
diff --git a/benchmarks/webbench/distinfo b/benchmarks/webbench/distinfo
new file mode 100644
index 000000000000..ea691dfdf9a5
--- /dev/null
+++ b/benchmarks/webbench/distinfo
@@ -0,0 +1 @@
+MD5 (webbench-1.3.tar.gz) = 05e3125dd060571bcfc76f1e17d69b99
diff --git a/benchmarks/webbench/files/patch-Makefile b/benchmarks/webbench/files/patch-Makefile
new file mode 100644
index 000000000000..3ae9a744cf32
--- /dev/null
+++ b/benchmarks/webbench/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.orig Mon Jan 12 16:36:48 2004
++++ Makefile Tue Jan 13 23:08:29 2004
+@@ -1,17 +1,17 @@
+-CFLAGS= -Wall -ggdb -W -O
+-CC=gcc
+ LIBS=
+ LDFLAGS=
+-PREFIX=/usr/local
+ VERSION=1.3
+ TMPDIR=/tmp/webbench-$(VERSION)
+ all: webbench
+
+ install: webbench
+ install -s webbench $(DESTDIR)$(PREFIX)/bin
++ install webbench.1 $(DESTDIR)$(PREFIX)/man/man1
++.if !defined(NOPORTDOCS)
+ install -d $(DESTDIR)$(PREFIX)/share/doc/webbench
+ install debian/copyright $(DESTDIR)$(PREFIX)/share/doc/webbench
+ install debian/changelog $(DESTDIR)$(PREFIX)/share/doc/webbench
++.endif
+
+ webbench: webbench.o Makefile
+ -ctags *.c
diff --git a/benchmarks/webbench/pkg-descr b/benchmarks/webbench/pkg-descr
new file mode 100644
index 000000000000..dfe95e6ae5ce
--- /dev/null
+++ b/benchmarks/webbench/pkg-descr
@@ -0,0 +1,7 @@
+webbench is very simple tool for benchmarking WWW or proxy servers. Uses fork()
+for simulating multiple clients and can use HTTP/0.9-HTTP/1.1 requests. This
+benchmark is not very realistic, but can test if your HTTPD can realy handle
+many clients at once (try to run some CGIs) without taking your machine down.
+Displays pages/min and bytes/sec.
+
+Radim Kolar
diff --git a/benchmarks/webbench/pkg-plist b/benchmarks/webbench/pkg-plist
new file mode 100644
index 000000000000..79507fa436f3
--- /dev/null
+++ b/benchmarks/webbench/pkg-plist
@@ -0,0 +1,4 @@
+bin/webbench
+%%PORTDOCS%%%%DOCSDIR%%/copyright
+%%PORTDOCS%%%%DOCSDIR%%/changelog
+%%PORTDOCS%%@dirrm %%DOCSDIR%%