aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/webbench
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 00:35:05 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-05 00:35:05 +0000
commite9782e8ecf72f341fca3926802d9f0c9c64ff5e8 (patch)
tree7b3ee374e223b3bb6fa38e07bc8fee4036f06930 /benchmarks/webbench
parent7caed251d85da3d07b15a6303ca6ac15000ae5ab (diff)
downloadports-e9782e8ecf72f341fca3926802d9f0c9c64ff5e8.tar.gz
ports-e9782e8ecf72f341fca3926802d9f0c9c64ff5e8.zip
Support stage
Notes
Notes: svn path=/head/; revision=338715
Diffstat (limited to 'benchmarks/webbench')
-rw-r--r--benchmarks/webbench/Makefile25
1 files changed, 7 insertions, 18 deletions
diff --git a/benchmarks/webbench/Makefile b/benchmarks/webbench/Makefile
index 986c4676322e..8dc0dff1bca5 100644
--- a/benchmarks/webbench/Makefile
+++ b/benchmarks/webbench/Makefile
@@ -12,27 +12,16 @@ COMMENT= Simple forking web benchmark
MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS}"
-.if !defined(NO_INSTALL_MANPAGES)
-MAN1= webbench.1
-.endif
-
PORTDOCS= copyright changelog
-PLIST_FILES= bin/webbench
-
-NO_STAGE= yes
-
-.include <bsd.port.options.mk>
+PLIST_FILES= bin/webbench \
+ man/man1/webbench.1.gz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/webbench ${PREFIX}/bin
-.if !defined(NO_INSTALL_MANPAGES)
- ${INSTALL_MAN} ${WRKSRC}/webbench.1 ${MAN1PREFIX}/man/man1
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/debian/copyright ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/debian/changelog ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/webbench ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/webbench.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/debian/copyright ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/debian/changelog ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>