aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/wrk/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-02-05 21:20:24 +0000
commit6d324c1f70c9ee4ebd41f6a689ac379f8d47927b (patch)
tree7c63a95968ed9b4eb610fca1b72ff17c7d9581c2 /benchmarks/wrk/Makefile
parent2da0cd8de2b6a439333303b69967925ed04914ad (diff)
downloadports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.tar.gz
ports-6d324c1f70c9ee4ebd41f6a689ac379f8d47927b.zip
- Remove inclusion of bsd.default-versions.mk from ftp/curl/Makefile so
bsd.default-versions.mk can rely on ARCH being defined. - In bsd.port.mk move inclusion of bsd.default-versions.mk from the pre-makefile section to the options section so the variables can be used earlier. Also put the bit of code sitting between the options section and the pre-makefile section into the options section. - Remove last few cases where ports set WITH_OPENSSL_PORT. This variable is handled in bsd.default-versions.mk and some ports were setting it after including bsd.port.options.mk. After FreeBSD 9 EoL all but a few ports, and then only when setting non-default options, work without setting that variable. PR: 215996 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=433456
Diffstat (limited to 'benchmarks/wrk/Makefile')
-rw-r--r--benchmarks/wrk/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/benchmarks/wrk/Makefile b/benchmarks/wrk/Makefile
index 9ba0f1a97b8f..0893b971185e 100644
--- a/benchmarks/wrk/Makefile
+++ b/benchmarks/wrk/Makefile
@@ -3,6 +3,7 @@
PORTNAME= wrk
PORTVERSION= 4.0.2
+PORTREVISION= 1
CATEGORIES= benchmarks www
MAINTAINER= osa@FreeBSD.org
@@ -15,11 +16,9 @@ LIB_DEPENDS= libluajit-5.1.so:lang/luajit
USE_GITHUB= yes
GH_ACCOUNT= wg
-USES= gmake
-USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
+USES= gmake ssl
CFLAGS+= -std=c99 -D_DECLARE_C99_LDBL_MATH
-MAKE_ENV+= WITH_OPENSSL=${LOCALBASE} WITH_LUAJIT=${LOCALBASE} VER=${PORTVERSION}
+MAKE_ENV+= WITH_OPENSSL=${OPENSSLBASE} WITH_LUAJIT=${LOCALBASE} VER=${PORTVERSION}
PLIST_FILES= bin/wrk