aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-18 15:42:01 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-18 15:42:01 +0000
commit033a00739a271a5eef2e7ced7a84a7b155aef55d (patch)
treed3218f8a3426685eac51f07cd9abe98c031cf2d5 /benchmarks
parentb653672af9f1ec3a668dc19c6155c9c3a90aa34d (diff)
downloadports-033a00739a271a5eef2e7ced7a84a7b155aef55d.tar.gz
ports-033a00739a271a5eef2e7ced7a84a7b155aef55d.zip
Stage support
Notes
Notes: svn path=/head/; revision=340189
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/dbs/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/benchmarks/dbs/Makefile b/benchmarks/dbs/Makefile
index f495746e49bd..44a7ce3b2835 100644
--- a/benchmarks/dbs/Makefile
+++ b/benchmarks/dbs/Makefile
@@ -26,9 +26,6 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|' ${WRKSRC}/script/dbs_view
@@ -38,22 +35,18 @@ pre-build:
do-install:
.for bin in dbsc dbsd
- cd ${INSTALL_WRKSRC}; ${INSTALL_PROGRAM} ${bin} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/${bin} ${STAGEDIR}${PREFIX}/bin
.endfor
.for bin in dbs_view
- cd ${WRKSRC}/script; ${INSTALL_SCRIPT} ${bin} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/script/${bin} ${STAGEDIR}${PREFIX}/bin
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in Copyright dbs.man dbs.man.jis dbs_paper.ps
- cd ${WRKSRC}/doc; ${INSTALL_DATA} ${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for ex in TCP2.cmd TCPvsMPEG.cmd
- cd ${WRKSRC}/sample; ${INSTALL_DATA} ${ex} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${ex} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif
.include <bsd.port.mk>