aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-01-08 03:48:30 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-01-08 03:48:30 +0000
commit46bd50407d900505c0151ad816f5c5f78b8ff18e (patch)
tree61642833de694337faa093697186e6c74063df60 /benchmarks
parent27cfa353f700c9f3cdf9b0ddce9f336e99deec19 (diff)
downloadports-46bd50407d900505c0151ad816f5c5f78b8ff18e.tar.gz
ports-46bd50407d900505c0151ad816f5c5f78b8ff18e.zip
Add p5-Benchmark-Forking 0.99, run benchmarks in separate processes.
PR: ports/107593 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=181743
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/p5-Benchmark-Forking/Makefile22
-rw-r--r--benchmarks/p5-Benchmark-Forking/distinfo3
-rw-r--r--benchmarks/p5-Benchmark-Forking/pkg-descr14
-rw-r--r--benchmarks/p5-Benchmark-Forking/pkg-plist8
5 files changed, 48 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index adbed5f87e25..2993ffc7db84 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -30,6 +30,7 @@
SUBDIR += netpipe
SUBDIR += nqueens
SUBDIR += nttcp
+ SUBDIR += p5-Benchmark-Forking
SUBDIR += p5-Benchmark-Stopwatch
SUBDIR += pathchirp
SUBDIR += pathload
diff --git a/benchmarks/p5-Benchmark-Forking/Makefile b/benchmarks/p5-Benchmark-Forking/Makefile
new file mode 100644
index 000000000000..d8193a1e0d3b
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Forking/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Benchmark-Forking
+# Date created: 2007-01-06
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Benchmark-Forking
+PORTVERSION= 0.99
+CATEGORIES= benchmarks perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Benchmark
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Run benchmarks in separate processes
+
+PERL_CONFIGURE= yes
+
+MAN3= Benchmark::Forking.3 Benchmark::Forking::ReadMe.3
+
+.include <bsd.port.mk>
diff --git a/benchmarks/p5-Benchmark-Forking/distinfo b/benchmarks/p5-Benchmark-Forking/distinfo
new file mode 100644
index 000000000000..577b8b2fe137
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Forking/distinfo
@@ -0,0 +1,3 @@
+MD5 (Benchmark-Forking-0.99.tar.gz) = e7174e746c2b2e02c24939b248230f96
+SHA256 (Benchmark-Forking-0.99.tar.gz) = 332c54ea8c08d75df012204caf45878878b84b957a35e00eda7e8e328b09e966
+SIZE (Benchmark-Forking-0.99.tar.gz) = 6182
diff --git a/benchmarks/p5-Benchmark-Forking/pkg-descr b/benchmarks/p5-Benchmark-Forking/pkg-descr
new file mode 100644
index 000000000000..61bcb40ed0c7
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Forking/pkg-descr
@@ -0,0 +1,14 @@
+The Benchmark::Forking module changes the behavior of the standard
+Benchmark module, running each piece of code to be timed in a separate
+forked process. Because each child exits after running its timing loop,
+the computations it performs can't propogate back to affect subsequent
+test cases.
+
+This can make benchmark comparisons more accurate, because the
+separate test cases are mostly isolated from side-effects caused by
+the others. Benchmark scripts typically don't depend on those
+side-effects, so in most cases you can simply use or require this
+module at the top of your existing code without having to change
+anything else.
+
+WWW: http://search.cpan.org/dist/Benchmark-Forking/
diff --git a/benchmarks/p5-Benchmark-Forking/pkg-plist b/benchmarks/p5-Benchmark-Forking/pkg-plist
new file mode 100644
index 000000000000..2a037c30ff89
--- /dev/null
+++ b/benchmarks/p5-Benchmark-Forking/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Benchmark/Forking/.packlist
+%%SITE_PERL%%/Benchmark/Forking.pm
+%%SITE_PERL%%/Benchmark/Forking/ReadMe.pod
+@dirrmtry %%SITE_PERL%%/Benchmark/Forking
+@dirrmtry %%SITE_PERL%%/Benchmark
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Benchmark/Forking
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Benchmark