aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-08-05 15:04:01 +0000
committerJohn Marino <marino@FreeBSD.org>2016-08-05 15:04:01 +0000
commit897f196f6512f32606571cab344234ff38fbb5c3 (patch)
tree21657622d5e168e12227f23c52f23a8aa1c4b152 /benchmarks
parent668f997b4a8e48dddaad1a3353b340f5a94df2cd (diff)
downloadports-897f196f6512f32606571cab344234ff38fbb5c3.tar.gz
ports-897f196f6512f32606571cab344234ff38fbb5c3.zip
benchmarks/clpeak: set USE_GL rather than hardcoding LIB_DEPENDS
The proper way to handle libGL is to set USE_GL=gl, and doing so allows dependency registration to match the port Approved by: infrastructure blanket (redundant deps work)
Notes
Notes: svn path=/head/; revision=419690
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/clpeak/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/benchmarks/clpeak/Makefile b/benchmarks/clpeak/Makefile
index 165af0a717dd..b05200823a35 100644
--- a/benchmarks/clpeak/Makefile
+++ b/benchmarks/clpeak/Makefile
@@ -3,6 +3,7 @@
PORTNAME= clpeak
PORTVERSION= 1.0
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= benchmarks
@@ -13,8 +14,7 @@ LICENSE= PD
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= opencl>=0:devel/opencl
-LIB_DEPENDS= libOpenCL.so:devel/ocl-icd \
- libGL.so:graphics/libGL
+LIB_DEPENDS= libOpenCL.so:devel/ocl-icd
RUN_DEPENDS= opencl>=0:devel/opencl
BROKEN_FreeBSD_9= clpeak is only supported on FreeBSD 10.1 and newer
@@ -26,6 +26,7 @@ GH_ACCOUNT= krrishnarraj
GH_PROJECT= clpeak
USE_LDCONFIG= yes
+USE_GL= gl
USES= cmake
CXXFLAGS+= -std=c++11